Boot to Windows not working after renaming efi to fix grub issue

Originally I had the same issue as described in this thread: Grub not booting unless i manually boot it from live CD

Grub would not load on my Lenovo Yoga Pro 3 laptop.

As suggested in the above thread, I followed the "drastic" solution by renaming the Manjaro EFI file as the windows EFI file. This in fact solved my issue where Grub would not load. YAY!!

Now my issue is that Windows 10 will not load when I select it in the Grub.

I have followed the suggested steps:

sudo touch /boot/grub/custom.cfg

Then edited the file like this:

menuentry "Windows New directory" {
        insmod part_gpt
        insmod fat
        insmod chain
        search --no-floppy --fs-uuid --set=3A21-0848
        chainloader /EFI/Microsoft/bootmgfw.efi

Then I reboot. I see an option in Grub for "Windows New Directory". When I select it, I get this:

error: no such device 3A21-0848
error: file '/EFI/Microsoft/bootmgfw.efi' not found.
press any key to continue


Wahhh! I hope you backed that "bootmgfw.efi" up. Try to change it back and get windows running again first by booting into manjaro and make the changes in


restore bootmgfw.efi in Microsoft directory
then make sure windows boots again.

Maybe you have to go throu the recovery procedure. In that case you could lose your Manjaro installation. If you just installed Manjaro that might be not the worst case.
After fresh install of manjaro do this

Thanks for the reply. I believe a backup was in fact made, as I followed these steps outlined in the linked post:

sudo cp /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi /boot/efi/EFI/Microsoft/bootmgfw.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

So I guess I can take the original file and move it back to the /boot/efi/EFI/Microsoft/Boot folder

But I'd like to wait for a bit to see if there are any other suggesetions.


First double-check this is the correct value, since if the partition was not found, how could win-boot loader be found..
Don't do the copy-back yet, you may not need to.
Did you enter UUID or PARTUUID in that entry?

Edit: I 've just seen you entered the UUID from the linked post. You have to enter YOUR /boot/efi PARTION UUID
Check with lsblk your partition /dev/sdsomething and with blkid its UUID.


Wonderful! I stepped out for dinner but will try when I get home. You're right, I just copy pasted, so hopefully that will fix it.

1 Like

Yes, it worked! I am now able to successfully boot Windows 10 or Manjaro. The issue was the incorrect UUID.

Thank you, and happy Summer Solstice :slight_smile:

1 Like

@petsam.. great job!
Looking forward to my retirement :laughing:


Hell, what a catch :smile:

So in this setup if I want to remove dual boot, how is that done?



BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,2001,0001,2002,2003
Boot0000* EFI USB Device (SanDisk)
Boot0001* Lenovo Recovery System
Boot0002* Windows Boot Manager
Boot2001* EFI USB Device
Boot2003* EFI Network

I believe the re-naming we did above has Boot0002 booting grub / Manjaro, correct? But then... how to get it all back?

See the first post here.. Then do completely all the steps including the [Additional UEFI commands] in step 6.

If you still have problems after reboot (very possible), see Lenovo link listed in the "Difficult UEFI setup" section. When doing this, careful that you copy (not remove) the windows efi file and do the custom.cfg for it (if you still want windows). If you don't do this, you cannot "get it all back" (except reinstalling windows boot and redoing the whole process). That is, if I understood your meaning of "get it all back" .

1 Like

To clarify "get it all back", I'm trying to remove dual boot and remove Manjaro and go back to Windows only on this PC.

I was thinking the easiest way would be to remove the custom config file so it once again boots to Windows only. Then use Windows to delete the Manjaro partitions. Thoughts on that approach?

If, and check that if, you have done all steps outlined, at manjaro, remove the 'fake' windows efi, move back the real windows efi to the Microsoft directory and that's it.

Remove manjaro directory in /boot/efi for housekeeping.
Remove (format) manjaro partition later on for housekeeping as well.

Removing windows entry in manjaro custom.cfg will not do. It just make windows unbootable instead.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by