Booting in to USB

Hi,

(Am a linux noob and a software engineer and my daily driver is manjaro)

I wanted to install manjaro on one of my old 15 year old acer laptops and in this effort I did successfully endup installing manjaro with i3 on it. I was meant to be dual boot. But after the installation I am not able to see windows in the grub and also am not able to get in to bios (f2 or anything other key wont let me in). I read a lot of posts on how to get in to bios and get windows in to the grub and all that. But now, I dont care much about windows or the grub. I can get in to the already installed manjaro.

Now I want to wipe out the complete machine and install manjaro on it 100% no dual boot no windows (windows 10 is useless on that machine)

In this context I wanted to know if I can boot in to a bootable usb from within manjaro. A command or something? I tried systemctl reboot --firmware-setup and it does not work. It says firmware does not support boot in to firmware.

So my only requirement is to be able to run some command from my existing manjaro so that I boot in to a USB stick which has manjaro in it and then wipe out the complete system and install majaro in it completely.

Any ideas?

thanks,
Yadhu

Anyone?

Hello :slightly_smiling_face:!
Firstely, if you are unable to get into a BIOS/UEFI something in you bios settings / firmware is majorly wrong and I would highly recommend trying to solve that first. A UEFI/BIOS reset might be required. Have you tried all common key combos like Esc, F2, Del and stuff like that yet? If yes, you might need to open up your laptop to remove the CMOS battery or find a CMOS reset buttoon/switch you can press.
Asides that, make sure to back up all your important data to an external drive, or it might get lost.

Thanks for the reply @DarkWav. Fortunately I dont have any data whatsoever. That laptop is my playground.

Few things.

  1. I have tried the key combos none of them works. Escape takes me to advanced options for the existing manjaro installation but that does not help.
  2. Can you tell me how I can reset a BIOS without actually getting in to the bios? Read something on it but could not figure out/understand...
  3. CMOS battery... ooooo sounds interesting and full of adventure... have never done that... let me try....

For now, can you tell me more about how I can reset my bios... by the way.... one thing I forgot to mention... While I still could reach windows, I could reboot in troubleshooting mode and reach bios actually.... Now I am not able to reach windows since it is not in my boot options... So if you can let me know how I can add windows to my boot option when manjaro starts up, even that could solve the problem.... I am so novice in all of this that I am not even sure which document to look in to... So would be great even if you can point me to the right manual and I will read it up and add windows to the boot options which might help me reach bios eventually.....

Let me know what you think.

Cheers!

Well, if you cannot get into the BIOS through pressing keys/software you will most likely need to open up the laptop and remove the CMOS battery.
By the way, was booting into BIOS possible before installing Manjaro?
For modifying Manjaro to detect Win10 on boot, there is a possibility.
You will need to edit the file

/etc/default/grub

as root. In this file, there should be the line

GRUB_TIMEOUT_STYLE=hidden

You need to change it so it is

GRUB_TIMEOUT_STYLE=menu

Additionally, add the following line to the file:

GRUB_DISABLE_OS_PROBER=false

After this, you need to update your bootloader, run

sudo update-grub

After this finished, try to reboot and check if a menu from which you can choose windows 10 pops up. Beware, that menu only shows for like 5 seconds if you don't press the arrow keys in time!

Thanks a million @DarkWav This is very helpful. I will try it out tonight and let you know.

Yes and No. Before installing manjaro, I could reach bios via restarting windows in troubleshooting mode but not using the keys.

After installing manjaro, the windows option disappeared from the menu so could not even do that.

But the instructions, you have given and very helpful, I will try it and let you know tonight....

Thanks again.

To me this sounds like BIOS. Maybe you have entered Bios without realising it?
What laptop model is it?

Nopes its the boot menu of manjaro....

Acer aspire v5

@DarkWav and @TheApologist - I am very sorry I have not been able to try it. Have been working on shipping a project for the past 3 days... Should be done by tomorrow... The moment i am done, I will get to this and let you guys know.

1 Like

Still not done with the project release... Should be done in a few days... Once done I will try this and update you.... Very sorry for the delay....

Hi... Finally got my hands on this.... Tried this... the grub did come up but there was no windows in it.... Will try to add windows there....

Any ideas in the meanwhile??

Looks like there are 100s of posts on this... Will look them up and get back to you....

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by