Booting install usb gives the word "GRUB" and otherwise black screen

I've been trying since yesterday to install Manjaro on an old laptop using a Live install USB stick. The screen shows the usual BIOS / HP screen and then it apparently tries to boot the USB. All that happens is the word "GRUB" appears at top left of the screen and then nothing. The USB stick shows no flashing light, indicating no transfer activity. I never see the initial Manjaro screen.

A few more bits of info: I've taken the same Manjaro USB installer, and booted it without problems on an even older laptop (which has far too little RAM to use). So there doesn't seem to be anything particularly wrong with the Manjaro USB installer. Second, I ran an Ubuntu USB installer on the laptop that won't boot the Manjaro USB. After retrying a couple times, it eventually loaded Ubuntu Live (I've tried to load Manjaro a couple dozen times at least). Third, the antique BIOS on this (Insyde F.1C I believe, on a HP Pavilion laptop) does not have any UEFI or EFI options nor a Secure Boot option. There's a place to set a boot password, but it is unset. Finally, once I see the word GRUB, the system seems inert--ESC and ctrl-alt-F2 have no effect.

I'm guessing the problem is the BIOS just doesn't do well w/ USB boot-ups and in particular whatever is in Manjaro. If anyone has thoughts on other things I might try, let me know.

Joel

Oh, and of course I checked the SHA1 hash for my downloaded ISO.

how have you created USB iso ?

Thanks Stephane: I used two different methods of burning the iso to USB:

sudo dd if=/path/to/iso/.iso of=/dev/sdb bs=4M;sync status=progress

And I used Gnomes disks program (gnome-disks), which has an option to burn an iso to a device.

Both yield exactly the same result. The gnome-disks version is the one I tried on an older laptop than the one I wanted to install on. It had no problem getting to the Manjaro configuration screen.

if you have a port USB 3.0 try with the USB iso

Thanks again Stephane. I have tried every usb port on the laptop with the same result, and one of the ports (unmarked) is supposed to be USB 3 compatible. However, I had changed a BIOS setting that fixed the graphics card to Intel before trying all 4 ports and it occurred to me that the dynamic setting might make a difference. I haven't tried all 4 ports with the dynamic setting. Will do when I get a chance.

What ISO file exactly have you used?

Hi Wollie: I used manjaro-xfce-20.0.3-200606-linux56.iso

Is it a 64bit processor? Any chance to provide something like inxi output when booting the Ubuntu stick? I fear you need an ISO with an older kernel, we would need to know more about your hardware.

I have Ubuntu already installed on the laptop. Output from inxi is below:

inxi -Fxzc0
System: Host: gwHP Kernel: 4.15.0-112-generic x86_64 bits: 64 gcc: 7.5.0
Desktop: KDE Plasma 5.12.9 (Qt 5.9.5) Distro: Ubuntu 18.04.4 LTS
Machine: Device: laptop System: Hewlett-Packard product: HP Pavilion dv6 Notebook PC v: 058D110002204720000622100 serial: N/A
Mobo: Hewlett-Packard model: 17FB v: 10.5A serial: N/A BIOS: Hewlett-Packard v: F.1C date: 01/23/2013
CPU: Quad core Intel Core i7-2720QM (-MT-MCP-) arch: Sandy Bridge rev.7 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17560
clock speeds: max: 3300 MHz 1: 798 MHz 2: 798 MHz 3: 798 MHz 4: 802 MHz 5: 807 MHz 6: 802 MHz
7: 801 MHz 8: 915 MHz
Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
Card-2: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,ati,radeon (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
version: 3.3 Mesa 20.0.8 Direct Render: Yes
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-112-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 07:00.0
IF: eno1 state: down mac:
Card-2: Intel Centrino Wireless-N + WiMAX 6150 driver: iwlwifi bus-ID: 0d:00.0
IF: wlo1 state: up mac:
Drives: HDD Total Size: 750.2GB (41.5% used)
ID-1: /dev/sda model: Hitachi_HTS72757 size: 750.2GB temp: 0C
Partition: ID-1: / size: 96G used: 20G (22%) fs: ext4 dev: /dev/sda8
ID-2: /boot size: 493M used: 142M (32%) fs: ext4 dev: /dev/sda7
ID-3: /home size: 424G used: 248G (62%) fs: ext4 dev: /dev/sda6
ID-4: swap-1 size: 24.90GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 58.0C mobo: N/A gpu: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 400 Uptime: 3:37 Memory: 4820.6/11953.7MB Init: systemd runlevel: 5 Gcc sys: 7.5.0
Client: Shell (bash 4.4.201) inxi: 2.3.56

Ubuntu uses a much older kernel, that's probably the reason it's working.

I don't know if it is possible to update from it but I would try the last version with 4.19 kernel:

At least, you can check if this kernel can be booted with the live stick.

When you want to give this ISO a try for installation I would recommend you to ask here for expert advice before updating.

Probably you will need the following before updating:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod a+x ./pacman-static
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo ./pacman-static -Syyu pacman --overwrite "*"

Thanks Wollie for all the info!

I was under the impression that the Manjaro installation first screen (configuration), the one I can't get to, appears before the kernel is used. I tried running the USB install stick in VirtualBox that for some reason had decided only to give me 32-bit options, so I chose the Arch 32-bit architecture and tried to install. I got to the installation screen just fine. However, it indicated that there was no appropriate kernel for the install (because the kernel is 64-bit).

I tried all 4 USB ports with what I believe are good BIOS settings (most permissive). No luck.

  1. Have you tried updating the bios?
  2. Have you tried resetting bios to defaults?
  3. Technically you could use grub from Ubuntu to load Manjaro assuming you had 2 usb sticks and could pull up the grub prompt. See ISO booting with grub
  4. I feel like this issue might be a secure boot issue. Sometimes setting a admin password lets you turn it off.

Thanks SlayerProof32: The idea of ISO booting w/ grub sounds like a terrific one. Was wondering if that was possible. Will have to take note of it. BIOS is as updated as it goes, at least according to HP website. Could try the other possibilities but I found a solution (see my next msg).

Thanks again everyone for all your thoughts and your time! I tried burning the live image to DVD and that booted without issue. I was able to install Manjaro. This laptop seems to be rather touchy about booting from USB (though Ubuntu was able to do so after a couple tries).

2 Likes

I have had a similar issue on booting Manjaro (including Live System from USB) on my Dell laptop when connected to the docking station.
In my case it helped to delete the option "quiet" out of the GRUB entry. You will loose the nice graphic mode boot logo and be presented with scrolling texts of starting processes. But it worked for me.

--> You can edit the boot parameters of the USB Stick from within GRUB and see if it works. This will work "one time".
--> After installation, also install a GRUB editor and kick out "quiet" permanently.

Good luck,
SuAlfons

I forgot you could install OSes via DVD😂. Hope you enjoy Manjaro!!

Thanks, I didn't know there was such a thing as a GRUB editor--should be very handy. I've done things the hard way before, editing some crazy involved coding files with nano.

Thanks!

Forum kindly sponsored by