Booting into grub prompt after a fresh Manjaro install into a pre-existing dual boot setup

Installed Manjaro on a system that had a pre-existing dual boot setup of Ubuntu and Windows 10. I overwrote the existing Ubuntu system with Manjaro by following the instructions given in this forum post. The installation finished successfully, however, the system now boots directly into grub prompt.

After exiting the grub prompt (by typing exit and hitting enter), I get the following option:

If I choose Manjaro, I get the intended Manjaro-based grub screen and everything works fine from there on. So, the boot manager seems to be ordered incorrectly.

This is the output of efibootmgr in terminal:

Screenshot_20200803_001711

I think if Manjaro were the top entry in the bootloader, my problem would be solved. I just can't figure out how to make it the top entry. Please advice.

Enter

sudo efibootmgr -o 0003,0001,0004,2001,0000,2002,2003
sudo update-grub

and reboot.

Go into your firmware/bios settings, find your way to boot devices or some such and move Manjaro to the top of the list. Save the settings and reboot.

Edit: Or go with @Wollie's suggestion :innocent:

This is the output I get after a sudo update-grub:

[kakarot@kakarot-predatorph31552 ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.6-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.6-x86_64.img
Found initrd fallback image: /boot/initramfs-5.6-x86_64-fallback.img
Found Windows Boot Manager on /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme1n1.
done

Executing efibootmgr I get:

[kakarot@kakarot-predatorph31552 ~]$ efibootmgr 
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0001,0004,2001,0000,2002,2003
Boot0000* HDD0: Samsung SSD 970 EVO Plus 500GB
Boot0001* ubuntu
Boot0003* Manjaro
Boot0004* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

Everything seems in order, but after rebooting I am still going in the grub prompt. When I relogin, I can see that the entries for efibootmgr are back to the old values:

[kakarot@kakarot-predatorph31552 ~]$ efibootmgr 
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0001,0004,0003,2001,0000,2002,2003
Boot0000* HDD0: Samsung SSD 970 EVO Plus 500GB
Boot0001* ubuntu
Boot0003* Manjaro
Boot0004* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

Suggestions? Should I try removing Ubuntu's entry?

Edit: I have deleted that entry. Wish me luck! This might be the end! :frowning:

Edit2: Wow! This is one Hoodini level OS! I deleted the entry for Ubuntu, updated grub. Rechecked the output of efibootmgr to confirm (there was no entry for Ubuntu). Rebooted and BAAM! It handed into the grub-prompt. Exited and logged into Manjaro and there it is back again!

[kakarot@kakarot-predatorph31552 ~]$ sudo efibootmgr 
[sudo] password for kakarot: 
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0001,0004,0003,2001,0000,2002,2003
Boot0000* HDD0: Samsung SSD 970 EVO Plus 500GB
Boot0001* ubuntu
Boot0003* Manjaro
Boot0004* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

Seems like I have messed things up badly. I can't seem to get into the BIOS menu. I own an Acer Preditor Helios 300. Upon checking the internet, it seems that pressing F2 gets me into BIOS. But now, it leads me to an empty blank screen and done! It just stays there. Empty blank screen!

Have you unknowingly Safe boot enabled in the firmware? Could it be that you have left Windows last time with a hibernation status and not fully shut down? All this could prevent you from required boot system changes.

And don't forget to try @Marte's suggestion as soon as you found a way back into your firmware.

1 Like

Forum kindly sponsored by