Booting multiple OSs from multiple EFI paritions and Restoring Windows and Manjaro Boot after losing EFI Partition

@SlayerProof32 Thanks for the suggestion, I'll take a look at that.

@gohlip As far as creating a second EFI parition, I just created a partition and formatted it FAT32, is there anything else I need to do?

No. At your MacOS installation, just choose this new partition as the EFI partition for it.


It seems your topic turned a little bit. You might want to modify the title and tags, to show it is about MacOS multi-boot.

1 Like

Ok, so, some bad news.

While trying to install Mojave, I formatted an empty FAT32 partition as HFS+ using the installer's Disk Utility. I exited the installer, but after doing so, I am now unable to boot my existing Windows 10 or Linux distros. They do not appear in Clover and I cannot reach grub. In addition nothing appears in my boot menu in BIOS except when a USB is plugged in.

When I relaunched the installer from the USB, I can see my other OSs and partitions in disk utility. So I suspect (and hope) they are still in tact. I believe something may have happened to my EFI partition which I have a backup of that I created with dd.

I tried to use a bootable USB with Manjaro on it, but when I attempt to boot it, it says "unknown filesystem" and leaves me at a 'grub rescue' prompt.

My new goal is to be able to boot into Windows and Manjaro to make backups which I admittedly should have done earlier.

Any ideas?

Let me translate that:
"How do i properly install hackintosh on a triple boot scenario?"
And for the THIRD time, this is not a forum for hackintosh installations!

You might be able to recover your data booting from Manjaro live media, but a proper one, done with Rufus in DD mode or done with Etcher; or maybe you can resurrect/repair the Windows installation. You practically screwed your partition table. Mojave uses the APFS (apple file system) and will not allow even a Boot Camp partition alongside, when you create a volume with Disk Utility will put it's signature on the entire drive. Why? Because of the full disk encryption feature and because converts HFS+ drives to APFS without warning.


Try to use this first post and at [Simple First Start], get back your manjaro bootloader.

But unless as @bogdancovaciu says, Apple converts the whole drive to its file system.

1 Like

Hmm, but like I said, I cannot even reach grub, as soon as I boot the USB, I get 'unkown filesystem' and a 'grub_rescue' prompt.

@bogdancovaciu I've heard of that and it could be the case, but I don't believe that it would have been converted yet.

Disk Utility wrote on that HDD information, and it does it at the begging of the drive whatever is GPT or MBR ...

1 Like

As soon as you boot the usb or after you get to the usb boot menu and after going to the grub prompt, then only when you tried to search.file... ?
The usb is the install media and not affected by Apple. Please be clear.

1 Like

It is as soon as I boot the USB, I cannot reach any menu.

It is as soon as I boot the USB, I cannot reach any menu.

That is .... {no words to say}

Anyway, can't you boot any liveusb and use whatever, gparted or file manager or whatever to check your internal drive?

Are you saying your computer cannot boot anything, even an external Apple-untouched usb?

1 Like

That's what I was hoping to do. I'm not sure why I can't boot the live usb.

Check the bios setup (F2 or whatever)

1 Like

Download Hirens BootCD and try with it to recover at least the data.
Probably when you booted the Mojave installer you also had a CMOS reset, and most of the BIOS settings you did previously are gone ...

1 Like

@gohlip no luck there, I'll try to post a video later

@bogdancovaciu okay thanks, I'll give that a try in a bit

Ok, update: I was able to boot up the live USB. I calculated and confirmed the checksum and recreated the USB, now it works.

Even better news, all of my partitions seem to be intact and I can mount them and see the files, etc.. It looks like the drive wasn't put in an APFS container, but that the EFI partition was destroyed as I had originally suspected.


Should I restore the image of the EFI partition that I had created with dd (I created the image in Manjaro, not from a Live CD, not sure if that's okay)? Or should I boot a windows image and create the EFI parition in windows and then let Manjaro add itself after that?

See post 20. Do it. But first..
Create back sda1 in format fat32.
Change uuid in fstab for it /boot/efi
Then do post 20.

Are they not on separate partitions?
The $esp's (EFI)?
Provide parted -l when solution done.


Here is the result

The EFI partition is gone, so it couldn't install grub there I think.

What's not on separate partitions?

Made edit in previous post. See it.
Apple destroyed your $esp on a sepaerate partition? Bad apple.

Ps: morning not my good time.


When doing post 20, after recreating $esp (sda1) and fixing fstab, do the more compliated setup, not the simple first start.
Need probe -u... command, and manually put in the kernels, etc...

Good luck.


Forum kindly sponsored by