Booting stuck with an "error: hibernation device not found" text

Yes, there is another kernel, but I'll be honest, I don't know how to do it from the terminal. Moreover, I cannot get access to my terminal, because whenever I get into the boot option (by pressing e, in the grub menu and then put a 3 at the end of the line which starts with "linux" ) it didn't boot to the terminal, I just get the same message as before.

in the grub menu there should be an option for advanced. all your kernels should be listed there to choose from.

1 Like

Ohh yes, I found them. I have these installed: IMG_20180619_191838
The last one is a 3.10.107-1 fallback initramfs

What causes you to this statement 4.9 is Bugi

The messages here are the result of changing the partition, but the / etc / fstab contains the old information.

Weche UUID belongs to which partition

ls -la /dev/disk/by-partuuid/
ls -la /dev/disk/by-uuid

This is the way to change / etc / fstab

try the third one down. if you get in, do a full update. this will replace your buggy 4.9 with a fixed one. also, while it is a good idea to have a backup kernel, 3.10 is not supported any more. i suggest you install 4.4 as a backup. not only is that an lts release, it'll be supported for even longer than 4.9 is.

the 4.9 bugginess is all the module errors, not the hibernation error. both bugs will need to be fixed or worked around for para to boot.

But that was fixed 10 days ago

Or it returned ?
Probably the OP didn't make the fix update ...

1 Like

Well I tried the third one to get into the system somehow, but my booting process just stops at this point
And there was another "failed" message which said, "Failed to load system kernel modules".

do you have a live environment you can boot and then chroot into your install to do a system update?

1 Like

Yes, I'm doing it right now.

Yes, It was my fault, I couldn't solve it since then because of my exams. :frowning:


Well, hope you passed well the exams, are quite important as i recall, and a linux box can be fixed any time.

Alright. I did a full upgrade, with chroot, but it generated another problem. When I try to boot the system with the 4.9 kernel, it sticks in the booting process and shows only a blinking cursor, but before that, it also says "failed to load kernel module". With the old 3.10 kernel, nothing changed.

Yes, my exams went well, thank you :slight_smile:

can you install 4.4 and try that? i don't think 3.10 will work any more, it hasn't been supported for a while.

i'm really surprised, though. doing an upgrade for the installed 4.9 should have fixed the module loading errors, though i wasn't expecting that to be the whole solution. you may need more knowledgeable help than me.

There is a huge chance that I do something wrong because when I open the chroot and type "sudo mhwd-kernel -i linux44" it says "error: no targets specified" however, it should be good. I did everything as instructed. Booted a live environment, in the terminal I downloaded the mhwd-chroot, and then just started it by typing "sudo mhwd-chroot".

hmm. i see a thread from last year that new kernels can't be reinsintalled with chroot. not your fault.

if you have the previous 4.9 version in your cache, you can install that

pacman -U /var/cache/pacman/pkg/linux49-4.9.105-1-x86_64.pkg.tar.xz

(make sure that filename matches the next most recent version in your cache)

Unfortunately, I didn't solve the issue. I reinstalled the kernel but it is still stuck after tlp system startup/shutdown. :frowning: I tried to solve the problem according to this thread HowTo - Restore an unbootable system after an interrupted kernel update, Although, I run mkinitcpio -P and update-grub in mhwd-chroot, but it didn't solve the issue either.

A little update, somehow I managed to ruin my grub loader, so the only thing I get is that "Manjaro minimal bash-like line editing is supported.... etc." So I try to save my data via mhwd and I'll reinstall my OS. I didn't find a better solution to this problem. If you have pls let me know. I only have an 8gb pendrive so it will take a while. :smiley:

If you haven't reinstalled....
See this first , it may help getting back your grub.
But it does not help in your 'other issues ' (hibernation? O really?). Note.

Forum kindly sponsored by