Bootloader does not install with dual boot

Hello I am somewhat familiar with linux, but I only used computers from school. I decided I wanted to install one on my own computer and decided Manjaro will be a good choice.

I followed this guide to dual boot with windows ([HowTo] Dual-boot Manjaro - Windows 10 - Step by Step) and found no issues until it said that it cannot find EFI directory for the grub-install.

I originally did the automatic partitioning as I figured it would work fine and I didn't really understand the differences between having the root and home partitions separate, but the grub-install failed so I figured to have another go at it doing the manual way. This still yielded the error message of not getting the bootloader and so I am stuck again.

I am using a DVD-RW to install all of this and I am currently in the installer.

I do not have the pictures of the error messages from the bootloader initially failing, but when trying just grub-install I get:

$ grub-install
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

I found that many posts list the lsblk -f however I am not sure how to decipher this and when people describe how to fix the issue they use this as I understand. I tried figuring it out, but I am just not sure. I was looking at this (Grub install fails with "grub-install: error: cannot find EFI directory.") but couldn't figure it to my situation.
$ lsblk -f
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
loop0
squash 4.0 0 100% /run/miso/
loop1
squash 4.0 0 100% /run/miso/
loop2
squash 4.0 0 100% /run/miso/
loop3
squash 4.0 0 100% /run/miso/
sda
├─sda1
│ vfat FAT32 C21F-B813
├─sda2

├─sda3

├─sda4
│ ntfs 01D4346CB2A8DB70 248.1G 82% /run/media
├─sda5
│ ntfs 485C9BF45C9BDB50
└─sda6
ntfs EE4092D64092A53D
sr0 iso966 Jolie MANJARO_XFCE_1902
2020-03-11-14-41-29-00 0 100% /run/miso/
nvme0n1

├─nvme0n1p1
│ ntfs System Reserved
│ 94B0657CB06565A8
├─nvme0n1p2
│ ntfs EA88665488661F77
├─nvme0n1p3

├─nvme0n1p5
│ vfat FAT32 1433-D470 510.9M 0% /tmp/calam
├─nvme0n1p6
│ swap 1 25420d43-73a7-4c6b-83c3-a5a82911e587
├─nvme0n1p7
│ ext4 1.0 912e83a9-d943-489b-8f3c-87b33672e782 12.4G 32% /tmp/calam
└─nvme0n1p8
ext4 1.0 e13d1c3d-0cca-4542-9f58-71c840c5cf0b 160.4G 0% /tmp/calam

What do I do next? I can provide whatever else is required.

Thanks :slight_smile: !

Here is the error I got:
image

Have you disabled secure boot in firmare?
Has Fastboot switched off in Windows?

If possible show us output of terminal command

sudo parted -l

Yes I did both of those things as they were listed in the guide I was following. I haven't restarted since I installed Manjaro so I don't see how windows could effect anything.

Windows fastboot affects things out of windows:

When you shut down a computer with Fast Startup enabled, Windows locks down the Windows hard disk. You won’t be able to access it from other operating systems if you have your computer configured to dual-boot. Even worse, if you boot into another OS and then access or change anything on the hard disk (or partition) that the hibernating Windows installation uses, it can cause corruption. If you’re dual booting, it’s best not to use Fast Startup or Hibernation at all.

Source

In my case: Apparently fastboot from windows 10 was blocking the installer from peeking into EFI partition. Disable it from advanced power options. Disable secure boot. Run the installer again.

1 Like

I have fastboot disabled and secure boot isn't even available on my machine. Windows should not be an issue then right?

image

I can't say for sure, Can you please post a screenshot of your current partitions setup? Seems you can't have the /boot on nvme Grub Install Error Cannot Find EFI Directory

3 am her and I'm too tired but take a look on this link.

Is that a manjaro thing that I can't have /boot on nvme? Windows is obviously fine.

What I find weird is that I set flags according to the guide, but they don't seem to stick correctly when looked at here
image

Read the link I provided. I'm not sure. It says:

Oh, os-prober error " warning: unknown device type nvme0n1." - just that os-prober (and grub) cannot parse nvme partitions, just /dev/sdxy partitions. Nothing to worry about (but yes, they should fix it).

So I will not be able to install this on a nvme? I am not sure what /dev/sdxy partitions are.
I added the error message from the installer to the original post.

It seems your Windows is installed in BIOS with MBR (msdos) parted disk and you tried to install Manjaro in UEFI style, your partition 8 looks like an EFI partition even if this does not makes sense on an msdos parted disk. I would think you should re-install Manjaro using the BIOS method, i.e. selecting the boot entry from your life ISO without EFI in the name. Grub to be installedin MBR in this case.

1 Like

Seems grub cant be on nvme. Put the boot partition out of nvme and the others wherever you want.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by