Boots only to Grub Rescue screen regardless of install settings

[manjaro@manjaro ~]$ inxi -Fxxxza
System:    Host: manjaro Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 misobasedir=manjaro misolabel=MJRO1815 quiet systemd.show_status=1 
           Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: GA-78LMT-S2 v: sex serial: <filter> BIOS: Award v: F6 date: 01/09/2014 
CPU:       Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 2 stepping: N/A 
           microcode: 6000852 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 42203 
           Speed: 1405 MHz min/max: 1400/3500 MHz boost: enabled Core speeds (MHz): 1: 1410 2: 1405 3: 1405 4: 1405 5: 1405 
           6: 1861 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: eVga.com. driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1401 
           Display: x11 server: X.Org 1.20.6 driver: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: NV126 v: 4.3 Mesa 19.3.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: NVIDIA GM206 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fba 
           Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: de00 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.38 TiB used: 668.6 MiB (0.0%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: <unknown> serial: <filter> rev: 3B6Q scheme: MBR 
           ID-2: /dev/sdb vendor: Toshiba model: DT01ACA100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A750 scheme: MBR 
           ID-3: /dev/sdc type: USB vendor: SanDisk model: Cruzer Glide size: 14.32 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
Partition: ID-1: / raw size: N/A size: 5.83 GiB used: 668.6 MiB (11.2%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 36.4 C mobo: N/A gpu: nouveau temp: 55 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 194 Uptime: 15h 55m Memory: 7.77 GiB used: 2.86 GiB (36.8%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.37 
[manjaro@manjaro ~]$ parted -l
[manjaro@manjaro ~]$ cat /etc/fstab
#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/mapper/root-image /             auto      defaults           0      0
[manjaro@manjaro ~]$ lsblk -fs
NAME  FSTYPE   LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0 squashfs                                                            0   100% /run/miso/sfs/livefs
loop1 squashfs                                                            0   100% /run/miso/sfs/mhwdfs
loop2 squashfs                                                            0   100% /run/miso/sfs/desktopfs
loop3 squashfs                                                            0   100% /run/miso/sfs/rootfs
sda1  ext4                     a3bd26c4-0034-4f3c-ae4a-53d37819664c                
└─sda                                                                              
sdb1  ntfs     System Reserved 6CD8294FD82918BA                                    
└─sdb                                                                              
sdb2  ntfs                     109A325A9A323D12                                    
└─sdb                                                                              
sdb3                                                                               
└─sdb                                                                              
sdb5  ext4                     528ab2a3-22e1-41f9-80f4-b867bb1d39b7                
└─sdb                                                                              
sdc1  iso9660  MJRO1815        2019-12-29-08-02-01-00                     0   100% /run/miso/bootmnt
└─sdc iso9660  MJRO1815        2019-12-29-08-02-01-00                              
sdc2  vfat     MISO_EFI        D1C7-AC88                                           
└─sdc iso9660  MJRO1815        2019-12-29-08-02-01-00                              
sr0                                                                                
[manjaro@manjaro ~]$ 

why speed is unknown?

can you check

sudo journalctl -b0 | -g sda

also missing returns

parted -l

When I type parted -l, nothing shows up.. I just copied and pasted the output of it in the other post.
Also, the sudo command you gave for journal, I get a message that '-g command not found'

sudo journalctl -b0 | grep sda

also missing returns

pacman -S parted
parted -l
[manjaro@manjaro ~]$ sudo journalctl -b0 | grep sda
Feb 09 00:20:44 manjaro kernel: sd 0:0:1:0: [sda] 976773168 512-byte logical blocks: (500 GB/466 GiB)
Feb 09 00:20:44 manjaro kernel: sd 0:0:1:0: [sda] Write Protect is off
Feb 09 00:20:44 manjaro kernel: sd 0:0:1:0: [sda] Mode Sense: 00 3a 00 00
Feb 09 00:20:44 manjaro kernel: sd 0:0:1:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Feb 09 00:20:44 manjaro kernel:  sda: sda1
Feb 09 00:20:44 manjaro kernel: sd 0:0:1:0: [sda] supports TCG Opal
Feb 09 00:20:44 manjaro kernel: sd 0:0:1:0: [sda] Attached SCSI disk
[manjaro@manjaro ~]$ 

parted -l still shows nothing, even after installing it

You would need to run it as root:
sudo parted -l

Ah, my bad -- it didnt even prompt me about that. Here is the output:

[manjaro@manjaro ~]$ sudo parted -l
Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary  ext4


Model: ATA TOSHIBA DT01ACA1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type      File system  Flags
 1      1049kB  577MB   576MB  primary   ntfs         boot
 2      577MB   495GB   495GB  primary   ntfs
 3      495GB   1000GB  505GB  extended
 5      495GB   1000GB  505GB  logical   ext4


Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sdc: 15.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2675MB  2679MB  4194kB  primary               esp


[manjaro@manjaro ~]$ 

manjaro do not use LVM on disks with calamares ,no logical partitions on dev/sdb
==>
3 495GB 1000GB 505GB extended

there is also something strange about this
D-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: < unknown >

on which disk manjaro has been installed ?

I installed it on my Samsung SSD 500GB using the whole drive. Normally I never have a problem when I do this using other non-arch distributions. I have a regular HDD that has two different partitions, which have never caused a problem before.. Installing any Arch based distro is the only time I have ran into this problem.

so your boot on USB manjaro ( not your disk )
you should use no-free drivers for nvidia cards

open a terminal

manjaro-chroot -a 
grub-install --recheck --verbose /dev/sda
update-grub
exit( quit chroot )

then reboot

This is what I get:

[manjaro@manjaro ~]$ manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your device.map.
==> Detected systems:
 --> 0) ManjaroLinux
 --> 1) Windows
 --> 2) LinuxMint
==> Select system to mount [0-2] : 

I chose '0', and did the commands you mentioned, rebooted, and still a grub rescue menu.

because sda has no flag boot ,
only sdb
can you add flag boot on sda ?

Not in front of my computer at the moment, do I change that in the BIOS settings? Havent had to do that before.

see this

Tried that solution, still didnt seem to work. I also cant boot into any of my operating systems on either drive, tried a few different methods I found on some other forums as well. When I run a few commands, the drives are recognized as being there and being plugged in, but I cant get to any of them and can only boot from the live USB.

Use this [Kernel Boot Method]. Let us know if you can boot into your installed OS.
Then print out output as stated in [If further help needed] section.

@gohlip p and @stephane, no clue how I managed to finally get this to work seeing that I THOUGHT I tried everything, I installed a fresh manjaro ISO from a USB, when partitioning the disks I changed locations of where I wanted the boot loader installed.. Was all prepared to follow your post (gohilp) and it ended up booting right to the menu where I could choose any OS I had already installed, on either drive.

Not sure why it worked this time, I tried that option before (tried installing it on each drive at one point, neither drive seemed to care and it kept sending me to grub rescue), just did it as a 'what the hell' last resort type thing and it managed to work this time.

Thank you guys so much! I hope I didnt take up too much of your time with this problem, and hopefully anyone else that has this issue can use your guidance to resolve it. Thanks again for being so helpful and patient!

1 Like

That's what worked.

You are on bios-legacy/msdos. What works is now you have set mbr to the right disk.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by