Bootsplash image stretched, then adjusts

I have the packages bootsplash-systemd and bootsplash-theme-manjaro installed. Bootsplash works, but between the grub menu and the login I get a stretched version of the image for a few seconds, then there's a flicker and the properly-sized image appears. I can upload two pictures to show what I mean.

It's purely cosmetic, but I'd love to find out what parameter is causing this. Anyone have an idea?

My inxi output: Dump your "inxi -Fxxxza --no-host" here and bookmark it

Adjust GRUB resolution to your native screen resolution, enable early KMS, pass i915.fastboot=1 as kernel boot parameter. Pray so that it works.

1 Like

Hey Signalrunner,

Thanks for your suggestions! So far I've done this:

  1. /etc/default/grub looks now like this (now the grub menu looks better, I didn't realize it was stretched as well)
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=1366x768x32

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=1366x768x32
  1. /etc/mkinitcpio.conf (your "early KMS" suggestion) has this:

MODULES="i915"

  1. and my /boot/grub/grub.cfg looks like this:
    linux /boot/vmlinuz-4.19-x86_64 root=UUID=cff84aed-a8b1-4e6e-8f84-28c625d59071 rw bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash i915.fastboot=1

RESULT: now instead of being stretched there is the manjaro image for about 1 or 2 seconds which is pulled apart/distorted across the screen before it shows the proper image.

Is there perhaps something I haven't done correctly with what I've changed? It seems I'm close to the desired result though. Now the offending image is displayed for only a few seconds, whereas before it was about 5 or 6.

Thanks again!

You can set gfxpayload as GRUB_GFXPAYLOAD_LINUX=keep to keep the resolution you already set in GFXMODE, but whatever, it should work anyway.

The proper syntax for the modules should be in brackets instead of commas AFAIK, like MODULES=(i915). I don't know if this alternative syntax is also valid, I think it is, but just in case... Did you rebuilt the initram thereafter with sudo mkinitcpio -P ??

Sorry, I don't know what else you could do, I don't have Intel myself and in my current AMD setup I suffered the same thing so... This is a fairly new thing very dependent on the hardware and drivers and won't work smoothly for all setups yet. Maybe take a look at this thread and see if you find something useful:

1 Like

I did do mkinitcpio -P ...

Hmmm, just an update: I can confirm that putting (i915)/"i915" after MODULES did shorten the display time of the glitchy image -- it's not even a second now.

Passing i915.fastboot=1 as a kernel boot parameter seemed to make NO difference at all.

Perhaps a future kernel update could fix it. It's all right, I learned quite a bit by poking around here. Thanks for your help Signalrunner.

If I ever get it working I'll post that here.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by