Bricked my boot (I think)

SO, this one is probably on me.
I WAS going to make a dual boot with Linux Mint KDE, BUT the installer for LM did not want to give me the option to install along side Manjaro. Before I got to the partition section I got a warning that I could carry on and make this UEFI boot (I thik it was UEFI), but that could destroy my current boot. So naturally I pressed cancel on that. HOWEVER after that I could not see my regular boot disk, and LM just wanted to install on another HDD, which I did not want. Unplugging that HDD made LM installer see my SSD boot, but I could not change anything there, even if I did check the manual option. SO in short story, I tried, but with better judgement did not go through it.
NOW my boot is nowhere to be seen in bios, and I am currently running of a USB stick. IS there anyway to reviwe my boot, or is it just cold reinstall of an OS?

Not really in the mood to be installing OS less than a week after I install Manjaro :confused:

Do you see your partitions from the USB stick?

If yes, good news, your Manjaro install still exists. So I will recommend to prepare a second USB stick with Manjaro, and follow those instructions:

You also will find info on the Arch wiki, section "bootloader".

For dual-booting, I strongly recommend to first partition your hard drive using a live usb distro, before going into the installation process. Doing that, you just resize one of your partition to let some free space on your HDD, and then in the installation process, you probably can just ask to install on the free space on your HDD. Grub should be updated automatically if doing so.

If Mint does not give your the option to do that (I would be surprised, but possible), this is a bad sign IMO so I would suggest considering using another ubuntu-based distro (MATE, or Ubuntu directly).

By curiosity: why do you want to install Mint one week after installing Manjaro?

I would think reinstalling grub should fix this. I am not the one to advise you on the procedure as I never multi boot with grub, so I have never borked an install that way. Search the forum to research the proper procedure. Hopefully one of the forum members who are experienced with repairing grub will show up to help you. In the meantime read up on your issue so that you understand better how to resolve this.

Perhaps a simple "sudo update-grub" would fix this, but I tend to think a grub reinstall may be required.

I do see some partitions but only when I am in the process of installing the OS.

Due to some very unusual bugs following my rig.

  1. Libreoffice calc behaviour is weird, see my thread here: Movements in Libreoffice calc different on the OS I am running, compared to Manjaro Beta on VM
  2. Blender will not snap.
  3. Nvidia (nonfree) driver will not work (or activate) even if installed, so rendering takes little more than forever.
    I have noticed those three, and even if small bugs, they really get on my nerve. I know I am running old hardware (GTX 550Ti and Intel i5 2400) but I have not had these problems on other OSes but Manjaro KDE (just KDE).

My thoughts now are that maybe I should move to an OS which worked fine for me until I have newer and better hardware.

can you show output of:
ls /dev/sd*
and fdisk -l /dev/sd[a-where_your_last_manjaro_partition_is] (if you only installed on sda just sda)

also like mentioned above,
chroot and update-grub should be able to restore grub

1 Like

/dev/sda doesn't show any partitions while I am on USB

Why not using this tutorial?

1 Like

did you install manjaro on sda ? if not use correct device (or if you split partitions over multiple hard disks use command shown above [x-z] (x = first, z = last)).

I had boot on sda, anyway I installed LM. It behaved bit nicer with my rig. Will try Manjaro again when I get newer and better hardware :slight_smile:

Is this a fermi nvidia card? If it is:

I wish people would stop using the words "■■■■■" or "■■■■■■■" to describe issues which don't involve making their devices literally act like a ■■■■■. "■■■■■■■" isn't used as a "secret" or "l33t" technical term so people can just stop.

Your "boot" can't be ■■■■■■■. If you thought about it you'd understand why.

It's not actually clear what the issue is. You could try or just "bite the bullet", chalk it up as a learning experience, and reinstall.

As a new Linux user you're going to break things a lot until you get used to how things work. Accept it. Embrace it. Learn.

1 Like

I get the distinct impression the OP is really not interested in spending any time trying to fix the issues he is having with his hardware on Manjaro. He really doesn't seem interested in running Manjaro unless it works OOTB with little effort. That's why many gravitate to the Debian based OS's like Mint. Once it is installed it rarely needs maintenance unlike a rolling release. For some that is just the best option.

7 posts were split to a new topic: How canwe make Manjaro easier for complete newbies?

I agree. While Manjaro is an "easy" arch-based distro, it is still more technical than Mint or Ubuntu. There is absolutely no shame in wanting your system to work OOTB, but maybe Manjaro is not the best distro for that. For instance, I noticed that you still have to setup manually IDLE spin down times for external HDD in Manjaro (on my system at least), sound may need manual intervention too, etc. So a distro like Ubuntu may be best if one wants to avoid those issues. After all, this is why there is so many Linux distro! One does not fit all!

(I was going to erase the following after noticing the split topic, which directly relates to the following thougths! I let them below for the record :slight_smile:)

But on this note, we could raise a general question (maybe answered somewhere already, I just give my live impression there): to which public Manjaro is aimed at? Or said differently: Should Manjaro clearly state that some parts may need a willingness to understand the underlying Linux system (at least poorly like me :slight_smile:) and to have a few (very few) manual interventions?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by