Brightness controls level-bar show up, but they do not change the brightness of the screen

I have freshly installed manjaro.

No brightness level bar was showing up below the volume bar (upper right corner).

Adding
acpi_backlight=video
on
/etc/default/grub,
and brightness controls did show up.

However, changing this brightness level bar has no effect in the actual brightness of the screen.

If I modulate this level brightness bar, I can see
/sys/class/backlight/acpi_video0/actual_brightness
does actually respond, i.e:

highest brightness level:

Screenshot%20from%202019-07-16%2012-17-33

corresponds with:

[david@ZB15G5 ~]$ cat /sys/class/backlight/acpi_video0/actual_brightness 
99

mid brightness:
Screenshot%20from%202019-07-16%2012-19-05

corresponds with:

[david@ZB15G5 ~]$ cat /sys/class/backlight/acpi_video0/actual_brightness 
45

However, the brightness in the screen does not change.

Specs:

[david@ZB15G5 ~]$ inxi -Fxxxz
System:
  Host: ZB15G5 Kernel: 4.19.56-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM 3.32.0 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP ZBook 15 G5 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 842A v: KBC Version 15.37.00 serial: <filter> UEFI: HP 
  v: Q70 Ver. 01.07.00 date: 04/15/2019 
Battery:
  ID-1: BAT0 charge: 71.9 Wh condition: 91.0/91.0 Wh (100%) volts: 17.5/15.4 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Charging 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 53004 
  Speed: 839 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 855 2: 854 
  3: 900 4: 900 5: 848 6: 892 7: 894 8: 892 9: 898 10: 885 11: 899 12: 900 
Graphics:
  Device-1: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Hewlett-Packard 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1cbb 
  Display: x11 server: X.org 1.20.5 driver: nouveau compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: NV137 v: 4.3 Mesa 19.1.1 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k4.19.56-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bb 
  IF: enp0s31f6 state: down mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 41.21 GiB (8.6%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000H1 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: EXA73H1Q 
  scheme: GPT 
Partition:
  ID-1: / size: 464.26 GiB used: 41.21 GiB (8.9%) fs: ext4 
  dev: /dev/nvme0n1p3 
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 47.0 C mobo: 43.0 C gpu: nouveau temp: 39 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 301 Uptime: 11m Memory: 31.27 GiB used: 1.56 GiB (5.0%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 
  running in: gnome-terminal inxi: 3.0.34 

hey, glad to hear you got it up and running. since this laptop has the ability to disable the intel gpu i would assume the brightness control is handled by the gpu. with nvidia drivers it's as simple as adding a brightness control option line. but im not sure about nouveau drivers.

couple questions:
is there a specific reason your using the nouveau drivers?
have you tried using nvidia drivers?

@dglt

Thanks so much for your reply :slight_smile:

No, there is no specific reason. Those specs posted for inxi -Fxxxz are the ones that come out after a fresh manjaro installation...
Just to get things right from the start, how shall we proceed? Thanks

if it were me, i would start by getting rid of the nouveau drivers and install the nvidia ones and go from there. up to you.

post output of mhwd -li

@dglt Ok.

[david@ZB15G5 ~]$  mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

have you run a full update yet since install? you should do that first if you have not.

sudo pacman-mirrors -f8
sudo pacman -Syyu

after thats done, to switch to nvidia drivers:

sudo mhwd -r pci video-linux
sudo mhwd -i pci video-nvidia

if there are any errors, post them here. if everything goes fine, reboot.

@dglt

Yes, I did that.
Nevertheless, I do it now:

david@ZB15G5 ~]$ sudo pacman-mirrors -f8
[sudo] password for david:
::INFO Downloading mirrors from repo.manjaro.org
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  1.483 Turkey         : http://ftp.linux.org.tr/manjaro/
  1.154 Turkey         : ftp://ftp.linux.org.tr/manjaro/
  1.442 Costa_Rica     : https://mirrors.ucr.ac.cr/manjaro/
  ..... South_Korea    : http://mirror.d-tl.com/manjaro/
  ..... Bangladesh     : http://mirror.xeonbd.com/manjaro/
  0.636 Hungary        : https://quantum-mirror.hu/mirrors/pub/manjaro/
  0.537 Hungary        : http://quantum-mirror.hu/mirrors/pub/manjaro/
  1.165 United_Kingdom : http://mirror.catn.com/pub/manjaro/
  1.063 Germany        : https://ftp.halifax.rwth-aachen.de/manjaro/
  0.766 Germany        : ftp://ftp.halifax.rwth-aachen.de/manjaro/
  ..... United_Kingdom : http://repo.manjaro.org.uk/
::INFO Writing mirror list
::Hungary         : https://quantum-mirror.hu/mirrors/pub/manjaro/stable
::Germany         : https://ftp.halifax.rwth-aachen.de/manjaro/stable
::Turkey          : http://ftp.linux.org.tr/manjaro/stable
::United_Kingdom  : http://mirror.catn.com/pub/manjaro/stable
::Costa_Rica      : https://mirrors.ucr.ac.cr/manjaro/stable
::South_Korea     : http://mirror.d-tl.com/manjaro/stable
::United_Kingdom  : http://repo.manjaro.org.uk/stable
::Bangladesh      : http://mirror.xeonbd.com/manjaro/stable
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
[david@ZB15G5 ~]$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                     149,0 KiB   272K/s 00:01 [######################] 100%
 extra                   1759,1 KiB   268K/s 00:07 [######################] 100%
 community                  5,3 MiB   177K/s 00:30 [######################] 100%
 multilib                 183,2 KiB   164K/s 00:01 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do
[david@ZB15G5 ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!
[david@ZB15G5 ~]$ sudo mhwd -r pci video-linux
> Removing video-linux...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-linux/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0380
Processing classid: 0302
checking dependencies...
:: lib32-mesa optionally requires lib32-mesa-vdpau: for accelerated video playback
:: libva optionally requires libva-vdpau-driver: backend for Nvidia and AMD cards
:: mesa optionally requires mesa-vdpau: for accelerated video playback
:: mesa optionally requires libva-mesa-driver: for accelerated video playback
:: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver

Packages (16) lib32-libva-2.4.0-1  lib32-libvdpau-1.2-1  libxvmc-1.0.11-1  lib32-libva-vdpau-driver-0.7.4-6  lib32-mesa-vdpau-19.1.1-1  lib32-vulkan-intel-19.1.1-1  lib32-vulkan-radeon-19.1.1-1  libva-mesa-driver-19.1.1-1  libva-vdpau-driver-0.7.4-4  mesa-vdpau-19.1.1-1  vulkan-intel-19.1.1-1  vulkan-radeon-19.1.1-1  xf86-video-amdgpu-19.0.1-1  xf86-video-ati-1:19.0.1-1  xf86-video-intel-1:2.99.917+863+g6afed33b-1  xf86-video-nouveau-1.0.16-1

Total Removed Size:  43,08 MiB

:: Do you want to remove these packages? [Y/n]
:: Processing package changes...
removing lib32-mesa-vdpau...
removing lib32-libva-vdpau-driver...
removing lib32-libvdpau...
removing lib32-libva...
removing lib32-vulkan-radeon...
removing lib32-vulkan-intel...
removing mesa-vdpau...
removing libva-vdpau-driver...
removing libva-mesa-driver...
removing vulkan-radeon...
removing vulkan-intel...
removing xf86-video-nouveau...
removing xf86-video-intel...
removing libxvmc...
removing xf86-video-amdgpu...
removing xf86-video-ati...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
> Successfully removed video-linux
[david@ZB15G5 ~]$ sudo mhwd -i pci video-nvidia
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: eglexternalplatform will be installed before its nvidia-utils dependency

Packages (5) egl-wayland-1.1.3-1  eglexternalplatform-1.0+3+g7c8f8e2-1  lib32-nvidia-utils-1:430.26-1  linux419-nvidia-1:430.26-5  nvidia-utils-1:430.26-1

Total Download Size:    77,44 MiB
Total Installed Size:  313,85 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
downloading eglexternalplatform-1.0+3+g7c8f8e2-1-any.pkg.tar.xz...
downloading egl-wayland-1.1.3-1-x86_64.pkg.tar.xz...
downloading nvidia-utils-1:430.26-1-x86_64.pkg.tar.xz...
downloading linux419-nvidia-1:430.26-5-x86_64.pkg.tar.xz...
downloading lib32-nvidia-utils-1:430.26-1-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing eglexternalplatform...
installing egl-wayland...
installing nvidia-utils...
==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.
Optional dependencies for nvidia-utils
    gtk2: nvidia-settings [installed]
    xorg-server-devel: nvidia-xconfig
    opencl-nvidia: OpenCL support
installing lib32-nvidia-utils...
Optional dependencies for lib32-nvidia-utils
    lib32-opencl-nvidia
installing linux419-nvidia...
In order to use nvidia module, reboot the system.
:: Running post-transaction hooks...
(1/5) Updating linux419 module dependencies...
(2/5) Reloading system manager configuration...
(3/5) Creating system user accounts...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Updating the desktop file MIME type cache...
xorg configuration file: '/etc/X11/mhwd.d/nvidia.conf'
> Successfully installed video-nvidia

[david@ZB15G5 ~/Dropbox]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI


Warning: No installed USB configs!

After reboot, the brightness control bar is still there in the upper right corner.
The screen brightness does not change when modulating the bar.

post:

cat /etc/X11/mhwd.d/nvidia.conf

@dglt

[david@ZB15G5 ~]$ cat /etc/X11/mhwd.d/nvidia.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 430.26

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

sudo nano /etc/X11/mhwd.d/nvidia.conf

edit this device section to match:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

save/exit and reboot. if brightness control is still not working, replace the acpi_backlight=video parameter you added with acpi_backlight=vendor

1 Like

@dglt

I did this.

Yes, still does not work.

Ok. I did this. It worked. Thank you so much.

1 Like

your welcome, glad it worked out. :+1:

@dglt This is very unexpected...

I have ssh-ed (with -X) to a computer named 'abc', in order to visualize some graphics...

ssh -X -Y username@abc...

After having ssh-ed, this is the error I receive when launching the application:

[david@ZB15G5 ~]$ ssh -X -Y username@abc...
[dcabu@thul ~]$ adfview
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Segmentation fault (core dumped)

I have tried this ssh -X -Y connection to 'abc' from a computer running manjaro as well, that hasn't got a dedicated graphics card... and the application launches normally...

I guess the drivers for this graphics card on this laptop are not fully functioning?

on this i have not the slightest clue, sorry.

@dglt Thank you.
man ssh | grep -m1 -A2 "\-X" yields the meaning of -X:

     -X      Enables X11 forwarding.  This can also be specified on a per-host
             basis in a configuration file.

My thought is that this might be related with the graphics card, since the inxi -Fxxxz yields a relation between the x11 and the graphics card:

[david@david-pc ~]$ inxi -Fxxxz | grep -A5 -m1 "Graphics"
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
  Display: x11 server: X.org 1.20.5 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 

well yeah, of course it does. i think for help on this issue you should really start a new thread since the original issue has been solved already and not many people that are likely to know what it is your trying to do (because i dont). starting a new thread and make it clear of exactly what you want to do. be sure to include at least inxi -Fxxxz and anything else you feel is relevant. sorry but i have zero experience in what your trying to do but im sure someone else does.

@dglt Yes, thanks, I started a new thread: `ssh -X` on laptop with dedicated graphics card, produces `libGL error`

1 Like

Thanks @dglt for the solution, i bookmarked it as i probably will need it often because of my frequent reinstalls!

Forum kindly sponsored by