Brightness is reset to maximum on every start or resume from suspend

Hello, today I 've installed Manjaro Xfce on my old MacBook Pro, I have some little issues. One of them is that brightness is reset to maximum on every start, restart, wake up and log in my session.
I've searched in the forum, I've found some related threads, but they are very old, so I'm not sure if they are still relevant. I.'ve also checked the Arch wiki and Google, but I still have no idea about how to fix it.

That's my inxi:

[albert@MacBookPro ~]$ inxi -Fxz
Host: MacBookPro Kernel: 4.19.14-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux
Type: Laptop System: Apple product: MacBookPro5,5 v: 1.0 serial:
Mobo: Apple model: Mac-F2268AC8 serial: UEFI: Apple
v: MBP55.88Z.00AC.B03.0906151708 date: 06/15/09
ID-1: BAT0 charge: 29.9 Wh condition: 30.2/59.4 Wh (51%)
model: DP bq20z451 status: Charging
Topology: Dual Core model: Intel Core2 Duo P8700 bits: 64 type: MCP
arch: Penryn rev: A L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10086
Speed: 796 MHz min/max: 798/2527 MHz Core speeds (MHz): 1: 1012 2: 1155
Device-1: NVIDIA C79 [GeForce 9400M] vendor: Apple driver: nvidia
v: 340.107 bus ID: 02:00.0
Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 1280x800~60Hz
OpenGL: renderer: GeForce 9400M/integrated/SSE2 v: 3.3.0 NVIDIA 340.107
direct render: Yes
Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel
v: kernel bus ID: 00:08.0
Sound Server: ALSA v: k4.19.14-1-MANJARO
Device-1: NVIDIA MCP79 Ethernet driver: forcedeth v: kernel port: 21e0
bus ID: 00:0a.0
IF: enp0s10 state: down mac:
Device-2: Broadcom and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN
vendor: Apple AirPort Extreme driver: wl v: kernel port: 1000
bus ID: 03:00.0
IF: wlp3s0 state: up mac:
Local Storage: total: 447.13 GiB used: 7.73 GiB (1.7%)
ID-1: /dev/sda model: LONDISK SSD 480GB size: 447.13 GiB
ID-1: / size: 18.21 GiB used: 7.32 GiB (40.2%) fs: ext4 dev: /dev/sda4
ID-2: /home size: 360.71 GiB used: 422.2 MiB (0.1%) fs: ext4
dev: /dev/sda6
System Temperatures: cpu: 62.0 C mobo: N/A gpu: nvidia temp: 63 C
Fan Speeds (RPM): N/A
Processes: 182 Uptime: 13m Memory: 7.54 GiB used: 1.28 GiB (17.0%)
Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28

Regards!! :grinning:

Macbook's often have that problem with Linux.
Try this and read the comments also:

1 Like

Thank you very much for the hint, I am going check it right now.

I dont't have a MacBook anymore but I remember I've had that problem too. If I recall it right I've solved it adding acpi_osi=!Darwin (or was it acpi_osi=Darwin) to GRUB kernel parameters -

It was a couple of years ago but probably is still a valid solution that does not need using AUR.

1 Like

Good point @sandrito !! I'll try it tomorrow, thanks. :grin:

At least, I have found that this problem only is present with the nonfree drivers. Nouveau handles correctly the backlight level.

Well, none of the previous suggested solutions have worked, the brightness still is reset to maximum on every start. And worst, after I press de backlight key the brightness level is lower.

I've been reading the backlight section of the Arch wiki:

I think that brightness is controlled by the graphic driver:

[albert@MacBookPro ~]$ ls /sys/class/backlight/

This is the max bright level, lower than the initial one:

[albert@MacBookPro ~]$ cat /sys/class/backlight/nvidia_backlight/max_brightness

According to the wiki, I've also tried to add a udev rule, no success...
Pommed-light neither works,despite I have put it as autostart as is suggested in its github homepage.

I don't know what to do now... :thinking:

UPDATE: 50% of success, after installing nvidia-bl-dkms now the brightness level it's the same when I press the keyboard after starting the system. However, the brightness still is reset to maximum on every start...:sweat_smile:

UPDATE 2: 25% of more success, there are settings in preferences which can set the brightness at start:

I still have the brightness reset to maximum when I wake up the laptop from suspend, I hope that can solve this... :grinning::grinning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by