Brightness Issue

Hello Manjaro Community!
I've just installed version 19.0 KDE and have a problem with adjusting the screen brightness. In fact, it happened with the ISO live as well.
At first it is possible to regulate it a few steps, but if I try to raise or lower the brightness repeatedly (e.g. by pressing the FN buttons or by using the slider more than 3 times) it gets stuck and can't adjust it anymore, moving the slider turns to have no effect. Afterwards, when I try to do something else, the system freezes and I have to force reboot.
What could be the problem?
Thank you so much in advance

Welcome! Please see:

Also I'm curious what the output of the following is:

sudo dmesg | grep backlight

Thanks! I'll take it into account.

Machine info ( inxi -Fxxxza --no-host)

System:    Kernel: 5.4.22-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=11c22d78-312e-481c-81fb-7696d78f613f rw quiet apparmor=1 
           security=apparmor resume=UUID=ca72e906-4644-4b96-a541-0a64dc093fd8 udev.log_priority=3 
           Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X541UJ v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X541UJ v: 1.0 serial: <filter> UEFI: American Megatrends v: X541UJ.301 date: 12/26/2016 
Battery:   ID-1: BAT0 charge: 27.8 Wh condition: 28.4/34.6 Wh (82%) volts: 10.8/10.8 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Not charging cycles: 192 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber Lake family: 6 model-id: 8E (142) 
           stepping: 9 microcode: CA L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21607 
           Speed: 3100 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3101 2: 3100 3: 3100 4: 3100 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Device-2: NVIDIA GK208BM [GeForce 920M] driver: N/A bus ID: 01:00.0 chip ID: 10de:1299 
           Display: x11 server: X.Org 1.20.7 driver: intel compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 
           Sound Server: ALSA v: k5.4.22-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 
           bus ID: 02:00.2 chip ID: 10ec:8136 
           IF: enp2s0f2 state: down mac: <filter> 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On driver: rtl8723be v: kernel port: c000 
           bus ID: 03:00.0 chip ID: 10ec:b723 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 246.38 GiB (26.4%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 5J scheme: GPT 
Partition: ID-1: / raw size: 100.00 GiB size: 97.93 GiB (97.93%) used: 12.25 GiB (12.5%) fs: ext4 dev: /dev/sda6 
           ID-2: /home raw size: 286.62 GiB size: 281.13 GiB (98.08%) used: 304.5 MiB (0.1%) fs: ext4 dev: /dev/sda7 
           ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2700 
Info:      Processes: 176 Uptime: 6m Memory: 3.73 GiB used: 949.3 MiB (24.9%) Init: systemd v: 242 Compilers: gcc: 9.2.1 
           Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37 

By the way, dmesg | grep backlight does not give any output, but dmesg itself provides this indefinitely:

[  611.376798] pcieport 0000:00:1c.5: AER: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[  611.376799] pcieport 0000:00:1c.5: AER:    [ 0] RxErr                  (First)
[  611.376827] pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
[  611.376832] pcieport 0000:00:1c.5: AER:    [ 0] RxErr                  (First)

Probably this could be the error cause, I've experienced this with a prior Ubuntu install. Yes, this is a Windows dual-boot machine.
Thanks again!

As I thought, that was the cause. The problem is solved by editing /etc/default/grub, appending pci=nomsi (or pci=noaer) to the line GRUB_CMDLINE_LINUX_DEFAULT, then sudo update-grub
A detailed description is explained here:
Hope this helps!


That may have solved the problem with the dmesg error and freezing, but the NVIDIA driver doesn't seem to be installed properly. The guy on AskUbuntu didn't have drivers installed, either.

Did you choose free or non-free drivers when installing? What's the output of:

mhwd -li

I chose non-free drivers, since I have a NVIDIA graphics chip.
The output of mhwd -li is:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-390xx-bumblebee            2019.10.25               false            PCI

Warning: No installed USB configs!

I wonder why inxi didn't detect the driver, then? I don't know much about fiddling with NVIDIA drivers, I just wanted to double-check since I had seen that.

The driver is installed though, isn't it? Otherwise it wouldn't be listed by mhwd, I think...
Yeah, I agree that those drivers cause more than a headache...

Yes, they're installed. Like I said, just wanted to double-check.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by