Broadcom BCM43142 [Solved]

Laptop 14" HP stream 14-z000na AMD apu A4

Hi. WiFi driver was working out of the box. But it was disconnecting often.
So I went to MSettManager, Hardware config, network broadcom and I disintalled it.
Now I try to install it again in the same way and it keeps giving me errors.
What should I do?
I don't have Ethernet connection on the laptop. Thanks

Solved.

  1. I connected laptop by USB directly to router to get internet.
  2. Add/Remove Package Manager search broadcom
    there were several packets listed listed
  3. deleted them all
  4. go to Settings Manager -> Hardware config -> delete Broadcom -> install Broadcom
  5. Add/Remove Package Manager -> Update
  6. Reboot

I hate to have to tell you, but this is the worst of a bad bunch of broadcom cards. If you get it working at all you will probably still experience very poor performance. It will probably always have connectivity issues.

My personal recommendation is to buy an adapter with good Linux compatibility for your computer. Wish I had better news, but that adapter has very poor support in Linux.

Ok. It worked somewhat ok. My issue is that I decided to uninstall the driver.

How to retrieve the original in kernel driver? I could reinstall the system and it does it automatically but I'm sure there is another option.

Also what external adapters are recommended, and also what internal adapters since I will be getting a new laptop soon. Thanks

Please post your hw specs:

inxi -Fxzc0

I really don't like to recommend specific adapters as manufacturers change chips regularly. Kernel support also changes as time goes on. This stuff can change rapidly and on a rolling distro it's better not to have outdated info posted in this regard. You are best to search online for recent Linux reviews on the newest adapters.

I will type the key since I cannot do copy paste I'm not on the laptop

Kernel 4.14.66 Manjaro x86 64
Bits 64 compiler
Distro ML

Network
Device-1 broadcom limited bcm43142
Driver N/A bus id: 01:00

I can't really troubleshoot unless you can post terminal output. Are you capable of using phone tethering for an internet connection.

Try this:

sudo systemctl stop NetworkManager

sudo modprobe -r wl

sudo modprobe b43

sudo rfkill unblock all

sudo systemctl start NetworkManager

Ignore any errors but report if any occur.

-r wl gives error
Modprobe: fatal: module not found

All the rest doesn't give any feedback after command.
Last gives notification disconnected network notification.

Rebooted & checked still no driver

Sorry, but there's not really much I can do for you in this situation.

Ok thank you very much for your effort and time.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by