Broadcom BCM43224 - Wifi not working

Please post

grep -r "blacklist\|install\|options"  /etc/modprobe.d/

pacman -Qsq linux | grep linux | grep -v -E '(arch|util|sys|api|firmware)' | grep -v nvidia
➜  ~ grep -r "blacklist\|install\|options"  /etc/modprobe.d/
➜  ~ pacman -Qsq linux | grep linux | grep -v -E '(arch|util|sys|api|firmware)' | grep -v nvidia


Need to create one.

Shall I go through:

Check that a blacklist file exists in /etc/modprobe.d/ with the following contents.

blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma

If a file does not already exist with those contents, create it.

You can automatically add the required entries to /etc/modprobe.d/blacklist.conf file with the following command:

sudo echo -e "blacklist b43\nblacklist b43legacy\nblacklist ssb\nblacklist bcm43xx\nblacklist brcm80211\nblacklist brcmfmac\nblacklist brcmsmac\nblacklist bcma" | sudo tee -a /etc/modprobe.d/blacklist.conf

Then, issue these commands separately:

sudo rfkill unblock all
sudo depmod -a
sudo mkinitcpio -P

Run the following list of commands in its entirety, regardless of any errors received. Issue the commands individually one at a time allowing several seconds between commands:

sudo systemctl stop NetworkManager 
sudo rmmod b43 b43legacy ssb brcm80211 brcmfmac brcmsmac bcma 
sudo modprobe -r wl
sudo modprobe wl
DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5) && sudo ip link set $DEVICE up
sudo rfkill unblock all
sudo systemctl start NetworkManager 

Etc. as per Broadcom wifi driver fails to install properly?

Which files are in

ls -l /etc/modprobe.d
➜  ~ ls -l /etc/modprobe.d
total 0

That is very strange. Did you manually delete files from there?

Not that I can recall.

Reboot again then I will give you a list of commands.

Rebooted and ready.

Run all commands separately unless I say otherwise.

grep -r "blacklist\|install\|options"  /etc/modules-load.d/

grep -r "blacklist\|install\|options"  /usr/lib/modprobe.d/
➜  ~ grep -r "blacklist\|install\|options"  /etc/modules-load.d/
➜  ~ grep -r "blacklist\|install\|options"  /usr/lib/modprobe.d/
/usr/lib/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS
/usr/lib/modprobe.d/systemd.conf:options bonding max_bonds=0
/usr/lib/modprobe.d/systemd.conf:options dummy numdummies=0
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist b43
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist b43legacy
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist ssb
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist bcm43xx
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist brcm80211
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist brcmfmac
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist brcmsmac
/usr/lib/modprobe.d/broadcom-wl-dkms.conf:blacklist bcma
/usr/lib/modprobe.d/bluetooth-usb.conf:options btusb reset=1
/usr/lib/modprobe.d/uvesafb.conf:# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
/usr/lib/modprobe.d/uvesafb.conf:options uvesafb mode_option=1024x768-32 scroll=ywrap
➜  ~ 

Well that explains a lot. I rarely ever have to ask for that , but the kernel modules not loading made no sense. There is a leftover blacklist file that should have been removed.

We need to delete this file:

sudo rm /usr/lib/modprobe.d/broadcom-wl-dkms.conf
1 Like


➜  ~ sudo rm /usr/lib/modprobe.d/broadcom-wl-dkms.conf
[sudo] password for jr: 
➜  ~

Reboot check your wifi

Done, WiFi still doesn't work, i.e. it's not showing available networks, though there are available networks, e.g. the one my phone is connected to.

Wait, now the networks are showing!

I was hoping. Test your connectivity.

please post

lspci -knnvvv | grep -i net
➜  ~ lspci -knnvvv | grep -i net
00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 05)
02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
➜  ~ 

please post

inxi -n

Argh, I just turned off the USB tethering and tried to go to, but that didn't load, and neither did other pages, and WiFi networks were no longer showing. I reenabled the USB tethering.

Forum kindly sponsored by