Broadcom BCM4360 not working

In the meantime could you please post the results of

inxi - Fxc0

  Host: qverkk-pc Kernel: 4.14.39-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 7.3.1 Desktop: Gnome 3.28.1 Distro: Manjaro Linux 17.1.10 Hakoila 
  Type: Desktop System: MSI product: MS-7816 v: 3.0 serial: N/A 
  Mobo: MSI model: Z97-G43 (MS-7816) v: 3.0 serial: N/A 
  UEFI: American Megatrends v: V17.11 date: 02/18/2016 
  Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64030 
  Speed: 922 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 853 2: 858 
  3: 832 4: 817 5: 827 6: 818 7: 839 8: 845 
  Card-1: AMD Bonaire XTX [Radeon R7 260X/360] driver: radeon v: kernel 
  bus ID: 01:00.0 
  Display: x11 server: N/A driver: radeon resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD BONAIRE (DRM 2.50.0 / 4.14.39-1-MANJARO LLVM 6.0.0) 
  v: 4.5 Mesa 18.0.3 direct render: Yes 
  Card-1: Intel 9 Series Family HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Card-2: AMD Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM] 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Card-3: Creative type: USB driver: snd-usb-audio bus ID: 3:2 
  Sound Server: ALSA v: k4.14.39-1-MANJARO 
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: 4c:cc:6a:0f:6e:3c 
  Card-2: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter 
  driver: N/A bus ID: 06:00.0 
  IF-ID-1: enp0s20u10 state: unknown speed: N/A duplex: N/A 
  mac: 2a:c2:96:0b:bf:50 
  HDD Total Size: 704.12 GiB used: 23.38 GiB (3.3%) 
  ID-1: /dev/sda model: PLEXTOR_PX-128M6 size: 119.24 GiB 
  ID-2: /dev/sdb model: WDC_WD5000AAKX-0 size: 465.76 GiB 
  ID-3: /dev/sdc model: GOODRAM size: 111.79 GiB 
  ID-4: /dev/sdd type: USB model: DataTraveler_SE9 size: 7.32 GiB 
  ID-1: / size: 92.33 GiB used: 23.38 GiB (25.3%) fs: ext4 dev: /dev/sdc2 
  ID-2: swap-1 size: 17.18 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 34 C 
  Fan Speeds (RPM): N/A 
  Processes: 231 Uptime: 1h 56m Memory: 15.62 GiB used: 4.08 GiB (26.1%) 
  Init: systemd Compilers: gcc: 7.3.1 clang: 6.0.0 Shell: bash v: 4.4.19 
  inxi: 3.0.07 

Have you tried any new kernels yet?
If not, try installing kernel 4.16 through Manjaro settings manager. Reboot then select 4.16 at grub boot menu.

Downloading 4.16 right now, before it was working on my current kernel tho which is strange, going to let u know if it works on the 4.16

Still nothing, want any debug from 4.16 kernel?

no lets try it on 4.14

Alright, im on 4.14 now and removed the 4.16

No big deal, but it would have been better to have left 4.16 installed. I'll give you the blacklist instructions shortly.

If the file /etc/modprobe.d/blacklist.conf does not exist, create it:
With a text editor create the file /etc/modprobe.d/blacklist.conf with the contents:

blacklist b43
blacklist b44
blacklist b43legacy
blacklist ssb
blacklist brcmsmac
blacklist bcma

If you are not comfortable creating and editing root configuration files use the method below as an alternative.

The following command will automatically generate an /etc/modprobe.d/blacklist.conf file with the correct entries.

sudo echo -e "blacklist b43\nblacklist b44\nblacklist b43legacy\nblacklist ssb\nblacklist brcmsmac\nblacklist bcma" | sudo tee -a /etc/modprobe.d/blacklist.conf

After the blacklisting is complete we must then uninstall the old drivers, and replace them with 2 new packages.

1 Like

Alright did it, should i reboot now or re-install broadcom-wl?

First install the linux414-headers (numbers must match your kernel version). Then, uninstall the broadcom-wl drivers, and then reboot.

sudo pacman -S linux414-headers
sudo pacman -Rns broadcom-wl

Alright installed the headers, uninstalled the wl drivers and rebooted now. Now i should install the broadcom-wl or broadcom-wl-dkms and from where? Pacman or AUR?

Pacman should work. Install the broadcom-wl-dkms drivers they're in the Manjaro repos.

sudo pacman -S broadcom-wl-dkms

Alright i've done that. Should i perform there actions now?

To load the new module, run as root:

rmmod b43 b43legacy ssb bcm43xx brcm80211 brcmfmac brcmsmac bcma wl
modprobe wl

or just reboot the system.

Run those commands, then reboot.

(edit) Just to clarify for others, those are two separate commands. Either use "su" (as in above commands), or "sudo" as in the commands below:

First command:

sudo rmmod b43 b43legacy ssb bcm43xx brcm80211 brcmfmac brcmsmac bcma wl

Second command:

sudo modprobe wl

Oh wow it's working man! Thank you very much for the help!! Hope this solves the problem to alot of users as there was nothing about what you've just told me right now on the manjaro forums. Really appericiate your time man!

1 Like

No problem. Glad to help. You made it easy, cause you're no newbie.


@qverkk I hope you don't mind I'm editing in some further details for others reading your thread. You did not need the extra info, but others may. I linked this post to another broadcom issue today and it resolved his driver problem as well. So, hopefully your thread may help many others.


Extremely happy that I found this thread. Thank you qverkk for describing the problem better than I could. Thanks tbg for explaining the process in such a clear fashion. (I appreciated the extra info :smile: )

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by