Broadcom BCM4360 wifi not working

After a fresh install of manjaro I noticed my wifi is not working. It is not scanning, only displaying "No networks available". Ethernet works fine. the computer being used is a macbook air 7,1. Its a shame because everything works flawlessly on my thinkpad.

Ip link only shows my ethernet connection. ip link:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: ens9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000 link/ether 38:c9:86:39:03:16 brd ff:ff:ff:ff:ff:ff

lspci -vnn -d 14e4: displays the following

03:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03) Subsystem: Apple Inc. Device [106b:0117] Flags: bus master, fast devsel, latency 0, IRQ 18 Memory at c1200000 (64-bit, non-prefetchable) [size=32K] Memory at c1000000 (64-bit, non-prefetchable) [size=2M] Capabilities: <access denied> Kernel driver in use: bcma-pci-bridge Kernel modules: bcma

I'm tired installing the b43 drivers but it didn't work.

There is this post on the arch forum - https://bbs.archlinux.org/viewtopic.php?id=201245

Seems a bit inconclusive, but says solved.........

I found this :
For b43...

Two reverse-engineered open-source drivers are built-in to the kernel: b43 and b43legacy.
b43 supports most newer Broadcom chipsets, while the b43legacy driver only supports the early BCM4301 and BCM4306 rev.2 chipsets. To avoid erroneous detection of your WiFi card's chipset, blacklist the unused driver.
Both of these drivers require non-free firmware to function.
Install b43-firmware, b43-firmware-classic or b43-firmware-legacy from the AUR.

But then for that specific card/macbooks there was also this on arch wiki..

broadcom-wl is sufficient if you are using the Linux mainline kernel. For custom kernels, you need to use broadcom-wl-dkms. Both are available from the AUR. Note that it does have to be built against the exact same kernel version as used by the installer, and this may differ from the latest version. If built against the wrong kernel you may encounter an error

And then under 'what doesnt work' there was this for wifi :

broadcom-wl or broadcom-wl-dkms from the AUR works
Stability is an issue for some, look at Broadcom wireless for possible fixes (e.g. downgrading kernel works if your card is BCM4360)

That all combined with the post above makes me think you might try broadcom-wl for whatever kernel you are running

yaourt broadcom-wl
1 extra/broadcom-wl-dkms 6.30.223.248-1
    Broadcom 802.11 Linux STA wireless driver
2 extra/linux310-broadcom-wl 6.30.223.248-6 (linux310-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
3 extra/linux312-broadcom-wl 6.30.223.248-7 (linux312-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
4 extra/linux314-broadcom-wl 6.30.223.248-9 (linux314-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
5 extra/linux316-broadcom-wl 6.30.223.248-8 (linux316-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
6 extra/linux318-broadcom-wl 6.30.223.248-8 (linux318-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
7 extra/linux319-broadcom-wl 6.30.223.248-10 (linux319-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
8 extra/linux41-broadcom-wl 6.30.223.248-10 (linux41-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
9 extra/linux42-broadcom-wl 6.30.223.248-10 (linux42-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
10 extra/linux44-broadcom-wl 6.30.223.248-12 (linux44-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
11 extra/linux45-broadcom-wl 6.30.223.248-7 (linux45-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
12 extra/linux46-broadcom-wl 6.30.223.248-0.9 (linux46-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.

Just what I could find ... Hopefully it can set you on the right path ...
Just make sure to properly remove or disable any 'fix' that didnt work before trying something else.

1 Like

Looks like B43 doesn't support your BCM4360. As cscs said, broadcom-wl is probably your best bet. I see it can be installed from the repositories with the package manager (pamac), but there are different packages depending on your kernel. Rebooting may be required to properly load the kernel module after installing.

If it still doesn't work, the B43 driver may need to be blacklisted so it isn't loaded instead of wl.

Let mhwd handle it, but you may need to plug in your ethernet connection. Just open up Manjaro Settings Manager and install the latest kernel, then go to hardware detection tool and install the broadcom-wl driver, that's the easiest way. If you don't have a working internet, you may need to manually download the package from your phone or anything and install it locally which is more things to do. Good luck :slight_smile:

+cscs your suggestion worked graciously. I appreciate your indepth research, and reslove. Thank you so much.

All in all everything else worked out of the box without a hitch.

Glad to hear it :smiley_cat:

I have the 4360 in my mid 2014 Macbook Pro 11,1 and want to share that I had success with broadcom-wl

'sudo pacman -S broadcom-wl' comes back with a dozen options for me, and some of them I tried but didn't work. This one worked great after a reboot.
linux-rt-manjaro-broadcom-wl-6.30.223.248-10

3 Likes

Sorry i am pretty new with linux and totally new with manjaroSo i am having the same issue as described. I ran Manjaro on a live SD card first and had no issues with the wifi connection. Then i install to my SSD and now having the same issue with the same wireless card as above.
I guess my question is, Do y'all think i had a problem with my install form live SD card or does it sounds like i need the non-free b43-legacy drivers?

You will most likely want to try the 'broadcom-wl' package that correlates to your kernel. For example if you have 4.4 (default right now) kernel then install "linux44-broadcom-wl"

sudo pacman -S linux44-broadcom-wl

(edit - @scachemaille - I win ;-))

2 Likes

if you have a broadcom 4360 yes it need broadcom-wl drivers.
if you have an other internet connection install broadcom-wl drivers.

sudo pacman -S linux44-broadcom-wl

replace linux44 with the kernel you have in your systemPreformatted text[quote="cscs, post:10, topic:2141"]
(edit - @scachemaille - I win :wink:)
[/quote]

I saw. :stuck_out_tongue:

2 Likes

First of all Geez you guys are on it when it comes to responses. and i really appreciate it i was expecting a couple days till someone even saw that i posted. Thanks!!
Well i updated installed driver as per my kernel which i did confirm was 4.4 using the command you provided. Seemed to have done everyhting properly and then i restarted PC. Still no luck. I am using tether to my smartphone right now to do the updates. Still confused that the live SD card worked/still works flawlessly. Any other suggestions.

This worked liked a charm to my macbook air 11 2013.
bcm43

2 years later

necro2

Forum kindly sponsored by