Broadcom - no wifi - Macbook (early 2008)

Hey all,

I'll start by admitting outright that I am n00bish Linux user and brand new to Manjaro. Please be gentle.

After installing many, many distros on this Black Macbook 4,1


over the last three days I am very very happy with Manjaro (manjaro-xfce-18.1.0-stable-x86_64). All of the other distros I tried had issues with the video card, extremely slow booting with lots of errors, no fans, wonky trackpad, regular app freezes, or some combination of those. Manjaro works beautifully, with one serious caveat; I cannot get the wifi working. It works with some other distros, with proprietary drivers (ubuntu for instance), but in Manjaro wifi isn't listed, only wired, despite the card showing up in the hardware preferences. I'm not sure where to go from here... I believe it's broadcom? I do have ethernet working.

I'm not brand new to Linux, but most of the things I know how to do in terminal are from google searches with code supplied. I'm still learning my way around Manjaro. I can follow directions though! Any extra charitable souls out there that would walk me through getting it working? I don't know: a) what driver to use b) where to get it c) how to install it.

Can you post some information about the hardware, especially the WIFI adapter?

can you returns

inxi -Fxxxza

There is a wealth of information on Arch Wiki with relation to Mac

Follow the instructions in the link below, (and be sure to test with numerous different kernels):

1 Like

You Sir, are a gentleman and a scholar. Worked perfectly. Many Thanks!

1 Like

Awesome, glad that helped. I've never been accused of being a gentleman before though. Guess it comes along with getting a little bit older.

I mostly was known by the nickname "Jhonny Obnoxious" in my younger days, but times change I guess. :sob:

For reference please list your wifi driver, kernel, and broadcom adapter model.

inxi -n

uname -a

I might take a while to get that posted. I had tried several 'solutions' previously and thought I should do a clean install and use the method you provided exclusively. I'M NOT SURE WHAT HAPPENED BUT I am unable to edit or change any system files, install a second kernel, do anything system wise really- all come back permission denied. Even using sudo AND root! Might take a while to get it sorted.

That's not good ar all.

I would suggest opening a separate help thread for that if you make no headway. That is the furthest thing from a wifi issue. Somehow your permissions got borked from the sounds of things.

Good luck.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by