Broadcom Wi-Fi on macbook 4,1 not recognized after install

Installer on version 18 recognizes Wi-Fi. After install Wi-Fi not working until kernel reinstalled or new kernel installed with corresponding Broadcom WL Wi-Fi driver.

Read this:

I don't think this is my issue...the correct driver IS installed it's just not configured properly after the initial install......REINSTALL of the correct driver fixes the issue. Also the addition of a different kernel causes the correct WL driver to be installed & configured properly. DKMS is not required for proper operation.

It's because on the live disk the broadcom kernel modules are usually used. On the installer the broadcom-wl modules are usually installed by default, and are often misconfigured on some models.

You are correct DKMS drivers are not required, but with a problematic kernel update I believe the DKMS versions break less often.

Reporting an issue for the developers to consider...I've worked around it, the less technical may

That is one of the reasons you see so many Broadcom issues on the forum. The average person doesn't know how to fix their broadcom driver issues.

It is not an easy fix at the installer level. I started researching implementing fixes with a programmer but he didnt get too far before he threw in the towel. There's no easy fix for the broadcom drivers. They're a mess in Linux.

Yep.. Ask The cloudready people....
The kernel module on the Manjaro 18 installer only runs in G mode on my router...
same issue with cloudready & for some reason they have given up on the WL as a default on this hardware....gotta change manually after every update..

1 Like

Dude I just had your same problem, the simple answer is to uninstall the broadcom-wl modules that was installed and reboot.

You can't generalize like that. The broadcom adapters don't all have kernel modules that work well. Sometimes the wl driver is the only choice. Some adapters will work with either wl or the kernel modules. You need to investigatate which is the best choice.

only runs in G mode on my router…]

Uninstall the broadcom-wl module and install this and reboot.

Your not listening. You can't give blanket advice like that. One size does not fit all. Just because that worked with your adapter doesn't mean it will work for all broadcom adapters.

Perhaps you need to read the broadcom archwiki page.

You're right, he's on a MacBook 4,1 which is really really old. I have a MacBook 8,2 and wifi hasn't been an issue yet.

Installing DKMS doesn't install headers by default...had to check the error message.

You must install the headers before installing the DKMS driver. The link I posted is pretty specific about that.

Actually you can install the headers just get a fail if you install DKMS first but it all comes out in the wash when you install the headers.

...I woulda thought pamac would see the headers as a dependency....

For some reason it is not listed as a dependency. While it does not "have" to be installed first, I find the best success is with it first (with a reboot inbetween) the driver install, reboot afterwards.

Ahh, If you search for how many problems I've had with macbooks...
The best answer was given by @anon73238028
You need to uninstall the broadcom drivers and restart, the generic drivers are the closest thing you'll get as far as a solution goes.

1 Like

What is with you guys. Not all Broadcom devices work well with the default Kernel modules. Some do not work at all with the kernel modules. You need to use the wl driver on some adapters.

I repeat yet again, just because your broadcom adapter works satisfactorily with the kernel module does not make it so for all broadcom adapters.

Please stop spreading bad advice. Go to official sources to find the proper information on which module to use:

Broadcom Wifi ArchWiki page:

Other authoritative sources:

Broadcom Linux supported adapters - driver reference lists:

1 Like

I've done it with 3 identical macbooks, so I know what I'm talking about, not necessarily from knowledge, but from experience. They all work fine with the live USB, after install is were it all goes wrong.
They all were 4,1 macbooks...

Forum kindly sponsored by