Broadcom-wl driver stopped working out of the bllue while pc was running before any update

(base) [moby_dick@rajat-pc ~]$ inxi -N
Network:
  Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n driver: wl 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 

when I tried reinstalling the driver I get this

Packages (1) linux419-broadcom-wl-6.30.223.271-73

Total Installed Size:  1.39 MiB

:: Proceed with installation? [Y/n] 
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing linux419-broadcom-wl...
:: Running post-transaction hooks...
(1/2) Updating module dependencies...
(2/2) Arming ConditionNeedsUpdate...
modprobe: FATAL: Module bcm43xx not found.
modprobe: FATAL: Module brcm80211 not found.
> Successfully installed network-broadcom-wl


Done ...
1 Like

I had tried installing the dkms driver but they too were not working, I went back to kernal 414 but didn't help either, should I install the 5.xx version ? Also I tried disabling the Mac Address Rando... but it didn't help

5.2.21-rt13-MANJARO (linux52) - I tried this kernal but still wifi not working, also I have tried to install the dkms version of wl using that post before posting here and it did not work either, I am amazed that the wifi stopped working all of a sudden while I was not updating my computer.

So, you say you followed this


You had no errors during the install, yet the wi-fi is not working ?

Also try disabling wifi power saving.

Read all fixes attempted /recommended on these threads:

Have you tried pinging various addresses.

ping -c5 8.8.8.8                                                                                

ping -c5 google.com 

ping -c5 127.0.0.1

ping -c5 localhost

Please post the input and outputs of those commands as well as:

hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S" 

Yes I followed that guide and had no error in installing the dkms drivers and yet they did not work, I uninstalled tlp now and still wifi not working.

I tried both the 5.2 and 5.3 kernals, right now running the 5.3 one but wifi still not working, I ran that command but it did not help

my wifi never worked on any of the distros I ever tried, on ubuntu if I installed them and somehow if they worked by the time I rebooted they were gone again but on manjaro they worked right out of the box

What command?

see my edits above.

You must post all inputs and outputs of every command requested. If you do not, the command was never run as far as I'm concerned without visual proof.

Did you create the disable Mac randomization file as suggested in the Link from @bogdancovaciu.

You are not capable of providing proper feedback to helpers on what they have suggested to you. Read all links, post all efforts you have made in full. Post all inputs and outputs requested and perhaps I might have time to look at your issue otherwise I would rather deal with non Broadcom issues with users that are cooperative.

I am sorry, I meant I ran the disabling random mac address command

(base) [moby_dick@rajat-pc ~]$ hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S"
Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
Driver: "r8168"
Device File: enp9s0
Link detected: no
Driver Status: r8169 is not active
Driver Activation Cmd: "modprobe r8169"
Driver Status: r8168 is active
Driver Activation Cmd: "modprobe r8168"
Model: "Dell Wireless 1704 802.11n + BT 4.0"
Driver: "wl"
Device File: wlp7s0
Link detected: yes
Driver Status: bcma is not active
Driver Activation Cmd: "modprobe bcma"
Driver Status: wl is active
Driver Activation Cmd: "modprobe wl"
Model: "Qualcomm Mobile Router"
Hotplug: USB
Driver: "rndis_host"
Device File: enp0s29u1u2
Speed: 480 Mbps
Link detected: yes
Driver Status: rndis_host is active
Driver Activation Cmd: "modprobe rndis_host"

When you run the ping commands do not have an alternate internet connection in use such as tethering etc etc.

Which desktop are you using (only one)?

When did you install Manjaro?

(base) [moby_dick@rajat-pc ~]$ ping -c5 8.8.8.8                                                                                
ping: connect: Network is unreachable
(base) [moby_dick@rajat-pc ~]$ ping -c5 google.com 
ping: google.com: Name or service not known
(base) [moby_dick@rajat-pc ~]$ ping -c5 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.038 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.033 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.047 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.055 ms
64 bytes from 127.0.0.1: icmp_seq=5 ttl=64 time=0.055 ms

--- 127.0.0.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4054ms
rtt min/avg/max/mdev = 0.033/0.045/0.055/0.008 ms
(base) [moby_dick@rajat-pc ~]$ ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.040 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.059 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.074 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.062 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.062 ms

--- localhost ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4062ms
rtt min/avg/max/mdev = 0.040/0.059/0.074/0.011 ms

Also I have tried reading as many posts I could find on this forum regarding my wifi driver as I could before posting and I am sorry if I was not being helpful in providing the outputs, also I have uninstalled tlp, tried both 5.3, 5.3 kernals, reinstalled the wl driver several time, ran the random mac address disable command, read your post about installing the dkms version of wl before posting here and tried doing that but that did not help either.
I am using Manjaro KDE which I have installed 3-4 months ago and have been using manjaro on this laptop for a year now ( earlier was using xfce but then did a fresh install of kde one )

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf
[sudo] password for moby_dick: 
[device]
wifi.scan-rand-mac-address=no

Did you miss this one^^^

I appreciate you have done your homework. This is a very difficult adapter to get working.

■■■■■ my bad..I don't know how I missed this one while copying.

(base) [moby_dick@rajat-pc ~]$ ping -c5 8.8.8.8
ping: connect: Network is unreachable

You have to do both just to make sure. Thank you for posting,.

Have you looked at dmesg for errors:

sudo dmesg | grep wl

Sorry, I did not see your edit.

I answered this question while I posted those ping queries, I am using manjaro kde only and installed it 4 months ago

sudo dmesg | grep wl
[sudo] password for moby_dick: 
[   15.850498] wl: module license 'MIXED/Proprietary' taints kernel.
[   16.236009] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
[   16.239454] wl 0000:07:00.0 wlp7s0: renamed from wlan0
[   26.215498] ERROR @wl_cfg80211_scan : 
[   29.002296] ERROR @wl_cfg80211_scan : 
[   52.001568] ERROR @wl_cfg80211_scan : 
[   85.002449] ERROR @wl_cfg80211_scan : 
[  128.002815] ERROR @wl_cfg80211_scan : 
[  145.512652] ERROR @wl_cfg80211_scan : 
[  163.535138] ERROR @wl_cfg80211_scan : 
[  180.510380] ERROR @wl_cfg80211_scan : 
[  197.511339] ERROR @wl_cfg80211_scan : 
[  214.006402] ERROR @wl_cfg80211_scan : 
[  231.010796] ERROR @wl_cfg80211_scan : 
[  247.506701] ERROR @wl_cfg80211_scan : 
[  264.012515] ERROR @wl_cfg80211_scan : 
[  280.508812] ERROR @wl_cfg80211_scan : 
[  297.011399] ERROR @wl_cfg80211_scan : 
[  314.461847] ERROR @wl_cfg80211_scan : 
[  331.510332] ERROR @wl_cfg80211_scan : 
[  348.530159] ERROR @wl_cfg80211_scan : 
[  365.509978] ERROR @wl_cfg80211_scan : 
[  382.510187] ERROR @wl_cfg80211_scan : 
[  399.507718] ERROR @wl_cfg80211_scan : 
[  416.509676] ERROR @wl_cfg80211_scan : 
[  433.510115] ERROR @wl_cfg80211_scan : 
[  450.506141] ERROR @wl_cfg80211_scan : 
[  467.509638] ERROR @wl_cfg80211_scan : 
[  484.508879] ERROR @wl_cfg80211_scan : 
[  501.510205] ERROR @wl_cfg80211_scan : 
[  518.509851] ERROR @wl_cfg80211_scan : 
[  535.508879] ERROR @wl_cfg80211_scan : 
[  552.510633] ERROR @wl_cfg80211_scan : 
[  569.509733] ERROR @wl_cfg80211_scan : 
[  586.510119] ERROR @wl_cfg80211_scan : 
[  603.507435] ERROR @wl_cfg80211_scan : 
[  620.510127] ERROR @wl_cfg80211_scan : 
[  637.509714] ERROR @wl_cfg80211_scan : 
[  654.510138] ERROR @wl_cfg80211_scan : 
[  671.506967] ERROR @wl_cfg80211_scan : 
[  688.509637] ERROR @wl_cfg80211_scan : 
[  705.509483] ERROR @wl_cfg80211_scan : 
[  722.509218] ERROR @wl_cfg80211_scan : 
[  739.509080] ERROR @wl_cfg80211_scan : 
[  756.515877] ERROR @wl_cfg80211_scan : 
[  773.509925] ERROR @wl_cfg80211_scan : 
[  790.509439] ERROR @wl_cfg80211_scan : 
[  807.509855] ERROR @wl_cfg80211_scan : 
[  824.509315] ERROR @wl_cfg80211_scan : 
[  841.509311] ERROR @wl_cfg80211_scan : 
[  858.509881] ERROR @wl_cfg80211_scan : 
[  876.008712] ERROR @wl_cfg80211_scan : 
[  893.010066] ERROR @wl_cfg80211_scan : 
[  910.011530] ERROR @wl_cfg80211_scan : 
[  927.010817] ERROR @wl_cfg80211_scan : 
[  944.007926] ERROR @wl_cfg80211_scan : 
[  961.006791] ERROR @wl_cfg80211_scan : 
[  978.011821] ERROR @wl_cfg80211_scan : 
[  995.009154] ERROR @wl_cfg80211_scan : 
[ 1012.008856] ERROR @wl_cfg80211_scan : 
[ 1029.010357] ERROR @wl_cfg80211_scan : 
[ 1046.009534] ERROR @wl_cfg80211_scan : 
[ 1063.011890] ERROR @wl_cfg80211_scan : 
[ 1080.008918] ERROR @wl_cfg80211_scan : 
[ 1097.007352] ERROR @wl_cfg80211_scan : 
[ 1114.008766] ERROR @wl_cfg80211_scan : 
[ 1131.005440] ERROR @wl_cfg80211_scan : 
[ 1148.011989] ERROR @wl_cfg80211_scan : 
[ 1165.007610] ERROR @wl_cfg80211_scan : 
[ 1182.010357] ERROR @wl_cfg80211_scan : 
[ 1199.010360] ERROR @wl_cfg80211_scan : 
[ 1216.010852] ERROR @wl_cfg80211_scan : 
[ 1233.009711] ERROR @wl_cfg80211_scan : 
[ 1250.012503] ERROR @wl_cfg80211_scan : 
[ 1267.010492] ERROR @wl_cfg80211_scan : 
[ 1284.006904] ERROR @wl_cfg80211_scan : 
[ 1301.011116] ERROR @wl_cfg80211_scan : 
[ 1318.011847] ERROR @wl_cfg80211_scan : 
[ 1335.010829] ERROR @wl_cfg80211_scan : 
[ 1352.009529] ERROR @wl_cfg80211_scan : 
[ 1369.010046] ERROR @wl_cfg80211_scan : 
[ 1385.997719] ERROR @wl_cfg80211_scan : 
[ 1403.010050] ERROR @wl_cfg80211_scan : 
[ 1420.008938] ERROR @wl_cfg80211_scan : 
[ 1437.010205] ERROR @wl_cfg80211_scan : 
[ 1454.010007] ERROR @wl_cfg80211_scan : 
[ 1471.010725] ERROR @wl_cfg80211_scan : 
[ 1488.010216] ERROR @wl_cfg80211_scan : 
[ 1505.009034] ERROR @wl_cfg80211_scan : 
[ 1522.062277] ERROR @wl_cfg80211_scan : 
[ 1539.010803] ERROR @wl_cfg80211_scan : 
[ 1556.009920] ERROR @wl_cfg80211_scan 

Forum kindly sponsored by