Broadcom-wl driver stopped working out of the bllue while pc was running before any update

Sorry, I did not see your edit.

I answered this question while I posted those ping queries, I am using manjaro kde only and installed it 4 months ago

sudo dmesg | grep wl
[sudo] password for moby_dick: 
[   15.850498] wl: module license 'MIXED/Proprietary' taints kernel.
[   16.236009] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
[   16.239454] wl 0000:07:00.0 wlp7s0: renamed from wlan0
[   26.215498] ERROR @wl_cfg80211_scan : 
[   29.002296] ERROR @wl_cfg80211_scan : 
[   52.001568] ERROR @wl_cfg80211_scan : 
[   85.002449] ERROR @wl_cfg80211_scan : 
[  128.002815] ERROR @wl_cfg80211_scan : 
[  145.512652] ERROR @wl_cfg80211_scan : 
[  163.535138] ERROR @wl_cfg80211_scan : 
[  180.510380] ERROR @wl_cfg80211_scan : 
[  197.511339] ERROR @wl_cfg80211_scan : 
[  214.006402] ERROR @wl_cfg80211_scan : 
[  231.010796] ERROR @wl_cfg80211_scan : 
[  247.506701] ERROR @wl_cfg80211_scan : 
[  264.012515] ERROR @wl_cfg80211_scan : 
[  280.508812] ERROR @wl_cfg80211_scan : 
[  297.011399] ERROR @wl_cfg80211_scan : 
[  314.461847] ERROR @wl_cfg80211_scan : 
[  331.510332] ERROR @wl_cfg80211_scan : 
[  348.530159] ERROR @wl_cfg80211_scan : 
[  365.509978] ERROR @wl_cfg80211_scan : 
[  382.510187] ERROR @wl_cfg80211_scan : 
[  399.507718] ERROR @wl_cfg80211_scan : 
[  416.509676] ERROR @wl_cfg80211_scan : 
[  433.510115] ERROR @wl_cfg80211_scan : 
[  450.506141] ERROR @wl_cfg80211_scan : 
[  467.509638] ERROR @wl_cfg80211_scan : 
[  484.508879] ERROR @wl_cfg80211_scan : 
[  501.510205] ERROR @wl_cfg80211_scan : 
[  518.509851] ERROR @wl_cfg80211_scan : 
[  535.508879] ERROR @wl_cfg80211_scan : 
[  552.510633] ERROR @wl_cfg80211_scan : 
[  569.509733] ERROR @wl_cfg80211_scan : 
[  586.510119] ERROR @wl_cfg80211_scan : 
[  603.507435] ERROR @wl_cfg80211_scan : 
[  620.510127] ERROR @wl_cfg80211_scan : 
[  637.509714] ERROR @wl_cfg80211_scan : 
[  654.510138] ERROR @wl_cfg80211_scan : 
[  671.506967] ERROR @wl_cfg80211_scan : 
[  688.509637] ERROR @wl_cfg80211_scan : 
[  705.509483] ERROR @wl_cfg80211_scan : 
[  722.509218] ERROR @wl_cfg80211_scan : 
[  739.509080] ERROR @wl_cfg80211_scan : 
[  756.515877] ERROR @wl_cfg80211_scan : 
[  773.509925] ERROR @wl_cfg80211_scan : 
[  790.509439] ERROR @wl_cfg80211_scan : 
[  807.509855] ERROR @wl_cfg80211_scan : 
[  824.509315] ERROR @wl_cfg80211_scan : 
[  841.509311] ERROR @wl_cfg80211_scan : 
[  858.509881] ERROR @wl_cfg80211_scan : 
[  876.008712] ERROR @wl_cfg80211_scan : 
[  893.010066] ERROR @wl_cfg80211_scan : 
[  910.011530] ERROR @wl_cfg80211_scan : 
[  927.010817] ERROR @wl_cfg80211_scan : 
[  944.007926] ERROR @wl_cfg80211_scan : 
[  961.006791] ERROR @wl_cfg80211_scan : 
[  978.011821] ERROR @wl_cfg80211_scan : 
[  995.009154] ERROR @wl_cfg80211_scan : 
[ 1012.008856] ERROR @wl_cfg80211_scan : 
[ 1029.010357] ERROR @wl_cfg80211_scan : 
[ 1046.009534] ERROR @wl_cfg80211_scan : 
[ 1063.011890] ERROR @wl_cfg80211_scan : 
[ 1080.008918] ERROR @wl_cfg80211_scan : 
[ 1097.007352] ERROR @wl_cfg80211_scan : 
[ 1114.008766] ERROR @wl_cfg80211_scan : 
[ 1131.005440] ERROR @wl_cfg80211_scan : 
[ 1148.011989] ERROR @wl_cfg80211_scan : 
[ 1165.007610] ERROR @wl_cfg80211_scan : 
[ 1182.010357] ERROR @wl_cfg80211_scan : 
[ 1199.010360] ERROR @wl_cfg80211_scan : 
[ 1216.010852] ERROR @wl_cfg80211_scan : 
[ 1233.009711] ERROR @wl_cfg80211_scan : 
[ 1250.012503] ERROR @wl_cfg80211_scan : 
[ 1267.010492] ERROR @wl_cfg80211_scan : 
[ 1284.006904] ERROR @wl_cfg80211_scan : 
[ 1301.011116] ERROR @wl_cfg80211_scan : 
[ 1318.011847] ERROR @wl_cfg80211_scan : 
[ 1335.010829] ERROR @wl_cfg80211_scan : 
[ 1352.009529] ERROR @wl_cfg80211_scan : 
[ 1369.010046] ERROR @wl_cfg80211_scan : 
[ 1385.997719] ERROR @wl_cfg80211_scan : 
[ 1403.010050] ERROR @wl_cfg80211_scan : 
[ 1420.008938] ERROR @wl_cfg80211_scan : 
[ 1437.010205] ERROR @wl_cfg80211_scan : 
[ 1454.010007] ERROR @wl_cfg80211_scan : 
[ 1471.010725] ERROR @wl_cfg80211_scan : 
[ 1488.010216] ERROR @wl_cfg80211_scan : 
[ 1505.009034] ERROR @wl_cfg80211_scan : 
[ 1522.062277] ERROR @wl_cfg80211_scan : 
[ 1539.010803] ERROR @wl_cfg80211_scan : 
[ 1556.009920] ERROR @wl_cfg80211_scan 

:slight_smile:

I would perform a hard power down with a full bios reset and see if that helps at all. Search the forum for the steps.

1 Like

well my drivers works or not but I really appreciate you helping me out

ok, I will look it up

1 Like

Your welcome, but I'm not sure how much hope there is to get this working.

I would have reinstalled but I have customized it somuch to make it my own I don't think I will reinstall it

su -c '/usr/bin/env bash -c echo "unloading network"; nmcli networking off; sleep 1; systemctl stop NetworkManager; sleep 2; DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5); sudo ip link set $DEVICE down; echo -e "\n--- unloading network ---\n"; sleep 3; modprobe -r wl; sleep 3; echo -e "\n--- restarting network ---\n"; sleep 3; modprobe wl; sleep 3; ip link set $DEVICE up; sleep 2; systemctl start NetworkManager; sleep 2; nmcli networking on; sleep 2; nmcli r wifi off; sleep 2; nmcli r wifi on; echo -e "\n--- process completed ---\n"'

Please post your input, and output from the command.

(base) [moby_dick@rajat-pc ~]$ su -c '/usr/bin/env bash -c echo "unloading network"; nmcli networking off; sleep 1; systemctl stop NetworkManager; sleep 2; DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5); sudo ip link set $DEVICE down; echo -e "\n--- unloading network ---\n"; sleep 3; modprobe -r wl; sleep 3; echo -e "\n--- restarting network ---\n"; sleep 3; modprobe wl; sleep 3; ip link set $DEVICE up; sleep 2; systemctl start NetworkManager; sleep 2; nmcli networking on; sleep 2; nmcli r wifi off; sleep 2; nmcli r wifi on; echo -e "\n--- process completed ---\n"'
Password: 


--- unloading network ---


--- restarting network ---


--- process completed ---

And no change at all?

well ethernet went off and on again but can not see wifi, restarted my router too

Screenshot_20191122_161313

You should really uninstall the r8168 driver. It is not used on new ISO's because of the problems it creates.

Run this command to remove it:

sudo mhwd -r pci network-r8168 

Then do the hard power down procedure and reset your bios to the factory default before rebooting into Manjaro.

1 Like

Oh cr@p you never mentioned you were using a VPN connection. That often creates issues with connectivity. Have you disabled your VPN through your troubleshooting procedures?

Have you tried recreating your wifi connection in Network Manager?

I rarely use them when I have to access blocked sites, I have the settings saved of free protonvpn, should I remove them ?

It might not be a bad idea and then you might want to reinstall network manager.

I have removed them and now will try to reinstall network manager

1 Like

I tried reinstalling network manager from octopi gui but it did not help either, I am gonna try hard power down and bios reset options

Sorry, but I'm going to have to pack it in on this for now. It's after 3am in my local time. I'm about done.

Good luck.

Forum kindly sponsored by