Broken GRUB (again)

Hi, a while back I had trouble with my GRUB, it simply said it lacked boot media. This was because when using Windows CMD: bootrec /FixMBR wiped it I must've wiped the boot record? I was sent this link Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader and this worked.

HOWEVER, I rebooted my laptop and this happened again... Now, I try that previous solution and it boots and once I type in config /boot/grub/grub.cfg it boots me straight into the GRUB that I'm MISSING so I know it exists!!! But the second step of the process includes installing the grub, which is where it fails. Here is the error I receive after downloading grub-vanilla...

##Grub Installation Error
michaelo@michael-pc ~> sudo grub-install /dev/sda
Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.

(If I could be a pain and ask for a small amount of hand holding through this process I'd really appreciate it as I need my laptop for work)

can you boot on USB live manjaro
open a terminal and a browser on this topic
and returns

inxi -Fxxxza
parted -l 

Big thank you for your fast response and for your time.
As requested, the results from the terminal.


System:
  Host: manjaro Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MJRO1815 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  Desktop: KDE Plasma 5.17.4 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard 
  product: HP Pavilion 15 Notebook PC v: 0974110000405F10000620180 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Hewlett-Packard model: 227E v: 77.25 serial: <filter> 
  UEFI [Legacy]: Insyde v: F.11 date: 08/07/2014 
Battery:
  ID-1: BAT0 charge: 13.7 Wh condition: 13.7/13.7 Wh (100%) 
  volts: 16.7/14.8 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-4288U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 25 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 20760 
  Speed: 1098 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 1098 
  2: 1099 3: 1098 4: 1098 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0a2e 
  Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa compositor: kwin_x11 resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 19.3.1 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 4000 
  bus ID: 08:00.0 chip ID: 10ec:b723 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 
  bus ID: 09:00.0 chip ID: 10ec:8136 
  IF: eno1 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.38 TiB used: 108.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST1500LM006 HN-M151RAD 
  size: 1.36 TiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0001 
  scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Toshiba model: TransMemory 
  size: 14.45 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.00 scheme: MBR 
Partition:
  ID-1: / raw size: N/A size: 5.78 GiB used: 108.4 MiB (1.8%) fs: overlay 
  source: ERR-102 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 185 Uptime: 1m Memory: 7.71 GiB used: 627.1 MiB (7.9%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: konsole inxi: 3.0.37 
[manjaro@manjaro ~]$ part -l
bash: part: command not found
[manjaro@manjaro ~]$ parted -l
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA ST1500LM006 HN-M (scsi)
Disk /dev/sda: 1500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  683MB   682MB   ntfs         Basic data partition          hidden, diag
 3      955MB   1089MB  134MB                Microsoft reserved partition  msftres
 4      1089MB  1055GB  1054GB  ntfs         Basic data partition          msftdata
 8      1055GB  1370GB  315GB   ext4
 5      1370GB  1372GB  1925MB  ntfs                                       hidden, diag
 2      1372GB  1393GB  21.0GB  fat32                                      msftdata
 6      1477GB  1478GB  900MB   ntfs                                       hidden, diag
 7      1478GB  1500GB  22.6GB  ntfs         Basic data partition          hidden, msftdata


Model: TOSHIBA TransMemory (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2895MB  2899MB  4194kB  primary               lba


[manjaro@manjaro ~]$

something wrong
EFI only require /boot/efi in vfat ( here fat32) with flag boot & esp on
that means ( no fast boot , no csm , no legacy , disk on AHCI EFI only)

also 21Gb for fat32 is not good

only EFI , need 512Mo /boot/efi fat32 with flag boot & esp

you also have lost entry for windows

first always check all options in Bios

Hi, both Windows & Manjaro are installed in legacy BIOS.
I have Legacy boot enabled as this is the way my bios has always been configured and the way it was configured before I accidentally wiped off my boot record when trying to fix my Windows boot entry not appearing in the grub (bootrec /FixMBR). But yes you're right that I have lost my entry for Windows.

manjaro cannot boot with legacy and GPT

is it really work this ?

Yes, because my Windows installation was Legacy MBR it wouldn't appear on the same GRUB as Manjaro, therefore I had to reinstall Manjaro (manual boot from the USB without the UEFI prefix) and then that allowed both boot entries to appear on the same GRUB.

This all worked fine until I accidentally wiped the GRUB off somehow when trying to fix Windows. ;'( It also works flawlessly on my PC.

no your disk is GPT.

Is it possible that this has somehow been reformatted since and is potentially causing the problem? If so, would it be possible to revert this to MBR and see if that fixes the issue?

on boot Bios USB you have only MBr partition , version GPT is not seen ( this is EFI USB vendor name partition 1 for boot in EFI )

other ways create a 8Mo Bios Grub partition

what do you mean by 8mo sorry? Got a link on how to do that?

    Step 2: Check disk OS boot from UFI for BIOS.
    Step 3: Convert GPT to MBR.
    Step 4: Reboot Or partprobe.
    Step 5: Re-install Grub.

Is this what you're referring to?

you can create a 8Mo partition called Bios_Grub ( see flag option )

Sorry, I'm not understanding what you mean by '8mo partition' and 'see flag option'
Googling it to try and avoid asking too many questions but I'm not getting related results.
Is there a link you can point me to?

Mo = MegaOctets = MegaByte. Go here for detailed instructions for MBR.

Thank you sir!!!

be careful , you will lose all data
--> save it before

1 Like

Manjaro CAN boot legacy in gpt as that’s how my computers are set up right now. You need to create a 8MB unformatted partition using gparted. Then it will stop giving you the “embedding is not possible” error

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by