Brother DCP-T300 not in CUPS

Hello! My printer Brother DCP-T300's driver is not inn CUPS. Can somebody help me? Thank you!
Here are my details:

System:
  Kernel: 4.19.126-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: X200MA v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X200MA v: 1.0 serial: <filter> 
  UEFI [Legacy]: American Megatrends v: X200MA.601 date: 04/19/2019 
Battery:
  ID-1: BAT0 charge: 13.8 Wh condition: 20.7/24.8 Wh (84%) volts: 11.2/11.2 
  model: ASUSTeK X200-30 type: Li-ion serial: <filter> status: Discharging 
Memory:
  RAM: total: 1.84 GiB used: 1.09 GiB (59.4%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Dual Core model: Intel Celeron N2840 bits: 64 type: MCP 
  arch: Silvermont rev: 8 L2 cache: 1024 KiB bogomips: 8663 
  Speed: 500 MHz min/max: 500/2582 MHz Core speeds (MHz): 1: 506 2: 575 
  Flags: 3dnowprefetch acpi aperfmperf apic arat arch_perfmon bts clflush 
  cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept erms 
  est flexpriority fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs 
  pge pni popcnt pse pse36 pti rdrand rdtscp rep_good sep smep ss sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer tsc_known_freq tsc_reliable vme vmx vnmi vpid xtopology 
  xtpr 
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0f31 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.0.7 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:0f04 
  Sound Server: ALSA v: k4.19.126-1-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Lite-On 
  driver: N/A port: f000 bus ID: 02:00.0 chip ID: 14e4:4365 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  v: kernel port: e000 bus ID: 03:00.2 chip ID: 10ec:8136 
  IF: enp3s0f2 state: down mac: <filter> 
  Device-3: Realtek RTL8192EU 802.11b/g/n WLAN Adapter type: USB 
  driver: rtl8192eu bus ID: 1-4.2:5 chip ID: 0bda:818b serial: <filter> 
  IF: wlp0s20u4u2 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 10.56 GiB (2.3%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 
  size: 465.76 GiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: AF10 scheme: MBR 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / size: 457.45 GiB used: 10.56 GiB (2.3%) fs: ext4 dev: /dev/sda1 
  label: N/A uuid: f11d7d8e-7413-4af7-9a8e-79da379b8d77 
Unmounted:
  Message: No unmounted partitions found. 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-3:2 info: Chicony USB2.0 VGA UVC WebCam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b483 
  Hub: 1-4:3 info: Genesys Logic Hub ports: 3 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05e3:0608 
  Device-2: 1-4.1:4 info: Lite-On Broadcom BCM43142A0 Bluetooth Device 
  type: <vendor specific> driver: btusb interfaces: 4 rev: 2.0 
  speed: 12 Mb/s chip ID: 04ca:2006 serial: <filter> 
  Device-3: 1-4.2:5 info: Realtek RTL8192EU 802.11b/g/n WLAN Adapter 
  type: Network driver: rtl8192eu interfaces: 1 rev: 2.1 speed: 480 Mb/s 
  chip ID: 0bda:818b serial: <filter> 
  Device-4: 1-4.3:6 info: Brother Industries DCP-T300 type: Printer 
  driver: usblp interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f9:0393 
  serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 6280.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3200 
Info:
  Processes: 165 Uptime: 39m Init: systemd v: 245 Compilers: gcc: 10.1.0 
  Shell: bash v: 5.0.17 running in: xfce4-terminal inxi: 3.0.37

and here are my printer's details:

Device-4: 1-4.3:6 info: Brother Industries DCP-T300 type: Printer 
  driver: usblp interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f9:0393 
  serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 

please help if someone knows how I can get the drivers. Thank you!

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by