Brother MFC-L2740DW Scanner Not Working

I just purchased a new Brother MFC-L2740DW wireless printer/scanner to replace an Epson unit that died. I'm running Manjaro Deepin 64-bit system. Brother only provides Linux drivers in .RPM or .DEB format. I used the AUR for the printer driver.

The printer works fine. I know this is a no-no, but I installed/used DPKG so I could install the .DEB version of the scanner driver. I have now since realized that the AUR has a brscan4 (or something like that - Not at my computer) scanner driver.

xsane recognizes the scanner, if I run scanimage -L it lists my scanner also. The printer/scanner is wirelessly connected to my system. Pinging the IP shows results so I don't think that is the issue.

I have followed both THIS and THIS, but that has not worked for me.

Additionally I created and added myself to a scanner user group. I don't have the link for another trick, but essentially it tells you to copy files from /usr/lib64/sane to /usr/lib/ because the driver wants to look there for the files it needs.

I also installed VueScan on a trial basis. My scanner works fine with VueScan. Although this may be my ultimate option, I would like to see if I can use xsane instead.

Help is appreciated. I need the scanner for home/business and my daughter for school use.

I think your printer/scanner works with Brother's iPrint & Scan app.

I use that app on my Android mobile devices to address all my scanning tasks on my Brother HL-2280dw machine. Once you scan something, the app allows me 1) to do some basic editing tasks like crop & rotate, 2) save the document locally on the Android device, or 3) share the file via email, Google (cloud) Drive storage and a bunch of other options. (My favorite option is to send the scanned document straight to my Manajaro KDE system using a fantastic tool called KDE Connect.

Another advantage of using a handheld mobile device is you can stand next to the scanner when you need to hold down and scan a thick item, like a book.

The scanner of my Brother MFC-9017CDW works fine after having installed brscan-skey and brscan4 from the AUR.
The configuration works after using the terminal:
sudo brsaneconfig4 -a name=Brother-Scanner model=Brother DCP-9017CDW ip=192.178.168.99

You only have to adapt the name of your device and your IP

1 Like

Why don't you uninstall the .deb version of the scanner driver and then install the corresponding driver from AUR? Who knows, maybe some of the libraries and files in the driver are arranged differently or saved in different places) in Arch-based systems compared with Debian?

You'll have to configure the driver per Bankman's post.

Thank you all for your time. I will try your suggestions this evening when I get home and report back my findings.

It's generally not a good idea to mix distro packages like that. Make sure you remove all drivers, installation packages etc and then do a clean install of the brscan4 AUR package.

Give the brscan-skey tool mentioned by @Bankman a try as well.

Ran, "dpkg --remove packagename" in terminal. Readout appeared to remove .deb package files.
Installed brscan4 and brscan-skey. Ran sudo brsaneconfig4 -a name=Brother-Scanner model=Brother MFC-L2740DW ip=192.168.xxx.xx.

scanimage -L recognizes scanner, it is a wireless scanner so scanimage -q also showed the scanner listed.

Fired-up xsane, splash screen shows device along with my webcam, select my scanner and receive an "Failed to open device 'brother4:net1:dev0' Invalid Argument.

Rebooted system just in-case - Same result.

:frowning2:

Try changing the net.conf and dll.conf sane files per these instructions: https://wiki.archlinux.org/index.php/SANE/Scanner-specific_problems#Network_Scanning

If that fails, Install gscan2pdf and try that one. It has several different frontend settings, and I'm curious whether one of them might work where Xsane fails.

You can choose different frontends in its settings: libsane-perl, scanimage, scanimage-perl and scanadf-perl. Try those out from within the settings menu inside gscan2pdf.

I no longer have a Brother machine, but when I had one, I could never get it working with Xsane when connecting it through the network (and neither does my new Samsung MFC work with it). It's not really any issue for me as Xsane is rather crappy and I prefer to use gscan2pdf and simple-scan. The latest (last?) version of Xsane was released back in 2010, which is probably why it takes some fiddling around to get it working with modern scanners.

With simple-scan my Brother MFC-9017CDW scans very good.
Xsane works too but i don't like the program

Thanks Beherit and Bankman. I didn't want to get too lengthy with my info, but I do have SimpleScan installed and that too would recognize the scanner, but not work.

I will try gscan2pdf and report back. I didn't realize sane was not updated recently. I noticed my version is .9999, and there is a 1.0.25 version, but when I read the wiki to install it, I got scared away. I barely know enough to get around so I didn't want to break anything.

In one of the links I posted, they tell you to actually downgrade sane. I didn't have anything in my cache to downgrade to and I would be in the same situation as if I upgraded, which is not really confident in installing this from scratch.

Xsane is not the same as sane. Xsane is a graphical frontend for sane. Sane is the underlying API/drivers for scanning. Xsane hasn't been updated since 2010, but sane is constantly being updated.

gscan2pdf gave me the same error. I can see it in the device list, I select the device, the program informs you it is updating options and then I receive a "Open of device brother4:net1;dev0 failed: Invalid argument" error window.

On the plus side, I wasn't aware of this program and I like its features.

The net.conf file was OK, it had the correct ip address and if I ran scanimage -q, everything is listed. Peeked into the dll.conf file and my backend (brother4) was listed and not commented out.

I double-checked to make sure the files located in /usr/lib64/sane were copied into /usr/lib/ as per another forum solution post.

Nothing is working.

Will try to uninstall sane and the scanner drivers and reinstall them as my last-ditch effort.

[Here's another reference for any future users reading this: https://help.ubuntu.com/community/sane Scroll to the bottom to read Brother's Scanners section.]

Nada

sudo pacman -Rcsn sane then a reinstallation did not change a thing.

EDIT I just went to http://support.brother.com/g/s/id/linux/en/download_scn.html and much to my chagrin, my model MFC-L2740DW is not listed, so installing brscan4 was of no use for this model.

Does anyone know of a replacement model #?, otherwise I'll have to pay for Vuescan and wait until Brother releases a new driver set.

[quote="steve_dude, post:14, topic:18227"]I just went to http://support.brother.com/g/s/id/linux/en/download_scn.html and much to my chagrin, my model MFC-L2740DW is not listed, so installing brscan4 was of no use for this model.
[/quote]

I wouldn't rule out it's Linux compatible, not just yet. The L-series are Brother's newest ones, but they aren't that new. :slight_smile:

I downloaded the brscan4 drivers from Brothers' website, and inside it, in /opt/brother/scanner/brscan4/models4/ext_11.ini it lists (amongst others):
0x0320,313,1,"MFC-L2740DW",133,4

What could be the cause of it not working for you is either user/group rights and/or udev-settings, as some point out when using brscan4 in AUR: https://aur.archlinux.org/packages/brscan4/

Read the comments there, especially those that explain they got it working by replacing scanner with lp in /etc/udev/rules.d/brscan4.rules.

Also, you might wanna check if the scanner is listed when running the lpinfo -l command, with sudo and without.

DEB packages were removed as mentioned earlier, reinstalled brscan4 from the AUR.

lpinfo required a full path. Running lpinfo -l stated an unknown command /usr/sbin/lpinfo -l with and without sudo just gave me the prompt again. Running /usr/sbin/lpinfo -v showed me this:

network socket
network http
network ipp
network lpd
network https
network ipps
network beh
network smb
network lpd://BRW1C3E8486C606/BINARY_P1
network lpd://BRW40490F909D4A/BINARY_P1

The second BRWxxxxD4A listing is for the Brother printer/scanner.

I have mofified the udev-settings. I made sure I was part of the lp and scanner groups.
(sudo usermod -a -G lp steve) , I checked the sane.d/dll.conf as mentioned previously and brother4 is listed.

I found this in 49-sane.rules, a remnant of the DEB install: http://pastebin.com/sGrxvYv5

"Read the comments there, especially those that explain they got it working by replacing scanner with lp in /etc/udev/rules.d/brscan4.rules."

I noticed, I do not have a brscan4.rules even though I used the AUR to install it.

These 2 things may be the issue. I'll need some time to figure this out ~Thanks again

1 Like

I have an older MFC and both scan and print over LAN (wired) work. Both scan and print did not work at first. I had several weird issues with both scan/print, so I'll throw out some things that seemed to get one or the other working various times:

Ran sudo brsaneconfig4 -a name=Brother-Scanner model=Brother MFC-L2740DW ip=192.168.xxx.xx.

  1. Try the brsaneconfig4 command as root (not sudo), put name/model/ip in quotes and don't use hyphens in name/model (model no. not necessary.. mines called brotha fromanothamotha)

scanimage -L recognizes scannerbr
Fired-up xsane...receive an "Failed to open device 'brother4:net1:dev0' Invalid Argument.

  1. a) Did you try to scan from scanimage instead of xsane? What is the output of scanimage > test.pnm and scanimage -d "brother4:net1;dev0" --source FlatBed -p > test2.pnm? Same error as xsane? Also try as root.

b) Just noticed your xsane error has two colons in device name. Second one should be semicolon (see scanimage command above). Did you copy/paste that error?

  1. If those easy fixes fail, don't overlook your network settings, both in the MFC (check both web UI and on the MFC keypad buttons) and in your router. After working for a few months suddenly mywouldn't scan despite scanimage -L finding it (it may have been "invalid arg" but don't remember) and able to ping the IP from other LAN devices. After many frustrating hours, I fixed it by disabling the "bound to" (ARP binding) setting in my router (tomatousb) for DHCP reservations. I don't know why this worked, but the problem never came back, and it remains my only dhcp reservation without "bound to MAC address" checked.

I had a similar problem where it would no longer print but it would scan. The solution was to set MFC to get a DHCP address. Initially I gave it a static IP in the MFC settings, but it was very flukey. IMO the most reliable setup is MFC set to DHCP, router has a DHCP reservation for MFC (reservation, not a static IP), and if your router has the option, disable ARP binding.

If possible, try installing from scratch with (1) ethernet, (2) MFC internally set to get IP from DHCP server, (3) router set to reserve an address for MFC, (4) router set to NOT bind the reserved IP to a MAC address for MFC.

If that doesn't work, then: (5) jiggle the handle or (6) try turning the MFC, your router, your computer, all the light switches within walking distance, and your car off and on a few times.

I am happy with my MFC7860DW, but you quickly learn what the M and the F stand for after you get a few cryptic error messages. Which reminds me, the 7860DW ppd for cups doesn't actually work for the 7860DW. Instead, you must use the 7840DW ppd, which works perfectly. Why? Because it's a MF... C.

1 Like

I set up my MFC printer/scanner using the http address it has on my home network. I find that works best. The lpd URI doesn't seem to work anymore (to print) as of about a year ago. But my MFC is expressly listed on the support page as being compatible with the brscan3 driver.

It's a bit off-topic, as its not specific to Brother printers.

It takes quite some effort to get auto configuration working within a LAN using DHCP. All manufacturers seemingly share the same standard, but insist on giving it different names: zeroconf, avahi, bonjour.. and then there's mDNS, IPP, DNS-SD, WINS, SLP, SNMP, AirPrint, Mobile Print, Google Cloud Print as well. The printer, router and computer, all need to be configured properly for this plug and play mess to work.

I spent time to get it working in Linux, OS X, Android, iOS and Windows. Weirdly enough, all OS' share the same bug/feature of insisting to resolve the local name to a fixed IP address in the printer/scanner/settings as soon as its entered. I had to alter the printer's IP address to its local name manually in the CUPS config file. In Windows, I could manually alter it in the printer settings, only to have it change back again on the next reboot.

Unless you have an interest in learning to get it to work, it's just as good to use a fixed IP for the printer and use it instead of a local hostname.

Thanks LonelyWoof,

According to my 1st and 3rd postings, I'm relatively confident its not a network connection issue. I have tried scanning via command line with the same error message. I believe Beherit is onto something. I don't have a brscan4.rules file that was created, and the DPKG I initially used created additional entries in my 49-sane.rules files.

I just need to make some time to investigate that further and see if I can somehow make or copy somewhere the brscan4.rules file. I'm leaning towards that being my issue.

Forum kindly sponsored by