Bspwm after update can't boot drive

So you have /boot and /? Is this uefi? Do you use btrfs or lvm?

yes I have boot and /. No I do not use btrfs or lvm

First mount your root partition to /mnt. Then mount your boot partition to /mnt/boot. Then do

  manjaro-chroot /mnt

You can then run commands as if you would have booted to your real system.

thank you.

Okay - I promise this will be last question. Are you saying to do this from mounted partitions in live usb?

I tried that but it says manjaro-chroot not found. If I do a regular boot it drops me into an 'emergency shell' where nothing seems to work.
So here is what I did:
mounted sda2 (root) to /mnt
mounted sda1 (boot/ to /mnt/boot
cd /mnt
typed manjaro-chroot /mnt
said not found

Obviously, I am doing something wrong :frowning:

For some weird reason your installation media lacks manjaro-chroot.

From live iso, assuming sda1 is /boot and sda2 is /

sudo su
pacman -Sy manjaro-tools-base
mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot 
manjaro-chroot /mnt 
pacman -Syu 
mkinitcpio -P 
update-grub 
exit
reboot
1 Like

got it! thanks. Really appreciate the help.

thank you

Did it work?

no it didn't. I still really appreciate all your help. Still getting the 'cant find UUID device'.

will research how to fix that.

Okay, let's try to cut the Gordions knot: chroot in and reinstall grub with

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=manjaro --recheck
update-grub 

thank you for hanging in there. I don't use efi so the command is the same without efi?

Oops, I misread your earlier comment. The command for legacy grub is

grub-install --recheck /dev/sda

Assuming your installation is on sda

comes back with:

grub-install: error: cannot find EFI directory.

Is your iso booted in uefi mode?

oh duh! sorry about that will reboot

Try this installation command in chroot:

 grub-install --target=i386-pc /dev/sdX

That should force legacy installation

I assume linux49 is used here. Known to had an issue, which is fixed now ...

After grub installation, check that grub passes the right kernel parameter. In /boot/grub/grub.cfg look for the lines that say root=UUID=

YOu can find the right UUID with blkid

sudo blkid /dev/sda2
/dev/sda2: UUID="6376774c-a2fe-474f-b6d7-e36c93b503df" TYPE="ext4" PARTUUID="82c66e2f-35b0-46d1-a01a-d692e5b7c1f8"

Okay, the link Philm posted probably has the right solution. Try that.

@philm @Chrysostomus: I want to think both of you. The link philm provided worked!

@Chrysostomus thank you again for all your help. It helped me to at least get my data off.

Everything is working fine now. Also, thanks to benbob for figuring out the solution..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by