[BUG] RPI4 missing 5ghz WiFi

Hey there, when I look for wifi on my raspberry pi 4, I can only find 2.4ghz bands. I tried raspbian and it was detecting 5ghz just fine, but when I go back to manjaro it doesn't recognise it. I have properly set my country code and even tried different desktop environments to no avail. (If it helps I use KDE mainly)

If you can access your router settings set the 5 GHz chanel to 36 or 40. Sometimes lowering the bandwidth helps as well.

I had this problem as well, my raspberry pi 4 couldn't see my 5GHz wireless AC network on band 157 when I installed Manjaro 19.12. I found out that the ARM edition of Manjaro did not have the wireless-regdm and crda packages installed by default. Once I installed those two packages, I set the CRDA domain using sudo iw reg set US and I could see my network.

I also uncommented my country code in the /etc/conf.d/wireless-regdom so that the settings persisted and updated the /lib/firmware/brcmfmac43455-sdio.bin wireless firmware file with the new one for the Raspberry Pi 4 for improved reliability as mentioned here . Hope that helps.


Good catch. I get so used to those packages being installed by default on other editions that I never expect they will be missing.

Hi kayhan1996. I have the same issue with my rpi4 seeing 5ghz and tried the incantation you describe in your post but was unsuccessful. While I have used Linux in the past I am far from an expert. So if you would describe how you fixed your rpi4's 5ghz problem in more detail, I would appreciate it.

Thanks, bwo.

Hey sorry for the late response. Can you check what country you raspberry pi’s wifi is set to using the command iw reg get. If you get an error, that probably means you don’t have the packages I mentioned installed, install them using sudo pacman -S wireless-regdm crda. Try to set your country code using sudo iw reg set CODE Where CODE is your country code eg. US CA DE etc. Then check they got set properly using iw reg get, which should list your country.


The solutions on this post work great. the 5GHz wifi on the pi 4 works great now. It has the best wifi chip out of all my devices in the home.

I wanted to point out that there is no wireless-regdm package, I installed wireless-regdb


Also for the sake of having all of the information in the right spot, here is the code for getting the latest BRCM firmware for the WIFI:

sudo mv -v /lib/firmware/brcm/brcmfmac43455-sdio.bin /lib/firmware/brcm/brcmfmac43455-sdio.bin.orig
sudo wget https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm/brcmfmac43455-sdio.bin -O /lib/firmware/brcm/brcmfmac43455-sdio.bin
sudo sync
sudo reboot

Whats the difference in the new firmware?

Not sure if it was the location setting or the firmware that did it but the WIFI speeds are much faster after I did it all.

It seems the new wifi broke bluetooth, so they reverted it shortly after.

But if you still get better wifi and have bluetooth I might update the firmware package.

I haven't tested bluetooth yet but it claims it is working. Let me try to connect something to it.

Yup no issues. Just connected my CAD Mouse to it and transferred a file from my windows PC to it. Looks GTG.

Also tested a few things myself and uploaded new firmware package to unstable branch.

1 Like

@Strit sweet! I'm going to read through the contributing guide. I'd love to help make Manjaro-ARM better!!

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by