Building Ferdi from AUR

Hi, guys.

I'm having trouble installing ferdi from AUR.
Below is the error log:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'install' ]
2 info using npm@6.14.6
3 info using node@v14.5.0
4 verbose npm-session 75f274a0454dcfdf
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall ferdi@5.6.0-beta.1
7 info lifecycle ferdi@5.6.0-beta.1~preinstall: ferdi@5.6.0-beta.1
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 36ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 1ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 2683ms
16 silly install loadAllDepsIntoIdealTree
17 http fetch GET 200 https://registry.npmjs.org/electron 717ms
18 silly fetchPackageMetaData error for electron@8.5.0 No matching version found for electron@8.5.0.
19 silly fetchPackageMetaData error for electron@8.5.0 No matching version found for electron@8.5.0.

23 verbose type version
24 verbose stack electron: No matching version found for electron@8.5.0.
24 verbose stack     at pickManifest (/usr/lib/node_modules/npm/node_modules/npm-pick-manifest/index.js:122:13)
24 verbose stack     at /usr/lib/node_modules/npm/node_modules/pacote/lib/fetchers/registry/manifest.js:24:14
24 verbose stack     at tryCatcher (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)
24 verbose stack     at Promise._settlePromiseFromHandler (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:517:31)
24 verbose stack     at Promise._settlePromise (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:574:18)
24 verbose stack     at Promise._settlePromiseCtx (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:611:10)
24 verbose stack     at _drainQueueStep (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:142:12)
24 verbose stack     at _drainQueue (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:131:9)
24 verbose stack     at Async._drainQueues (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:147:5)
24 verbose stack     at Immediate.Async.drainQueues [as _onImmediate] (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:17:14)
24 verbose stack     at processImmediate (internal/timers.js:458:21)
25 verbose cwd /var/tmp/pamac-build-zeno/ferdi-git/src/ferdi-git
26 verbose Linux 5.7.9-1-MANJARO
27 verbose argv "/usr/bin/node" "/usr/bin/npm" "install"
28 verbose node v14.5.0
29 verbose npm  v6.14.6
30 error code ETARGET
31 error notarget No matching version found for electron@8.5.0.
32 error notarget In most cases you or one of your dependencies are requesting
32 error notarget a package version that doesn't exist.
32 error notarget
32 error notarget It was specified as a dependency of 'ferdi-git'
33 verbose exit [ 1, true ]

There are more irrelevant (I think) lines, but due to the char limitations I couldn't post all of it.

Any help would be great :slight_smile:

ferdi requires electron8, which is not installed automatically as a dependency because it's also in AUR.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by