Built-in laptop keyboard input sometimes working slow

Hi everyone,
My laptop keyboard input sometimes working very slow for no reason, it delayed while I'm typing on it. But that problem doesn't exist when I'm using external keyboard. What I've done so far to resolve this issue are :

  1. Try different kernel version, I've tried kernel linux415, linux417, and 418.
  2. Try to use cli mode (assuming it's video driver or rendering issue)
  3. downgrade libinput to version 1.10.1 and xf86-input-libinput to version 0.27.1
  4. Try to use another distro, which are ubuntu 18.04 and kali
  5. Boot into my windows 10

point number 1,2,3 : the problem still persist
point number 4 and 5 : the problem resolved

Maybe it's just lag because of huge cpu load.. Well, I don't think so because I've been looking into htop and system-monitor while doing my job just to make sure the keyboard input lag is caused by huge cpu load, but it isn't.

Inxi output :

System:    Host: alina Kernel: 4.18.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.0 
           Desktop: KDE Plasma 5.13.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A315-41 v: V1.01 serial: <filter> 
           Mobo: RR model: Metapod_RR v: V1.01 serial: <filter> UEFI: Insyde v: 1.01 date: 01/19/2018 
Battery:   ID-1: BAT1 charge: 16.4 Wh condition: 33.9/36.7 Wh (92%) model: COMPAL PABAS0241231 
           status: Discharging 
CPU:       Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP 
           arch: Zen L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19972 
           Speed: 1497 MHz max: 1600 MHz Core speeds (MHz): 1: 1591 2: 1583 3: 1476 4: 1392 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] driver: amdgpu v: kernel 
           bus ID: 03:00.0 
           Display: server: N/A driver: ati,radeon unloaded: modesetting resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus ID: 03:00.1 
           Device-2: Advanced Micro Devices [AMD] driver: snd_hda_intel v: kernel bus ID: 03:00.6 
           Sound Server: ALSA v: k4.18.4-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: 2.3LK-NAPI 
           port: 2000 bus ID: 01:00.1 
           IF: enp1s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci v: kernel 
           bus ID: 02:00 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 280.91 GiB (30.2%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
Partition: ID-1: / size: 107.28 GiB used: 23.61 GiB (22.0%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda8 
Sensors:   System Temperatures: cpu: 43.6 C mobo: N/A gpu: amdgpu temp: 43 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 183 Uptime: 1h 19m Memory: 3.33 GiB used: 1.60 GiB (48.2%) Init: systemd Compilers: 
           gcc: 8.2.0 Shell: zsh v: 5.5.1 inxi: 3.0.21 

I hope someone could help :slight_smile: , Thank you.

I have a similar lag (Desktop + usb keyboard) in Plasma Testing.

System:    Host: ma64testimg Kernel: 4.18.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.0 
           Desktop: KDE Plasma 5.13.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P7H55-M v: Rev X.0x serial: <filter> BIOS: American Megatrends 
           v: 1101 date: 08/18/2010 
CPU:       Topology: Dual Core model: Intel Core i3 560 bits: 64 type: MT MCP arch: Nehalem rev: 5 
           L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26771 
           Speed: 2215 MHz min/max: 1200/3333 MHz Core speeds (MHz): 1: 2215 2: 1928 3: 2142 4: 1869 
Graphics:  Device-1: NVIDIA GF116 [GeForce GTX 550 Ti] driver: nvidia v: 390.87 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.1 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 550 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.87 direct render: Yes 
Info:      Processes: 221 Uptime: 7h 51m Memory: 7.72 GiB used: 3.64 GiB (47.2%) Init: systemd Compilers: 
           gcc: 8.2.0 Shell: bash v: 4.4.23 inxi: 3.0.21 

Maybe someone has an idea..

First, please review Accessibility options. Some DE's have something like 'slow keys' setting there. Apparently something like a 'screen reader' can also be a culprit - often found in the same Accessibility or Universal Access settings.
Also - this could be related to microcode stuff. AMD just got a new microcode disseminated in manjaro. Maybe check if you have it installed and test with/without.
...you may also want to go poking around modprobe.d files for anything funky.
..and I just thought of a longshot. Check lsmod for any weird modules being loaded or getting in the way. Maybe even try disabling some possible bad actors like joystick modules or similar.
Otherwise I'm pretty stumped too if it isnt hardware or system load ...

1 Like

Both options are available but defaultly disabled in Plasma, and I'm pretty sure if this problem is not depend on the DE, because I have bspwm and I have lag there and even without starting xserver I still got the lag in cli mode.

AMD microcode for manjaro/arch is bundled in linux-firmware package and it's installed by default, so I can't do anything on it. I just found intel-ucode package installed in my system and remove it just now.

I found nothing in modprobe.d, but then I make a config there to block joydev to load as you said, but while I'm typing in this post the keyboard input is still lag.

Ack. Sorry - those were just 'off the cuff' ... hopefully someone else has some more ideas.

Different situation than the OP, but you could try an old school PS/2 keyboard.

The point is, I didn't have this lag before some recent update. I just suspected a Plasma factor/combination with OP :wink:

The new FDlimit introduced with last update (stable 31/08) made my brightness control weird (working but with an increasing delay at each strike) maybe your problem is related.
Comment the following line and reboot to test:

DefaultLimitNOFILE=1048576

In:

/etc/systemd/system.conf.d/40-fd-limits.conf
/etc/systemd/user.conf.d/40-fd-limits.conf
1 Like

Oh yeah, forgot about that one. Certainly worth checking.
I think on mine I'm using 4096

BTW @sagwascript

Is not exactly accurate. There is now a package called amd-ucode

But I still think the FDLimit thing is another new change worth looking at
(it will also soon be reverted it seems, so an update may soon fix it)

I have followed @Yoy0 's post, now I'm still testing it and I hope it really works.

about the amd-ucode package, yesterday I was trying to install it but pacman says if that package had a conflict with linux-firmware, but I just do it again just now and it works. now I'm working on it

EDIT : The test break, the lag comes out. problem not yet resolved :cloud_with_lightning:

1 Like

The newest Testing Branch update also changed upower package due to some problems that were initially thought to originate from the FDlimiting, so make sure to keep an eye out and do your updates :wink: .

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by