Bumblebee doesn't work and screenfetch can't find my GPU

Did you try auto install proprietary drivers?

Yes. When doing it through the Manjaro Settings Manager, I get the following:

Starting
> Skipping already installed config 'video-hybrid-intel-nvidia-bumblebee' for device: 0000:01:00.0 (0300:10de:1c20) Display controller nVidia Corporation GP106M [GeForce GTX 1060 Mobile]
> Skipping already installed config 'video-hybrid-intel-nvidia-bumblebee' for device: 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation


Done ...

Check if bumblebee service has started:

systemctl status bumblebeed

To check which gpu is enabled:

cat /proc/acpi/bbswitch

Also let's see if you are in the right groups (also from terminal)

Status:

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2018-11-07 15:01:49 -03; 1h 54min left
 Main PID: 465 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 1.6M
   CGroup: /system.slice/bumblebeed.service
           └─465 /usr/bin/bumblebeed --use-syslog

nov 07 15:01:49 manjaro-pc systemd[1]: Started Bumblebee C Daemon.
nov 07 15:01:50 manjaro-pc bumblebeed[465]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started
nov 07 12:02:42 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:05:30 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:06:40 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:06:46 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:11:29 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:17:17 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:25:42 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card
nov 07 12:26:41 manjaro-pc bumblebeed[465]: Could not enable discrete graphics card

Groups:

bumblebee network power lp wheel magluf

Now for the last one (!!!):

0000:01:00.0 OFF

I'm failing to find out how to turn it on, though.

See:

[magluf@manjaro-pc ~]$ sudo tee /proc/acpi/bbswitch <<< ON
ON
[magluf@manjaro-pc ~]$ cat /proc/acpi/bbswitch
0000:01:00.0 OFF

have you try this
in grub ( or lines boot kernel on grub commands )
GRUB_CMDLINE_LINUX="acpi_osi=! acpi_osi=“Windows 2009”

1 Like

For example:
primusrun glxgears
or
optirun glxgears
each application you want to open with it needs primusrun or optirun

Yeah, that was needed for me to get Manjaro to work at all on my machine, along with other setups, as detailed here.

I've tried running both commands before, with no luck:

primusrun:

primus: fatal: Bumblebee daemon reported: error: Could not enable discrete graphics card

oprtirun:

[ 4972.394892] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 4972.394952] [ERROR]Aborting because fallback start is disabled.

Have you reboot since you started making changes ?

Several times xD My uptime is 48m on the screenfetch log on OP.
Gonna reboot now, anyways! xD

Nope. Still nothing after reboot.

Is linux419-bbswitch installed properly ?

Yep. I have tried kernel 4.14 as well.

Okay, so I've uninstalled bumblebee and bbswitch completely and screenfetch now recognizes my GPU:

 ██████████████████  ████████     magluf@manjaro-pc
 ██████████████████  ████████     OS: Manjaro 18.0.0 Illyria
 ██████████████████  ████████     Kernel: x86_64 Linux 4.19.1-1-MANJARO
 ██████████████████  ████████     Uptime: 1m
 ████████            ████████     Packages: 999
 ████████  ████████  ████████     Shell: bash 4.4.23
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: Deepin 15.7
 ████████  ████████  ████████     WM: Metacity
 ████████  ████████  ████████     GTK Theme: Adapta-Nokto-Eta-Maia [GTK2/3]
 ████████  ████████  ████████     Icon Theme: Papirus
 ████████  ████████  ████████     CPU: Intel Core i7-8750H @ 12x 4.1GHz [62.0°C]
 ████████  ████████  ████████     GPU: GeForce GTX 1060 with Max-Q Design
 ████████  ████████  ████████     RAM: 1377MiB / 15741MiB

I'll reinstall everything and see if I get lucky and post here about it.

UPDATE:

Yep. That did it:

  1. Uninstalled bbswitch;
  2. Uninstalled bumblebee;
  3. Reboot;
    (after the reboot, I could already see my GPU on the screenfetch output)
  4. Installed bbswitch by package manager (using 4.19 kernel and I can verify that it did not work on 4.14);
  5. Installed bumblebee as per this post;

And that's it. I hope this can help people that found the same issue.

OBS.: I kept the TLP changes described in this post.

2 Likes

This is the only different step I can see and.. I can't see the real difference, since

this is supposed to install mhwd profile, which is supposed to install bbswitch too.
Can you please check and post your current settings:

cat /etc/modprobe.d/*.conf | grep bbswitch
cat /etc/modules-load.d/*.conf | grep bbswitch
cat /etc/systemd/system/*.service | grep -B 8 -A 5 bbswitch
cat /etc/bumblebee/bumblebee.conf | grep -B 2 "bbswitch|TurnCard"
cat /etc/modprobe.d/*.conf | grep bbswitch
options bbswitch load_state=0 unload_state=0

cat /etc/modules-load.d/*.conf | grep bbswitch
# no output

cat /etc/systemd/system/*.service | grep -B 8 -A 5 bbswitch
[Install]
Alias=display-manager.service
[Unit]
Description=Enable NVIDIA card
DefaultDependencies=no

[Service]
Type=oneshot
ExecStart=/bin/sh -c 'echo ON > /proc/acpi/bbswitch'

[Install]
WantedBy=shutdown.target


cat /etc/bumblebee/bumblebee.conf | grep -B 2 "bbswitch|TurnCard"
# no output
1 Like

You might want to specifically assign switching method to bbswitch

[driver-nvidia]
PMMethod=bbswitch

even I think the command I gave you was wrong. This should be better

cat /etc/bumblebee/bumblebee.conf | grep -B 2 "bbswitch\|TurnCard"

For the record:

  • screenfetch often does not show secondary Nvidia unless it is ran with optirun
  • You might keep a note of this command to try wake up your card manually
sudo echo 1 > /sys/bus/pci/rescan

The service found "Enable NVIDIA card", have you manually created it or which package does it belong to?

pacman -Qo /etc/systemd/system/nvidia-enable.service

(change file name if it is different)

Done! :smiley:

Here's the output of that:

# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
--
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
--
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=bbswitch

Duly noted! Thanks for the tip.

It doesn't belong to any package and I haven't installed it manually.

error: No package owns /etc/systemd/system/nvidia-enable.service

Things have been running pretty smoothly, either way, after the setup I've done in the solution of this post.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by