Bumblebee: GRUB ACPI boot options

I've been doing some reading around pcie_port_pm (after AMD issue *atombios stuck in loop for 5 sec* SOLUTION) and came across this on GitHub:

It's a list of GRUB option workarounds for newer hybrid Nvidia laptops. There's one common item:

acpi_os=! acpi_osi="Windows 2009"

that might be worth testing.

I'm not sure if it's possible to pass this as an option specifically when selecting an item in the GRUB boot menu (for the installer images), but if so, and it doesn't break older laptops, it might be worth trying out.

I'm about to test it on my hybrid now (which already works correctly).


No apparent negative effects on my i7-3630QM + GTX680M.

Anyone else for some testing?

1 Like
Nvidia GTX1070 Mobile laptop fails to boot
Installing Manjaro KDE 17.1.9 on MSI GE62 6qf [bumblebee+NVIDIA]
Manjaro KDE freeze at installation to 75%
Screen Tearing on Gnome running Bumblebee
External Monitor Not detected HDMI
Can't boot Manjaro on Intel/NVidia setup, can't use Xorg
Installing Manjaro freezing at Hardware Configure
Cannot manage to have a external monitor and laptop display working at the same time
System76 & Manjaro
Support for Intel's Kaby Lake-R (8550u, laptop with NVIDIA GPU)
Won't boot beyond the login screen
Nvidia non-free driver prevents me from loading Manjaro
Problem with bumblebee and window effect in Deepin edition
Help installing CUDA on nvidia optimus enabled system
Issues after trying to use mhwd to configure graphics drivers
Issues after trying to use mhwd to configure graphics drivers
Black screen with NVIDIA proprietary drivers and GeForce GT 330M
My nvidia drivers sabotaging me
Problem installing NVIDIA Drivers - without NVIDIA Optimus
Nvidia proprietary drivers not installable
Cannot install Manjaro with the "nonfree" driver option
Optimus setup with nouveau works perfectly on live ISO but doesn't work on a fresh installation
Unable to boot into system after installation
Cannot enable nvidia gpu for bumblebee XPS 15 9550
Manjaro KDE and Nvidia
Nvidia drivers don't work
Problem with Manjaro on MSI GP72MVR 7RFX gaming laptop
[SOLVED] System hang when using mhwd on Entroware Kratos
Bumblebee Troubleshooting|20181229
Dell Inspiron Gaming 7567 - Multiple Hardware Issues, Booting problems and hardware management
[SOLVED] Bumblebee not working after suspend
Manjaro kde 17.1.5 freeze after login
Nvidia Drivers with Intel Integrated Graphics - Current Status?
TLP: "pcieport" power saving
I can't boot Manjaro without connected to AC Adapter
Segmentation fault when I try to run xfce4-display-settings
Error installing Manjaro 17.0.6 KDE

The other one that's worth trying is


which should not be affected by how old the machine is; therefore, if it helps I suspect it could be enabled by default.


1 Like

Just today I was wondering if "non-free driver" options shouldn't be renamed to "nvidia", for users understandability

Anyway, I dunno, maybe an additional "alternative nvidia safe mode something" entry (perhaps nested inside non-free driver?) might be better.

I wonder if these options can be set during boot and before bumblebee is installed. This means it can be seamless instead of having multiple options for different setups.

I don't know what effect the GRUB option would have on older (and non-hybrid) machines. I suspect not a lot, but then again it may cause issues.

I have tried all these options, but non of them work for me.
The only way it works in my setup is with acpi_osi=! acpi_osi="Windows 2009"

Btw, is there a way to double check if NVIDIA is really working and if a program is not 'secretly' going to the INTEL driver instead?
The reason why I am asking, is because I can;t run steam with primusrun, although it seems to work when I use that in the command section per game/application.

You need to say what your setup is for this to be useful.

That's a key word/phrase which should prompt you to start a new thread. #manjaro-development is for purposeful discussion rather than getting help.

No problem.

My setup is an Asus ROG GL552VW-CN108T
This one has a GeForce GTX 960M, Intel Core i7-6700HQ (Skylake) and of course the Intel HD Graphics 530.

edit: running on the 4.15 kernel, xfce minimum setup.

The way I installed it is with the Architect disk and installed the drivers in chroot mode.
Than booted immediately with these commands.
I do have some strange issues with Steam, but I am not totally sure if that's an issue in XFCE?

1 Like

Bumblebee switch is responsible for switching between gpus.

cat /proc/acpi/bbswitch

OFF = intel, ON = nvidia.

You can also use optirun --status.


3 posts were split to a new topic: Touchpad not working in GNOME

Sadly I have really bad issues with my hybrid HD 630 & nvidia 1050. I can't run installation in "nonfree" because my PC stops at "TLP startup/shutdown". Only "free" works but then I can't install ANY driver because laptops is freezing. When I try to click on something that is connected to MHWD or terminal "driver" checking commands few sec. After laptop is freezing. Updating to newest kernel & pacman -Syu do not solve problem, same as with acpi_osi. I hope you'll patch it in near future because I'm sick of hopping distros and manjaro is solid one I always wanted to test but had issues with compatybility.

I was having the same issues with my laptop as well. Mine was a Intel HD 630 with a nvidia 1050Ti. Had the same issue as yours.

Hope this helps.
Won't boot beyond Login Screen

Forum kindly sponsored by