Bumblebee not working, PRIME broke my setup

My focus right now is to get the Nvidia propietary drivers working properly. I managed to install bumblebee with supposedly the right driver but Nvidia config screen shows wrong resolutions and hz and performance is pretty bad. Xrandr shows proper resolution so I guess it's just bumblebee design issue.
After that I decided to go with only Nvidia driver (no bumblebee) but apparently that's not possible.

In the end I decided to this tutorial even when I don't want primus ( [HowTo] Set up PRIME (output offload) with NVIDIA proprietary driver ) 3 times and ended up formating 3 times I call for resource helps to start from scratch.

Which gpu do you have?

which display manager do you use?

if stuck in black screen , output of xorg.log and systemctl status display-manager.service could provide useful information


Hi vetzki. Thanks a lot for your reply.
I am using a community build called Manjaro i3.
I think my display manager is called xrandr, but I don't know how to check it.

Right now I have formatted the computer again so can't provide xorg file just yet. I'm following a tutorial that I found that looks very promising(it is a step by step version of the previous one that I linked) but then I had another problem that's blocking me; I'll open another thread for that issue and come back after I solve it.

To the admins: please leave this thread open since I'll update it as soon as I overcome the blocking issue. Then I'll edit this postm I. just wanted to be polite and reply to vetzki for offering his help.

With display manager I mean sddm, lightdm, gdm, ... . Or do you use the default which is included in i3 community edition (probably)?
Please check also which nvidia gpu the laptop has

Last but not least if you solved your other issue, just reply instead of edit. If you just edit your first post then likely nobody will notice

My Nvidia GPU is gtx1070 (laptop is msige73 8rf)
The display manager is lightdm I think, which is included in that build (ssdm and gdm are not).

The other issue I am just going to reproduce it again so I can provide accurate details. Will post it in a few minutes since I just reinstalled manjaro. Thanks a lot for your help and patience~

please if you want any help on this forums
you have to give more details

You are right, Stephane.

Initially this post was asking for resources to learn how to setup a Nvidia gpu, not a specific question. but an administrator split it in two.

The reason why I didn't provide more details is because I just found another tutorial and I was following it. It looked very promising, so I deleted my manjaro installation.

Anyway, following this new tutorial I found the blocker issue is this one:
Manjaro-settings-manager freezes when accessing the hardware section

I guess we can just close this thread.

so did you get your graphical issues resolved?

Not at all. As I said, I'm stuck in the other thread, that's why I initially suggested to leave this thread on-hold in order to keep the forum clean, but apparently I got the wrong result. Once I'm able to fix my graphics I'm determined to write a step by step tutorial so total newbies like me can follow it. For now, I'm stuck at this step:

As I said, we can close this thread, which was supposed to be a "give me a good tutorial" one, but got split by an administrator.

Thanks for your reply

Edit: actually, I just noticed that your can actually click the little arrows in the tutorial and they unfold and provide the commands I was looking for. It is, indeed, a great tutorial! I didn’t know you could click those arrows!

ok, responded to your other thread. this problem is easily worked around with manjaro-chroot

1 Like

It was split because you were wanting help configure your graphics drivers.

A "good tutorial" is already available, but if you can't follow it then that's a different issue.

But, seeing as "an administrator" has made a mess, let's close these threads.

Forum kindly sponsored by