Bumblebee/optirun

Hey, having trouble with bumblebee switching.
Running optirun glxgears hangs.
I've tried up to date kernels 4.14 and 4.16 with no luck.
Acer nitro 5 laptop, gtx 1050m.

Modifications i currently have:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi='!Windows 2013' acpi_osi=Linux"

/etc/X11/mhwd.d/intel.conf added:

Section "OutputClass"
    Identifier "intel"
    ModulePath "/usr/lib/xorg/modules/extensions"
EndSection

Acpid,bumblebeed are enabled and running.

cat /proc/acpi/bbswitch

0000:01:00.0 ON

dmesg|grep bbswitch

[    2.093265] bbswitch: version 0.8
[    2.093269] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.093272] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    2.093368] bbswitch: detected an Optimus _DSM function
[    2.093463] bbswitch: disabling discrete graphics
[    2.193378] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off

grep -i glx /var/log/Xorg.0.log

[     3.708] (II) LoadModule: "glx"
[     3.711] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     3.717] (II) Module glx: vendor="X.Org Foundation"
[     3.761] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[     3.761] (II) AIGLX: enabled GLX_ARB_create_context
[     3.761] (II) AIGLX: enabled GLX_ARB_create_context_profile
[     3.761] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[     3.761] (II) AIGLX: enabled GLX_INTEL_swap_event
[     3.761] (II) AIGLX: enabled GLX_SGI_swap_control
[     3.761] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[     3.761] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[     3.761] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[     3.761] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[     3.761] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[     3.761] (II) AIGLX: Loaded and initialized i965
[     3.761] (II) GLX: Initialized DRI2 GL provider for screen 0

optirun -vvv glxgears

[  139.359825] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  139.360195] [INFO]Configured driver: nvidia
[  139.360627] [DEBUG]optirun version 3.2.1-2017-02-27-Format:%h$ starting...
[  139.360655] [DEBUG]Active configuration:
[  139.360662] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  139.360670] [DEBUG] X display: :8
[  139.360678] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[  139.360686] [DEBUG] Socket path: /var/run/bumblebee.socket
[  139.360693] [DEBUG] Accel/display bridge: auto
[  139.360705] [DEBUG] VGL Compression: proxy
[  139.360725] [DEBUG] VGLrun extra options: 
[  139.360738] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[  139.361102] [DEBUG]Using auto-detected bridge primus
^C[  247.040245] [WARN]Received Interrupt signal.
[  247.040276] [DEBUG]Socket closed.
[  247.040321] [WARN]Could not read data! Error: Bad file descriptor
[  247.040342] [DEBUG]Socket closed.
[  247.040361] [DEBUG]Killing all remaining processes.

journalctl -p err -b

bumblebeed[320]: [XORG] (EE) kbd: <default keyboard>: failed to set us as foreground pgrp (Inappropriate ioctl for device)
bumblebeed[320]: X unresponsive after 10 seconds - aborting

I admit i havn't tried every kernel parameter combination i've found researching this topic, well at least not systematically yet, am i missing something obvious before i start?

Solution:
post 14 below:
https://forums.opensuse.org/showthread.php/522828-optirun-fails-failed-to-set-DRM-interface-version-1-4-Permission-denied/page2

I had dropped input/output policies of ipv6 with ip6tables, a quick change to accept and optirun -vvv glxgears works. Allowing localhost is enough, appears that the kernel paramaters,config additions are not required for me either, it would have run out of the box.....
Thanks for your time.

Have you tried primusrun ?

Thanks for the reply.
(glxgears alone is working)
primusrun glxgears hangs with no output.

optirun -vvv glxgears actually throws the following error now:
[ERROR]Failed to retrieve LibraryPath setting.
My first post was the output from first run, so perhaps something changes for subsequent runs.
The other outputs posted seem consistent.

I did have an error before in bbswitch that a 'nvidia' driver was in use, but at least one of the modifications i mentioned has prevented it for now.

Did You try install bumblebee-git package? It help with my optimus card.

Thanks for the suggestion, i might try this evening.
Solution added to first post.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by