Bypass password at GNOME (GDM) login

Hello everybody,

I would like to bypass the login-password prompt in GNOME, so that other people can use the machine without needing the password (I do not plan to create other user accounts).

Right now my instalationl has a single user which is also administrator, and at the installation phase I chose to use the same password for the root and for my user (a poor choice probably).

I have read a few posts on how to do this but sometimes I was not sure if it was safe enough in my case (like adding the nopasswdlogin group).

I have also changed the /etc/gdm/custom.conf

# Enable automatic login for user 
[daemon]
AutomaticLogin= *username*
AutomaticLoginEnable=True

with no success...

Sorry for the maybe simple question, hope somebody can direct me to a simple solution

Please use the Settings > Details > Users and enable Automatic login ...

Has to be:

[daemon]
AutomaticLogin=username
AutomaticLoginEnable=True
1 Like

Thank you @bogdancovaciu
Sorry for the error in the post, but it was actually as you suggest (I have fixed the missing newline in the question).

Adding this did not solve the problem... :frowning:

Then you have to:
sudo rm /etc/gdm/PostLogin/Default
from terminal
i guess will work after that.

1 Like

Did you also remove the whitespace between the = and the username?

1 Like

Yes, @Strit the config file looks like this:

# GDM configuration storage

[daemon]
AutomaticLogin=username
AutomaticLoginEnable=True

# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

why do it the hard way, you can do it simply in settings so simple so easy

Screenshot%20from%202019-06-02%2010-05-59

Thank you @mandog, but actually that was the first thing I tried (with no luck).

screen

I am really not sure what is going on...

Would you suggest to use another Display Manager? Although I am not sure if this would make any sense... I am totally fine with the one I am using.

Thanks anyway for your help.

Hello @bogdancovaciu, I also tried removing the 'Default' file as you suggested but it only works for the fist login, and actually asks me for the login keyring password

I am considering to remove my password using passwd?
What do you think?

Almost fixed!
First of all I am sorry for problably asking the question in a not completely correct way.
In shot I wanted to be able to login without typing the password at login screen. So in case of logout again I want to log back in without typing the password.
It seem to work through the procedure described in this post under passwrdless login.

The only problem I am facing now is the password request from gnome-keyring, will search the forums if this can also be set automatically at login

Fixed also the issue with gnome-keyring by simply turning off the daemon as described in this post.

Very happy now :smiley:
thanks everybody

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by