Cable Modem Reboots

Try changing your encryption method to AES

Do not use a hidden SSID

It's AES already but I use Ethernet Cat 6e for my network that have gigabyte ethernet like my PC's and media devices. I just use wireless for phones and tablets.

Well this is very strange. Have you tried browsing your network from a live boot image on the problematic computer. This will at least tell you if it has something to do with your configuration or possibly recent updates or kernel changes.

Are you using an r8168 adapter on this computer.

Yes I am using an r8168 adapter. That's a good idea to run from the DVD.

Which driver are you using. If your using r8168 drivers, then blacklist the r8168 driver and use r8169. If your using r8169 drivers the blacklist the 69 drivers and use the 68.

If it works on the live boot then check which driver is loaded on live boot and the configuration files in /etc/modprobe.d

According to the Hardware Configuration both Open Source and Installed are checked. So is that a yes?

Forgive me but I have very little experience with drivers.

The other thing you might want to try doing is assign a static ip address by Mac address association if your router supports this.

Try this first.

Reboot both your router and computer after assigning a static ip.

My router does support that but all my PC's and media devices have static IP's. I set the troubled PC by MAC Address Association.

Well you've already done all the right things. Try the live boot. See what happens.

Ok doing it now. So far so good but I really don't wanna have to reload this machine it has all 8TB of my media on it shared through NFS. Looks like I'm gonna be real busy this weekend.

Is the live system using the r8169 driver

I believe so according to hwdetect.

If the live system is using r8169 then when you reboot into your Manjaro install go into MSM. In MSM untick the non free r8168 drivers then reboot. I think this is all you will have to do, but I'm not 100%sure because I use the blacklist method.

1 Like

I will give it a try. Thanks for all the help.

Hope that works. If not I will give you instructions on blacklisting. Be sure to mark your thread solved if it corrects the problem. Good luck.

See this post if you want to follow the r8168 uninstall/blacklisting procedure.

3 Likes

I went into MSM and unticked the non free like you said and rebooted and then had no network. I went into Network in the settings and turned it on and set it up and have not had a reboot on the cable modem since. So I consider it solved. Thanks so much for all your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by