Calamares cannot install on SSD LV as parallel install next to Fedora

Hi All,

This is making my brain hurt already!! I've already used the downloaded .iso to install Manjaro (Fringilla) on an old laptop - in that case I just created brand new partition in fdisk and then let Calamares do its thing.

Now I'm trying to install the same image on my existing Fedora system. I have 3 HDDs - one for data, one for music, and one current system drive, an SSD which hosts Fedora on MBR partition using grub2.

Going through the install screen with Calamares, I get to select install destination, and the gui chooses for me but defaults to the wrong disk. At this screen is the option to "install alongside" but since this defaults to an unwanted location I select the desired location using the dropdown (the SSD which currently has a grub partition and the rest is a single LV ext4 containing the Fedora installation). I cannot then proceed with the installation. Even if I choose to manually edit the partition - by shrinking the LV, all I get is a blank area of free space. The "next" option just does not become enabled.

Can you not use manual partitioning in such a complex case? Check out the User Guide supplied with the ISO.

A hint: to select the right disk you need to click on a drop-down list in the installer.

Is that considered complex? Oh. I thought it was fairly straightforward :0/

I'd be prepared to manually configure but my experience with Linux to date has always allowed me - even when using a graphical installer - the ability to resize, delete or add partitions and then click "proceed" or "next".

My disks are
/dev/sda1 : data and backups
/dev/sdb : music
/dev/sdc1 : grub MBR
/dev/sdc2 LVM PV - which is where I want to install Manjaro - by shrinking this partition and installing in the new space

The dropdown list in Calamares defaults to installing in "shared" on /dev/sda1, which it sees as GPT, and where it wants to write the boot records.

If I use this list to select /dev/sdc* the only options I then have are to "replace" the installation (no!!) to delete the partition (no!!!!) or to manually configure. If I choose this, there's no possibility to then proceed with the installation - the "next" button stays grayed out.

I never tried installing on LVM, but I think this feature is quite new in Calamares installer, so maybe try the 17.0-beta2 ISO

Umm, okay. But we are on a pretty slow connection here. If I can avoid downloading a 1.5gB file I'd rather - that will take five+ hours!

Is there any documentation I should be reading that will allow me to maybe use diskpart or something and set up my disk in advance, if Calamares itself can't do it?

You could try the ISO you have and in live environment connect to the unstable repo (you know how pacman works?) and install the most current version of Calamares.

su
pacman-mirrors -g -b unstable --geoip
pacman -Syy
pacman -S calamares

But this might result in a broken installed system, because newer+older packages => conflicts sometimes.

Another more hackish approach would be to install Manjaro on some other partition, then mount that partiton, mount the LV and copy everything over:
sudo cp -a /mnt/source/* /mnt/target
Then chroot the target, correct the /etc/fstab, and update-grub:

manjaro-chroot /mnt/target
nano /etc/fstab
update-grub
1 Like

thanks for that - all very constructive.

To be honest, while I understand that Manjaro is a rolling release, I still want some form of basic stability/useability from my installs. While I have already install Arch on one machine, and then added my own DE, there were still too many small niggles, which is why I went back and chose another complete spin - this time Arch based.

I feel it rather completely undermines the entire point of creating and using a live .iso if one then has to start 'hacking' on the command line. While it's true that I never chose explicitly for Fedora to create a LV for me, I really don't see why this should even be an issue.

What I think I'm going to do is hold off using Manjaro as anything other than a curiosity on my second machine, until such time as there's a fully supported "out of the box" solution, assuming that in the meantime I don't get so utterly fed up with Gnome DE and the stupid shenanigans of Wayland/X conflicts I end up wiping the entire disk and starting again with Majaro ;0)

1 Like

Unfortunately you are attempting to install Manjaro during a period of Calmares development where LVM is one of the features in the process of being integrated into the GUI installer.

The NET installer would have been able to deal with this, but alas this was discontinued.

Then there is manjaro-architect cli installer, which will hopefully be able to handle installation scenarios such as yours, but this is still under development too.

When both Calmares and manjaro-architect are feature complete Manjaro installation options will be great.

In the interim you could always attempt to install with the latest NET edition installer (16.06 I think), install an absolute bare bones system, then upgrade. Once upgraded you should have no show stopping issues, it is just getting a system to install into that LVM environment is currently not really possible with the current Live ISO.

Sometimes in life, timing is everything...

EDIT : Latest NET installer was 16.08

https://downloads.sourceforge.net/manjarolinux/manjaro-net-16.08-x86_64.iso

or

https://downloads.sourceforge.net/manjarolinux/manjaro-net-16.08-i686.iso

2 Likes

@sueridgepipe

So let me just make sure I fully understand:

If I use this net .iso installer, I WILL be able to boot up and run it via a USB (as I tend to with the live .iso), and choose to install on /dev/sdc2 LV, where it will install just a minimal Manjaro? Is that correct? And that it will take care of the Grub2 config for me? And that once a basic 'slimline' Manjaro is in I can then add my own apps/programs as I see fit? If so, this is pretty much what I wanted anyway ;0) because what I want is a well designed, stable OS WITHOUT all the bells and whistles and endless 'stuff', half of which I end up removing anyway

This is my understanding, others with significant more know-how that me may be able to give a more categorical yay or nay in terms of your specific LVM environment. If you are looking for an iron clad guarantee, I can't give you that, but it is the best tool available at the moment to tackle your installation issue.

Blurb from the Manjaro website

The NET edition of Manjaro provides a base installation without a pre-installed display manager, desktop environment, or any desktop software applications. However, it is in keeping with our user-friendly philosophy.

Of course this is an old ISO with kernel 4.4, old xorg, old mesa, 9 month old drivers, etc... but assuming all that supports your hardware and the install succeeds the update should be small as you will inititially have ■■■■■■ all to update. From that point install what you want.

What have you got to lose? It should work, worst case it doesn't, nothing ventured nothing gained.

manjaro-architect has options for lvm, but I have never tried it (or lvm in general). Anyway, it should work, but there are still some quirks with the basic desktop installation (you may need to enable login screen and networkmanager manually).

But it installs by downloading the latest packages, so you need internet and it might take longer than downloading an iso.

Screens from the NET cli installer, which I just downloaded and launched in a VM.

This what you were looking for?

This, or just in the mount part of the installer mount an existing LVM. Or a hackish way: mount the partition, then in a separate teminal tab

sudo umount /mnt
sudo mount -o <some LVM mount options I know nothing about> /dev/mapper/<volume_group>-<logical_volume> /mnt

Then continue with the install. Everything will be written to the mounted LV.

But this will not save the OP any download.

I use GPT and UEFI, not MBR, so I can't easily recreate this scenario.

Just playing around with Manual Partitioning on the latest 17.0 Beta 2 Calmares, and if you don't set the mount point for the system partition Next stays greyed out. This makes sense.

Set the / mount point to instruct where to install Manjaro, and Next is enabled.

I am able to set my bootloader partition manually by keeping content and setting the mount point to /boot/efi for an existing partition (ie sda1), but it could be any partition. This will simply use the existing bootloader, not install a new one. I used this to install Mabox today, and use the same UEFI bootloader as KDE Beta 2 install (ie GRUB 2).

Can something similar be done with MBR, that is, explicit partition selection through mount point, or is this at the heart of the problem? That is Calmares assumes the MBR boot partition is always on sda1? Just trying to work out if this is a Calmares bug, or related to your specific environment. My MBR knowledge is lacking as I don't use it.

Does your sdc2, where you want to install Manjaro, show as a valid partition in Calmares Manual Partitioning module ? Within manual partition can you select it, choose to format it, and set the mount point to /?

1 Like

Thanks again. Have downloaded the iso, have noted your remarks. Need to respond to others below who have kindly contributed. One question for now though: assuming I did install a "bare bones" Manjaro, how would this differ from simply installing plain Arch? It's because I don't really want to have to install an entire DE that I went with a live iso in the first place. However, it's all useful learning - nothing ventured nothing gained ;0)

Think I'll pass on the cli installer if it's currently unsupported.

Now this - THIS - looks promising. Thanks!

What I think I should do is take screenshots, as I recognise all of yours, but am not allowed certain of these options on my hardware.

The reason I'm using MBR partitioning is simple. I inherited a 7 year old machine. In its day it was a good piece of kit: quad i7, 12gB DDR3, Nvidia GTX580 and so on, so no reason not to use it - I gather Linux is generally less resource hungry, apart from which Fedora works fine (for the most part). Having read up on partitioning, bios etc. I went with MBR because my mainboard doesn't appear to support UEFI only. So, what appears to happen is that, using the Fedora live iso it sets GPT partitions under MBR, and by default set the system device /dev/sdc1 /dev/sdc2 (two partitions on a single SSD, one for bios Grub install, other for system files) as LVM

Using Calamares (I'd obviously still prefer to just install the complete spin/iso rather than custom install) I can get to the screen to choose install location, but once I select /dev/sdc2 using the dropdown, there's no way of choosing to install Manjaro "beside" any other partitions - all I get is an "either/or" option to replace, overwrite or delete. I'll take some screens for you and post them here.

Do you actually need LVM? If not remove Fedora, install it in plain partition, install Manjaro on another partition and that's it. Or wait for a LVM pro to help.

It is such a simple partitioning scheme which "install alongside" is meant for.

1 Like

I understand the sense of the comment, but err... Fedora is currently THE operating system/computer I use for everything - photo editing, mail etc. etc. Remove it and start again? Easier to leave Manjaro alone. Funny thing is (or not) I'm pursuing this precisely because I'm still looking for the "right" spin. I thought it was Fedora, but it breaks as often as it doesn't. I realise Manjaro is a rolling release, but straight out of the box on my laptop it looked and felt "right" - simple, clean, well thought out, no unnecessary eye candy AND!!!! it plays nicely with my Nvidia card, meaning watching films on VLC was pain free - all of which is in complete distinction to Fedora. Not trying to start a flame war, didn't come here to dump on Fedora (after all, all of this stuff is FREE!!!) just explaining.

If I can't get this install to work, I'm going to wait until it plays nicely with my existing system. Don't think this is asking the earth ;0)

1 Like

By default, arch has installed

  • netctl

While manjaro has preinstalled

  • graphics drivers (automatic detection)
  • Xorg (so you can install a desktop and it just works. For example, sudo pacman -Sy gnome)
  • maybe bmenu? (shortcuts for useful stuff in command line)

Forum kindly sponsored by