Calamares doesn't show list of disks to install bootloader

I have windows 10 in my laptop's hard disk and I am trying to install manjaro in external hard disk. Both the hard disks have GPT partitions. I created USB install media using rufus (GPT for EFI only). USB boots fine and I'm greeted with the manjaro welcome dialog. So I start my installation process and choose manual partitioning. This is where things start falling down for me. My manual partitions (on my external hard disk obviously) are as follows:

Home --> ext4 2gb
/ --> ext4 18gb
swap --> 2gb
efi --> 500mb

There is no option to select where bootloader will be installed. So, I proceed and complete the installation without any hitch. But it doesn't boot. Complete black screen.

Then I tried chroot and installing grub for removavble storage manually in my efi partition. Yet nothing, only black screen.

I am quite sure that manjaro can be installed in external hard disk as I have done the same steps as above but with MBR instead of GPT. When my hard disk had MBR table then it used to show option to select disk where bootloader needs to be installed (and it still do, tried in virtualbox).

Only problem is that calamares doesn't show list of disks to install bootloader for GPT based disks. I have tried the same thing with ubuntu and it shows the choice for GPT disks and boots just fine.

P.S. I know full install on external hdd doesn't make it portable and it was never my intention. Selecting bootloader disks gives me freedom of reinstalling either of OS independently without messing anything. Also it saves me quite a hassle.

EDIT2: I thought of reporting it as a bug on calamares but "report a bug" link on github gives me 404.

In uefi installations, there is no place to choose where to install bootloader.
You need to tell installer where is your $esp (the fat 32 partition). And that is all besides choosing where is your root (/) partition. In choosing your $esp, you have to tell it to mount as /boot/efi.

You most likely had chosen that $esp to mount as /boot when you should have chosen mount point /boot/efi

Never mind, you can boot up using this and correct it. But after booting up, you need to verify that is the case and then correct it.

For newer users, it may be just easier to reinstall again (using the correct mount points).
If you want to correct your installation, after booting up, at terminal, provide

cat /etc/fstab
sudo blkid
findmnt /boot
findmnt /boot/efi
sudo parted -l
test -d /sys/firmware/efi && echo UEFI || echo BIOS

[edit] - important, when installing, do not format that $esp partition or you may lose the windows boot.

Yes, I mounted it at /boot/efi and it automatically chooses fat32 for it. But it doesn't work for me.

Edit2: As stated above, my windows installation is in entirely different disk so formatting my /boot/efi partition doesn't do anything.

Ok, Manjaro is at external drive and if you pull it out occasionally, you need to grub-install using '--removable' (yes, no need to do that with msdos/bios-legacy externals, but with uefi/gpt external, you must).

See if you can just boot up manjaro using the boot setupkey (usually F8 ~ F12).
If not, boot up Manjaro using this and then at terminal, verify you have /boot/efi mounted at right terminal by

findmnt /boot/efi

Then if /boot/efi is correct

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug --removable

Note '--removable'
Note however, after pulling out the external, you must boot manjaro using the boot set key (F8 ~ F12) when you reconnect the drive.

I have tried grub install with --removable flag by booting in live usb media and doing chroot to my hard disk, but I don't know how well I performed all those steps (it was complicated). Anyway let me try above too.


[quote="himsin, post:5, topic:28654"]
.....and doing chroot to my hard disk,......(it was complicated)
[/quote]If you have done chroot, suggest you reinstall grub as well.

sudo pacman -S grub
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug --removable
sudo update-grub

Reason: chroot can mess things up if not done well or extra things were done in chroot (or not exited well), avoid chroot whenever possible.


ok so I tried a fresh installation again. Please refer to the for my issue.
As you can see in 1st image I have two hdd and I have created partitions as shown in image.

After finishing up the installation, boot options doesn't show manjaro (I have removed live installation media at this point). It does show ubuntu which was previously installed on the same disk and I think it's the leftover of it.

Selecting ubuntu takes me to grub prompt as it cannot find anything to boot (3rd image).
Selecting last boot option shows only black screen and nothing happens on F8~F12.

Ok, so I solved my issue just before giving up on manjaro. I plugged in my live installation media and it had an option "detect bootloaders" on startup. I selected it and it listed all available bootloaders on both my disks. I selected manjaro and it booted fine. Then I used grub-install command with --removable as suggested by @gohlip and it worked fine. Now I can boot my manjaro without live media.

Thanks a lot @gohlip for helping me :smiley:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by