Calamares failing to install a bootloader

Idk why exactly this happens but when I try to install Manjaro KDE at the end of the install it gives me the error in the attached photo. IMG_20191222_154943

I used balena etcher to create the USB. ISO from the official website.

How did you partition the disc?

Told it to format the entire disk without swap or encryption.

I had manjaro on it before but xfce. I will try if that edition works.

You may want to post to calamares bugs

You can still boot to Manjaro installed OS by using this first post.
Use the [More complicated setup] method, the simple first start won't work as you do not have grub.cfg
Do the steps after booting and you'll be alright.
Don't forget to the 2 Additional UEFI commands.
If you still have problems, do not come back with just "It doesn't work". I won't respond.
Provide the output as stated there.

1 Like

I've redownloaded KDE I will try to clean install again tomorrow.

The SHA1s match.

We tested our ISOs on several machines and didn't had that issue. Please restart the installation but provide the full installation log: sudo -E calamares -d. This way we will have the configuration you used.

Well i have Windows installed right now again and id like to have a usable system, hmmm, could i put it on a separate partition or would that not work?

Installing inside VBox works without an error so now ima try on bare metal after taking a system image.

Heres the session log up until the error message:!Ai1BObdB01ni9AbRB-OyaGOvO7gh?e=Cw9RSe

Perhaps the ouput of sudo parted -l (that is lowercase L) from your live usb can give forum members more detailed info about your disk set-up.

It's 1 Single HDD. Set to be formatted and partitioned from the installer.

Thanks for the reply! Still the output of the command would provide more detailed info.

From Calamares log (line 255-259):

2019-12-25 - 15:31:48 [6]: Check EFI bootable "/dev/sda" "/dev/sda" 
2019-12-25 - 15:31:48 [6]:  ..  flags QFlags<>() 
2019-12-25 - 15:31:48 [6]:  ..  moved towards root 0x55b2ade6c9a0 
2019-12-25 - 15:31:48 [6]:  ..  partition table 0x55b2ade6c9a0 type 6 
2019-12-25 - 15:31:48 [2]: WARNING: system is EFI but no EFI system partitions found. 

I suspect you are booting up your USB in UEFI mode and try to install Manjaro in the same mode on a disk that doesn't have an EFI system partition. This will naturally fail, since for an installation in UEFI mode the existence of an EFI system partition is a requirement.


There is an EFI system partition on here right now but im telling the installer to format the entire drive and partition it automatically.

I am not clear if you want to dual-boot with Windows:

Or single-boot Manjaro only:


I'm aiming for manjaro only like I had it before

Well if you don't want to have the MS partitions at all you can go radical and create an new partition table. GPT for example. This ensures that the hard disk is really blank. It seems for whatever reason the old partition scheme is conflicting here.

Wouldn't really make sense cause I'm formatting the full drive but ye I may try tomorrow or whenever I feel like it with some manual partitioning.

I have the same Problem as OP and this seems to be a bug in Calamares. It's not just Manjaro, I also tried Arco and Endeavour and I always get the same error. Settings don't seem to matter, I tried to erase disk and manual partitioning, I tried with and without encryption, nothing works.
So looks like there's not much we can do until Calamares fixes this bug.
BUT: Manjaro Architect works fine for me! And that's one thing I really like about Manjaro, that there's an alternate way to install. Other distros, like the others I mentioned, unfortunately do not offer any options beside Calamares.

1 Like

Forum kindly sponsored by