Calamares partioning

So I have already uploaded my updating problems in the Stable branche for the 2020-01-16 update, however there is another problem that is occuring during the installation of Manjaro.

It seems that Calamares is "picky" on what it wants to install. On my Dell XPS 13 (9370) laptop when I am running the live media for a new install it will show the correct partioning of a new installation, boot + efi + ext4 partitions respectively.

However, on my current system..

inxi Fxzc0 output:

System:
  Host: manjaro Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: KDE Plasma 5.17.4 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P3.90 date: 12/09/2019 
Battery:
  Device-1: hidpp_battery_0 
  model: Logitech MX Ergo Multi-Device Trackball 
  charge: 55% (should be ignored) status: Discharging 
CPU:
  Topology: Dual Core model: AMD Athlon 3000G with Radeon Vega Graphics 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 27957 
  Speed: 1553 MHz min/max: 1600/3500 MHz Core speeds (MHz): 1: 1549 
  2: 1777 3: 1528 4: 1746 
Graphics:
  Device-1: AMD Picasso driver: amdgpu v: kernel bus ID: 06:00.0 
  Display: x11 server: X.Org 1.20.6 driver: amdgpu FAILED: ati 
  unloaded: modesetting tty: N/A 
  OpenGL: renderer: AMD RAVEN2 (DRM 3.35.0 5.4.6-2-MANJARO LLVM 9.0.0) 
  v: 4.5 Mesa 19.3.1 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio 
  driver: snd_hda_intel v: kernel bus ID: 06:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus ID: 06:00.6 
  Device-3: Creative SB Omni Surround 5.1 type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-2:2 
  Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 238.01 GiB used: 135.0 MiB (0.1%) 
  ID-1: /dev/sda vendor: Western Digital model: WDS240G2G0B-00EPW0 
  size: 223.57 GiB 
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 111 
  size: 14.44 GiB 
Partition:
  ID-1: / size: 10.20 GiB used: 135.0 MiB (1.3%) fs: overlay 
  source: ERR-102 
Unmounted:
  ID-1: /dev/sdb2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: 9D87-6CAB 
Sensors:
  System Temperatures: cpu: 23.2 C mobo: N/A gpu: amdgpu temp: 23 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 195 Uptime: 17m Memory: 13.60 GiB used: 1.37 GiB (10.1%) 
  Init: systemd Compilers: gcc: N/A Shell: bash v: 5.0.11 inxi: 3.0.37 

..it shows the current drives and Manjaro was installed on ID-1 a couple of hours ago, but when I run the installer, Calamares won't properly set up the partioning for a clean install and instead only shows 1 ext4 partition that covers the entire disk without boot or efi.

Here is a picture of what I mean simply:

20200117_103117

EDIT: And this goes for both XFCE and KDE.

Your system has been booted in BIOS mode also named Legacy and CSM or Compatibility mode.

Ensure your system is booted as EFI system.

4 Likes

As @linux-aarhus says...

And don't use "Erase Disk".
You will have an error that your boot-loader will not be installed properly.
Use "Manual Installation" and prepare partitions beforehand.
If you had 'erased disk', before installation use gparted and "Create Partition Table" (at device tab)
(at device tab --> Creates Partition Table --> gpt ). Then make partitions.

2 Likes

@linux-aarhus

Thanks that solves the clean installation problem. For some reason the CSM in my BIOS was enabled.

Still gonna wait for fixes for the 2020-01-16 update as it breaks my system for some reason. The Login Service seem to fail and Modem Manager so I hope I'll get some help in that thread.

But thanks for the CSM solution! I shan't forget it! Much obliged!

Is the 'erase disk' bug fixed yet?

As far as I know, it is, well.. it is for me. To me the problem resided with a BIOS setting.

But when I choose the 'Erase disc' function now, it creates everything you need just as you expected.

I hope this will be the same for you. You can simply try it during a live boot and see if it automatically creates the necessary partitions :smile:

It may create partitions, but does that create a boot flag and boots after installation?
If you are on uefi/gpt, that may be alright as that makes a efi partition
but have you tried it on msdos/bios-legacy?

Well.. ever since owning a custom computer, I didn't have any problems with the Calamares installer with it making the proper partitions.

However, when UEFI was on and CMS and all, the Calamares installer simply created filled the entire disk with 1 ext4 partition.

Turning everything off again in the BIOS, it created everything as it should do.

Again, this was in my experience of course.

in UEFI, as we can see.
Here are just 2 links where boot flags are needed because 'erase disk' is used (in bios-legacy)
One
Two

There's more from way back, but I really cannot vouch for it as I have always used manual partitioning from way way back (I have lots of partitions and OS's, so I cannot erase disk).
And that's why I'm interested to know from others if erase disk in bios-legacy have no problems.
Not that I want to be contrarian.

Well, in my fairness, I have actually never done or used manual partitioning. Not even in Windows 10, I just always selected the 'unallocated space' and with installing a Linux distro it always with the use of an installer mostly, even Ubuntu Server.

My problem simply suddenly happened during the Linux 5.4.x problems of which there is a huge thread by me trying to help @philm to solve it. For some reason it changed settings in the BIOS back to default leading to me creating this thread.

If there is something you'd like me to try, I have a burner laptop if you'd like me to play with settings and all. Let me know.

2 Likes

Thanks. In that disk, do 'erase disk'.
Then install any manjaro in bios-legacy
At end of installation, tell us if there is any error, something like
'python-bootloader fails; at line blah blah blah cannot blah blah blah"
Remove usb installer and boot.
Tell us if you can boot.

If you cannot boot, just do [Kernel Boot Method] in bios-legacy and you should be able to boot up. At terminal, just do (without setting flags)
sudo grub-install /dev/sda
sudo update-grub

Tell us if this time it will boot up.
If it cannot boot, boot again into it using same method.
Then at terminal, just do

sudo parted /dev/sda set 1 boot on

Reboot and tell us again if that boots this time.



Next experiment.

Same disk. same computer. same bios-legacy install
Use gparted, device table --> Create Partition Table --> select msdos.
Then create partitions.
Install manjaro, but not using 'erase disk' but using manual partitioning.
Tell us if any error at installation.
Reboot and tell us if it reboots without error.



Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by