Can get dual-boot works properly

Hi all.

I have an msi gv62 7rd laptop, i've been trying to install manjaro alongside windows 10.

I can boot on live-cd without problems (With free drivers, with nonfree i cant get it to works).
I install without problems and grub seems to be working correctly.

When i try to boot Manjaro's system it gets stuck on msi logo or in the start TLP step or in the the reached target Graphical interface step.

I tried the next things:

  • Booting up wiht nouveau.modeset=0 flag.
  • Booting up with the 3 kernel flag active to get in tect mode, then install bumblebee drivers.
sudo mhwd -a pci nonfree 0300
  • Once installed get into the system with:
sudo manjaro-chroot -a

And then remove the video-linux and install the bumblebee driver (After executing a complete update of the system).

Other curious thing is that when i enter in textmode and execute any inxi commands the laptop gets stuck.

I assume is a problem with the graphic card, if you can help me i would be very grateful.
If you need more info about my system ask me.

What is the output of:

inxi --display

so we know which chipset you have so we can give you better directions.

Hi Fabby thanks but i get it resolved.

Finally i can resolve it doing the next things.

def run():
    """ Configure the hardware """
    
    mhwd = MhwdController()
    
    # return mhwd.run()
    return None # <- Add this and comment the above line
  • Then I install, after install i reboot and add the next kernel flags to this boot.
acpi_osi=! acpi_osi="Windows 2009"
  • Once into the system i updated it
sudo pacman -Syu
  • Then install the nvidia-driver
sudo mhwd -a pci nonfree 0300
  • Finally reboot, and it seems to work properly.
mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI

inxi -G

Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 440.44 
           Display: x11 server: X.Org 1.20.7 driver: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.6 Mesa 19.3.2
nvidia-settings

Screenshot_20200128_172734

P.D: If i edit the file /etc/default/grub and remove the kernel flag quiet from this line

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

And then execute

sudo update-grub

It gets stuck on booting

1 Like

Start by reading this

I had the same problem you did. I have a different laptop but same graphics you have.
To boot after install I used the nouveau.modeset=0 flag.
Then updated my system
rebooted using the same flag as before
followed the instructions on this page Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA)
and it worked great.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by