Can no longer boot after installing video-nvidia-390xx

image0-8

Installed the 390xx driver via the settings manager GUI

this is a laptop ,
have you checked before if you are using hybrid video card ?

I think just gotta run

sudo mhwd -r pci video-nvidia-390xx

To remove the driver that caused the issue right

How to check?

check with mhwd and provides returns

mhwd -d -l --pci

mhwd will propose by order priority ( highest should be working )

video this?

Was able to boot after removing the driver that made this whole thing happened! Seem to be running off the Mesa drivers according to steam but how do I get the Nvidia propietery drivers?

so you can returns

inxi -Fxxxz

there no more video--** before video-linux ?
only 2 drivers ?

Screenshot_20190620_171636

it's an optimus laptop with a kepler gpu. you can use nouveau (video-linux) or bumblebee with the 390xx drivers since 430.xx dropped them :sleepy:

video-hybrid-intel-nvidia-390xx-bumblebee

It dropped support for Kepler-based Quadro GPUs, not all Kepler GPUs.

430xx still supports the 870M.

Now you can boot, please copy and paste text as text instead of uploading screenshots of text which are difficult to read.

1 Like

Will do once he comes back online, I am very grateful for your help and your distro! I love it!

Also, does that mean he can just install "video-nvidia" in the system settings and be good to go?

no.
It means install video-hybrid-intel-nvidia-390xx-bumblebee

mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

or the auto one would probably pick that up:

mhwd -a pci non-free nonfree 0300

(just installing 'nvidia' [or nvidia-390] alone is what created this 'problem' in the first place)

Thank you! So just run that and reboot afterwards and everything should be ok?

What does he do about "Don't forget to add yourself to the bumblebee group so you can use bumblebee"?

This is all available in the docs.

Buts ... to see what groups the user is in just type groups . If you dont see bumblebee then do

gpasswd -a USERNAME bumblebee

(replace USERNAME with the correct user)

After that (and successful install of bumblebee and restart, etc) from then on they should be using intel by default. To use the nvidia you use optirun or primusrun

Test:
glxgears --info
then
primusrun glxgears --info
or
optirun glxgears --info
You should see the nvidia card in use during the second example(s)

https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards#Bumblebee

https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup#Bumblebee_and_Steam

Bumblebee Troubleshooting|20181229

https://wiki.archlinux.org/index.php/Bumblebee

https://wiki.archlinux.org/index.php/Users_and_groups

1 Like

Sorry, but not sure what was done wrong, but even when running optirun steam , system information in steam still says this is the driver, so I believe it is still running off the iGPU?

Driver:  Intel Open Source Technology Center Mesa DRI Intel(R) Haswell Mobile x86/MMX/SSE2

Who said to run steam using optirun?

Its explicitly not suggested and instead you should append it to each game run option like so:
primusrun %command%

Oh, so put primusrun %command%in each game launch options? Question what about something like Lutris? Because my friend is getting the no vulkan support error when trying to install a game

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by