Can no longer boot after system update. (2019-11-14)

Apologies if this is in the wrong section. I have been using Manjaro KDE for about six months now and have always been able to find solutions to my problems by searching but this is a doosie for me.
This morning, Octopi notified me that system updates are available so I went ahead with it. I walked away for a couple of hours and when I returned, it was complete. When I tried to launch Brave browser it would pop up with a white window for a few seconds and then close. I decided to reboot and was was puzzled to see all the linux status stuff scrolling on the screen instead of the Manjaro logo. It stopped at some point and went no further. One of the lines said "Fail" and "See systemctl status systemd-modules-load.service". So I pressed Alt-F2, logged in and typed the aforementioned command. It spit out:

■ systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-11-14 09:35:12 EST; 2min 42s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 485 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 485 (code=exited, status=1/FAILURE)

Nov 14 09:35:11 Gamer systemd[1]: Starting Load Kernel Modules...
Nov 14 09:35:11 Gamer systemd-modules-load[485]: Failed to insert module 'nvidia': Invalid argument
Nov 14 09:35:12 Gamer systemd-modules-load[485]: Failed to insert module 'nvidia_drm': Invalid argument
Nov 14 09:35:11 Gamer systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Nov 14 09:35:11 Gamer systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Nov 14 09:35:11 Gamer systemd[1]: Failed to start Load Kernel Modules.

I assume it is an issue with the nVidia driver, but I have no idea what to do at this point. If it were Winblows, I would just reinstall but it took me forever to get my desktop environment right.

Thank you in advance.

1 Like

Maybe incomplete/partial update.
Update again with pacman.

sudo pacman -Syyu

Maybe check your kernels and nvidia versions to your branch
https://manjaro32.org/repo-compare/

1 Like

Today's update also broke my Manjaro. In the startup log, I get

[FAILED] Failed to start Load Kernel Modules

The boot process then hangs at some point and never gets to the graphical login.

sudo pacman -Syyu tells me that there is nothing to do, it didn't fix the problem.

Same here on manjaro cinnamon. Updated just now and the Nvidia module seems to be broken so I can't boot to desktop.

I fixed this based on a post from the update thread. In my case, I was running kernel 4.19.84 and nvidia proprietary drivers 430xx. Upgrading the nvidia drivers to 440xx fixed the problem

Press Ctrl+Alt+F1 to get a login promt, login, then use mhwd to update the driver.
sudo mhwd -r pci video-nvidia-430xx
sudo mhwd -i pci video-nvidia-440xx

Hope this helps

3 Likes

worked for me

Thank you. This is my main machine and it sucks being stuck without a DE. First time I have a major issue with a manjaro update though.

Thank you danman! Your suggestion worked for me as well. Before you posted, I tried AgentS' solution and it did update four Mesa items but still wouldn't boot. Since that is video related I think that may have been part of the problem as well, so thank you to both of you. I was dreading going back to Windows, especially after bragging to everyone how I ditched Microsoft. :smile:

If nvidia-440 works on your systems, it's fine.
Nevertheless, nvidia 430 should work as well on the same hardware, but I believe @philm is aware of this.

Just wanted to say thanks, also had this same issue. Something in the update process with nvidia is currently messed up.

I tried danman's solution of upgrading to 440 nvidia drivers.
But for me Booting still yields a black screen with a curser.
If i change to another login prompt,type startx and than look into the log files
It says that there is a segmentation fault happening in the driver

Segmentation fault at address 0x2a9

Does anyone know why this happens? What can i do?

Post logs.
How to change video drivers or configuration and troubleshoot

Do you mean you get to your GUI session?

Do you mean you get to your GUI session?

No i dont get a Gui Session

I also just realised that the logs i was seeing were from a previous start of X.
So i Just cleared the Xorg log files and restarted the system again.
Then directly after the restart the logs at ~/.local/share/xorg/Xorg.0.log and /var/log/Xorg.0.log are empty?? shouldn't there be at least something

Edit:
Running startx produces this log file
https://pastebin.com/60kM4y2p
located at: ~/.local/share/xorg/Xorg.0.log

Please read the linked tutorial (my previous post) to see where files are and how to troubleshoot, get log files etc.

Running startx produces this log file
https://pastebin.com/60kM4y2p
located at: ~/.local/share/xorg/Xorg.0.log

Running
systemctl start lightdm just gives me a black screen with a flashing cursor, just like when i boot normaly

What's the journal reporting? Post (pastebin) please...

systemctl status lightdm
journalctl -b -p3 --no-hostname --no-pager

First off, thanks for helping me and your quick replies


systemctl status lightdm

https://pastebin.com/pYu5PFap

journalctl -b -p3 --no-hostname --no-pager

https://pastebin.com/wkAKTCUa

Now i am not quite sure if i am using lightdm at all it should be gdm if i am on gnome right?

There is a problem with nvidia driver.
Try another version of nvidia driver. (418 etc)
If you have kernel 4.19, use it to boot. If not, try installing it.
Also try fallback kernels (not sure it will help in this case, though).

15737750473651405261566077386871

Did not work here. :confused:

Try to update first with an up-to-date mirror.

To change nvidia driver version, first uninstall nvidia-utils with pacman and then use mhwd. But, as said, first try a fresh mirror update.

Forum kindly sponsored by