Can’t boot into desktop ... display driver failure

I can’t boot into my system. Been struggling with display drivers. I have a new problem, Chose latest Nvidia driver, in optimus manager, chose start with Nvidia , but when I rebooted, it doesn’t work, just blank ... I’m assuming chosen to run on Nvidia, but driver not compatible. What to do now ... complete reinstall or any other way?

rob@rob-dellxpsl502x ~]$ inxi -Fxxxza --no-host
System: Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64
root=UUID=17e7c708-1792-49fe-9df2-448b23ff19b5 rw
quiet apparmor=1 security=apparmor
resume=UUID=0a20dec3-73a0-4338-aed6-83e8e3d40cca
udev.log_priority=3
Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm:
SDDM Distro: Manjaro Linux
Machine: Type: Portable System: Dell product: Dell System XPS L502X v:
N/A serial: Chassis: type: 8
v: 0.1 serial:
Mobo: Dell model: 0714WC serial: UEFI [Legacy]:
Dell v: A12 date: 09/07/2012
CPU: Topology: Quad Core model: Intel Core i7-2630QM bits: 64
type: MT MCP arch: Sandy Bridge family: 6
model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 6144 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 31941
Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1:
798 2: 798 3: 798 4: 798 5: 798 6: 798
7: 798 8: 798
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge
pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache
flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass
disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and
__user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel 2nd Generation Core Processor Family
Integrated Graphics vendor: Dell driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0116
Device-2: NVIDIA GF108M [GeForce GT 540M] driver: N/A bus
ID: 01:00.0 chip ID: 10de:0df4
Display: x11 server: X.Org 1.20.8 driver: modesetting
compositor: kwin_x11
resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition
Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID:
8086:1c20
Device-2: NVIDIA GF108 High Definition Audio driver:
snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:0bea
Sound Server: ALSA v: k5.6.19-2-MANJARO
Network: Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak]
driver: iwlwifi v: kernel port: efa0
bus ID: 03:00.0 chip ID: 8086:008a
IF: wlp3s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit
Ethernet driver: r8169 v: kernel port: 2000
bus ID: 06:00.0 chip ID: 10ec:8168
IF: enp6s0 state: down mac:
Device-3: Dell F3607gw v2 Mobile Broadband Module type: USB
driver: cdc_acm,cdc_ether,cdc_wdm
bus ID: 2-1.6:4 chip ID: 413c:8184 serial:
IF: wwp0s29u1u6i6 state: down mac:
Drives: Local Storage: total: 698.64 GiB used: 65.52 GiB (9.4%)
ID-1: /dev/sda vendor: Seagate model: ST9750420AS size:
698.64 GiB block size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial:
rev: DEM1 scheme: MBR
Partition: ID-1: / raw size: 689.83 GiB size: 678.01 GiB (98.29%) used:
65.52 GiB (9.7%) fs: ext4
dev: /dev/sda1
ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap
swappiness: 60 (default)
cache pressure: 100 (default) dev: /dev/sda2
Sensors: System Temperatures: cpu: 49.0 C mobo: 49.0 C
Fan Speeds (RPM): N/A
Info: Processes: 215 Uptime: 1h 25m Memory: 7.67 GiB used: 1.06 GiB
(13.8%) Init: systemd v: 245
Compilers: gcc: 10.1.0 alt: 8 Shell: bash v: 5.0.18 running
in: konsole inxi: 3.0.37

[rob@rob-dellxpsl502x ~]$ mhwd -li

Hi!
You have dual graphics intel/nvidia, try following this guide

This doesn’t help .. I can’t boot into the system .. no GUI interface

Hi!
Ctrl+alt+f3
You'll go to a terminal
Find what nvidia's driver do yo have install
Pacman -Qs nvidia
Then
Sudo pacman -Rns driver nvidia
This would uninstall nvidia drivers, reboot

Ok great ,,, getting somewhere ... BUT, ran it and got failed error ... “ dependency... required by Nvidia-prime”
I know I can’t uninstall using GUI even if Nvidia-prime installed, always have to uninstall Nvidia-prime first, but don’t know how to do it via terminal ...?

Ps ... also when I ran “list” ... it also showed driver conflicts, those supplied by default with MANJARO installation ...

image

Hi!
To uninstall nvidia-prime sudo pacman -Rns nvidia-prime

Hi .., I’m using mhwd ... and I tried ... sudo mhwd -r Nvidia-prime ... but didn’t work

Ok wait, sorry I’m new to all this ... ran your instruction and it seemed to work ... it ended with a line “Arming ConditionNeedsUpdate”

Hi!
sudo pacman -Syyu and reboot

Ok I managed to remove Nvidia video driver ... now what ... must I install new driver via terminal?

Hi!
Follow the guide I posted before. You'll need to delete any config of previous drivers, then install the drivers and optimus manager

Hi ... first thanks for your help so far. Second ... if you talking about that link about installing optimus manager for hybrid ... am I supposed to follow and do the whole thing from top to bottom? Honestly I don’t think I could, most of time I’m shooting in the dark not knowing what I’m doing. What I do know is a already had optimus manager and the qt installed, used from system tray. But also the prime was installed, and when I uninstalled that, things didn’t seem to go too well. I also have old legacy card, so uses the Nvidia-video-340 and 390 options and bumblebee available ... I’m thinking it’s too old and probably not an official “optimus card” and not sure if suited for “prime”.
Is there any simple command to just clean the video driver section and restore the default Linux video drivers?

Ps ... when I ran command to remove nvideo video driver it also asked if I want to remove config and I said yes, so I THINK the config is removed, not 100% sure if everything that needs to be removed is removed. I’m currently still in the terminal ... not sure what to do next

Hi!
If you card work with bumblebee try with it, is easier than prime.
If you already delete the config then so far so good.
Maybe you can try manjaro channel in telegram for continuous assistance.
Just glad to help man!!!

Ok but what do I do right now ... can I just exit terminal and reboot ... will Manjaro find and reinstall default drivers? And how do I safely exit terminal?
Will look into telegram
Ps ... I ran command to install “free video drivers” ... it kind of went well, but then failed when tried to update sync database, I think cause I’m not connected to internet, not sure if it did still install the drivers ..?

Hi!
Reboot then you'll be using igpu

1 Like

How to exit terminal?
Okay sorted.
Thanks again, take care

Ps ... sorry one last thing ... if I’m using optimus manager, should I uninstall Nvidia-prime? Doesn’t the drivers need it, or is there conflict at all?
Thanks again and best

Hi!
They're two different methods, one prime, other optimus manager, there are some more, bumblebee and optimus switch por amd/nvidia. Everyone has there way, mixing it bad karma!! xddd
Read'u around!!

Forum kindly sponsored by