Can´t update mpv-git

,

I tried to update it with octopi and I get this error:

Checking for OpenGL context support                                  : yes 
Checking for libplacebo support                                      : yes 
Checking for Vulkan context support                                  : yes 
Checking for VAAPI Vulkan                                            : yes 
Checking for EGL helper functions                                    : yes 
Checking for FFmpeg/Libav present                                    : yes 
Checking for libav* is FFmpeg                                        : yes 
Checking for libav* is Libav                                         : no 
Checking for Libav/FFmpeg library versions                           : no ('libavutil >= 56.27.100 libavcodec >= 58.16.100 libavformat >= 58.9.100 libswscale >= 5.0.101 libavfilter >= 7.14.100 libswresample >= 3.0.100' not found) 
Unable to find development files for some of the required FFmpeg/Libav libraries. Git master is recommended.
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build mpv-git.
==> Restart building mpv-git ? [y/N]
==> --------------------------------
==>

I don´t know what is it or how to solve it, help please.

Important knowledge

Please select the text in the terminal
Paste the text into the post
Select the newly pasted text in the post
Click the </> icon in the post toolbar

This creates nicely formatted text which is readable for other users after you.

(Text was copied from @ linux-aarhus)

You need to use ffmpeg-git

2 Likes

I already have installed ffmpeg of manjaro, should I uninstall it and install git version?

If you want to use mpv-git, yes.

mpv-git is looking for the ffmpeg version that is in Arch Linux. Which is just a tad more up to date than Manjaro Stable.

1 Like

Uninstalling ffmpeg ask me to uninstall a lot of programs that I use as dependencies, can I just install ffmpeg-git and have both installed?

No, but you can replace ffmpeg with ffmpeg-git. Just use your favorite AUR helper to install ffmpeg-git. By this way, ffmpeg will get replaced if you allow it.

2 Likes

It works now, I updated it and replaced ffmpeg and all works fine, thank you all

1 Like

It have even higher requirements, libvautil soname version is 56.22.100 for ffmpeg 4.1.4 in Arch, while is required libavutil >= 56.27.100

No because they install the same files

@MNRBN installing ffmpeg-git will be an ongoing hassle, do you really need mpv-git?
on the other side it is an occasion for learning about packging and library versions

1 Like

I need mpv-git because apparently it has support for a program I need (smooth video player). I tried long time ago to configure this program with mpv manjaro version and it didn´t recognize it, so I just installed git version and all worked fine.

Maybe things have changed and regular mpv is now up to the task. Would sure save you a lot of trouble now and in the foreseeable future..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by