Cannot access virtualbox Windows 2000 from Ubuntu (Mint)

I have had vbox installed on Mint for several years with guest Windows 2000. It has worked satisfactorily when accessing it from Mint and Manjaro using http and remmina.

I now have to install an updated version of Mint, so in preparation I have set up vbox on one of my Manjaro machines and transferred a copy of the vbox/guest into it.

This works fine from my other Manjaro machine but I cannot access the guest in any way, including ping, remmina/rdp, http, from any Mint machine. I have added the new IP into the hosts file for all machines - I gave the guest a new IP and made an exact copy of the remmina/rdp access record with the new IP.

Communications between Mint and Manjaro have always been troublesome to set up. Is there something I'm doing wrong? Any clues, please?

this is concerns only mint and theirs forums

If you are connecting remotely from other machines over those protocols, the issue is probably on the Mint side. A ping doesn't care what type of OS is installed.

  • Have you tried accessing it by IP on the Mint side or are you relying on the hosts entry?
  • Is there are firewall running on the Mint machine?

@stephane, did you post that response in the wrong topic? How is steam and 32-bit libs related to this?

Only the Manjaro machines can view the guest. Neither of the Mint machines can. I have tried pinging the IP from both Mints. Remmina also uses IP rather than host.

There are no firewalls installed.

Forgot to say before, the Guest does not appear in the File Manager's Browse Networks on Mint, either (caja).

The impression is that the Guest is not on the network, though it is under Manjaro.

Can you share more information on all these Manjaro and Mint machines.

Which are physical vs virtual, and for the ones that are virtual, where are they hosted? Which host os and on which machine(s)? This is a network issue of some sort and we need to understand the topology.

All machines are pysical except for the Windows 2000 Guest on a Manjaro machine. All are on the same subnet.

All machines talk to all the others using a variety of protocols - except for the Guest which only talks to manjaro machines, again with a variety of protocols.

Is all this true?

  • There is more than 1 mint machine and none of them can ping the guest
  • There is more than 1 manjaro machine, at least one of which isn't the host and those can all ping the guest
  • The IP address of the Windows 2000 guest is inside the range.

That is all correct. Also, the Guest can ping ALL the physical machines.

What version of mint is on the those machines and the ping command you are doing is just ping <ip address>?

Mint 18.1 Serena Mate on one, the other (which USED to run the Guest Windows) is the one I'm about to upgrade but currently Mint 17.3 Rosa Mate.

I'm using Network Tools for the ping but, as I said, Remmina (and web browsers) fail as well. Dos box for ping from Windows.

I've just discovered that the old Guest on Rosa was running (forgot to turn it off after a reboot). Powered it down and the pings now work for both, plus file manager access, which is weird for the Serena machine. Why did it not work when I originally had the Rosa Guest turned off, two days ago?

The only thing now is accessing the new Guest from Remmina - I think that's something I can track down.

Thank you for your time and effort on this. Your questions prompted me to look again at the old Rosa machine.

I recently experimented with a headless system running a virtual windows.

I have always thought that a rdp session to a vm running windows had to be done by using the vm ip on port 3389.

I discovered that you only need to use the Display section of the VM settings. It as simple as ticking the box Enable Server. This action is probably equivalent to this command

VBoxManager modifyvm <your-vm-name> --vrde on

Start the VM and start an rdp session using the host IP address.

Remote Display Settings


Thanks for that, but it made no perceptible difference. The one Mint machine still cannot connect via remmina RDP. The other one - rosa - has no remmina but is due to be updated today so I'll try when I've completed it.


I cannot guess the specifics of your environment - so all I can do is tell how I did it using Manjaro.

Thanks for the information, anyway. :slight_smile:

I installed Mint 20 Ulyana on the Rosa machine yesterday and remmina access of the Windows 2000 Guest works. Still cannot get the Serene machine to connect but it's also due for an update soon so I'll try again after that.

Thanks again for all the help in this topic.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by