Cannot boot after installation Manjaro KDE version

Hi all,

I've been running Manjaro KDE edition in a VM and wanted to install it. But I'm having a problem. I used rufus and my bios is set to only UEFI. I first got a grub rescue> "error: unknown filesystem" on the USB drive. I read here that I needed to make the usb boot with "dd" mode in rufus and that worked and it boots Manjaro.

However, I tried installing it with filesystem encryption checked. First time it gave me a python script error regarding cryptfs midway through the install. I had to reboot because trying the installer again wouldn't let me select a partition.

I tried it a second time and it worked! (I did "erase disk" and "Swap with hibernate" settings and "encrypt filesystem" but after installation when I rebooted (and pulled the USB drive) it just goes to an:

error: no such device: 9d4e...
error: unknown filesystem.
Entering rescue mode...
grub rescue>

grub rescue> ls just reports (hd0)

I must be doing something wrong. I installed Kubuntu on this laptop a while ago and it worked before going back to windows for a bit. But I'd like to try again outside a VM with a more "rolling release" style distro.

When using Rufus, be certain that it uses the "DD Mode" and not "ISO mode".

I did. It booted once I did "dd" mode. However, after installation, I once again cannot boot.

Install KDE again and install grub not on usb-stick.

But I can also be totally wrong. :slight_smile:


inxi -Fxxxz

Search upper right in forum

@gohlip grub boot

50+ Results for @gohlip grub boot
Sorted last ...
No such device, unknown file system, enter grub secure
Technical Issues and Assistance grub kde
15h - Alright, do you have kernel vmlinuz-4.19-x86_64 or are you not sure? Let’s check that out. At grub prompt, do following… grub > search.file /intel-ucode.img root grub > ls ($root)/ Do you get output of vmlinuz-4.19-x86_64 and initramfs-4.19-x86_64.img (besides other stuff)? If you do not have vml...
Slow boot to Manjaro, strange update-grub output
Newbie Corner
2d - Since everything is working fine now, there’s no need for further action, But if Manjaro’s grub gives you some silliness, you can do the changes in /etc/default/grub and the terminal commands after that. Cheers, take care. And you’re welcome.
Booting third OS, grub issue?
Technical Issues and Assistance
7d - linux /boot/vmlinuz Sure it is not /vmlinuz root=UUID=xxxxxxx ro Or /boot/vmlinuz-4.19.23-gentoo root=UUID=xxxxxxx ro Same for initrid line.
KDE 18.03 installs, then boot to grub rescue, every time, on Dell inspiron 1525 (Resolved by installing 18.04)
Support for Community Editions
7d - ZeroAssassin: grub > search.file /etc/manjaro-release root", Mapping for encypted partition is different. Search for issues on encrypted systems. Try 18.04. I think it is resolved there.
Black screen on boot after grub on fresh install
Newbie Corner

Thanks for the reply. How can I install KDE without having the USB drive present? It's the live system that I'm using to install it. I only selected the default "erase disk" which was /dev/sda which is my harddrive. I didn't at any point select to install anything on the USB drive.

Ok, then search in forum, like above.

Yet another privacy concerned Manjaro citizen!
You need to learn how you can handle encrypted partitions, since all/most tutorials or utilities are targeting not encrypted systems.

I would suggest you study about it and use Manjaro Architect, either from its ISO or as an application from your current Live ISO.
Here are some helpfull tutorials for you.

Try whatever you feel comfortable and post what you have tried and failed, together with system info required, as described in the first link. Also cryptosetup and LVM stuff (which I don't know, but others may do..)
Here are some useful

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by