Cannot boot manjaro installer from USB

Hello,

I am trying to install Manjaro for the first time on a Lenovo Yoga 500 14ISK laptop. It has currently Ubuntu and Windows dual booting, and I would like to replace Ubuntu with Manjaro eventually, but right now I couldn't even boot from the usb installer: namely, if I select the USB stick from the quick boot menu, my computer goes straight to GRUB after a few seconds. I seem to have exhausted the previous posts in this topic, that's why I'm starting a new thread, but apologies if I missed something.

Also one more notable circumstance is that due to my own folly, I have forgotten my bios administrator password some time ago (and to my best knowledge it cannot be reset on this machine), so my options are limited in that domain. However, I seem to have fulfilled all the requirements for the installation:

  • Verified ISO file both with SHA1 and SHA256 checksums
  • Disabled secure boot using mokutil --disable-validation (Now the first thing that my computer shows upon startup is "Booting in insecure mode", so I think this worked properly)
  • Checked that my Ubuntu installation is indeed UEFI
  • Checked that my hard drive is in GPT mode using sudo gdisk -l /dev/sda
  • Tried both Manjaro 20.03 XFCE and Manjaro Architect
  • Tried the USB stick on a different machine (and it worked)
  • Tried writing the installer to the USB both with dd, Etcher and Rufus (in dd mode)

One thing I could not check is whether fast boot is enabled. I think I disabled it during the Ubuntu installation a long time ago, but I am not 100% sure and I could not find a terminal command to check that without going into the UEFI settings.

Also one weird thing is that the desktop I tried the usb stick on displayed two options in the boot menu for the usb stick, one UEFI and one not; while my laptop only displays a single option for the usb (uefi or else is not indicated).

What else should I try to be able to boot from the usb? Thank you in advance!

The system has compatibility mode enabled.

Since you have all these issues making Manjaro boot - there is several good reasons to keep using the system as is.

  1. No firmware access
  2. mokutil only manipulates the shim
  3. Secure boot may still be enabled which is why you cannot boot Manjaro.

The ultimate test would be an Arch ISO.

Another possible venue for creating a bootable USB is a fairly new project named ventoy with a quite unique approach - you don't need to flash the ISO to usb. (https://ventoy.net)

After initializing the USB with the ventoy script and binaries you do a one-to-one copy of the ISO file to the USB - and reboot your system.

I have tested Windows ISO, Arch ISO, Manjaro ISO and a couple of other ISO and it works very well.

And I cannot modify that without accessing the firmware, right?

This was interesting, though it made no difference, I could not boot from this either.

I tried this, too -- still the same, sadly.

Also, for comparison, I also tried a fresh Ubuntu iso, from which I was able to boot. What might be the reason for this?

Are you sure that Secure Boot is disabled in your firmware settings?

Ubuntu supports secure boot as far as I know.
Some people may see this as a microsoft backdoor. So I suspect this will not come to arch or manjaro, but some might correct me here.

That is explained by the fact that Ubuntu has bought into Microsoft's certificate chain for Secure Boot.

And this is the reason why installing Ubuntu usually doesn't require Secure Boot to be disabled.

And all your failing efforts to boot anything but Ubuntu points to: Secure Boot is enabled in the firmware and since you cannot access the firmware - forgotten password - you cannot change it.

I think you will have to accept the fact - you are stuck with Microsoft and Mark Shuttleworth

Well that is sad. But thank you all for your kind replies! I will wait a few days in case somebody has a new idea, and then mark the question solved.

I am just curious if any one of the methods described in the link below can solve the issue of resetting the Bios' password:

That is a good idea - we used to do that - once - the problem is the battery powering the RTC on a laptop is next to impossible to find - you have to take it completely apart :slight_smile:

1 Like

I wonder if this is the case for this model, what happens with the old board?
https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/bios-password-remove-from-yoga-500-14ibd/m-p/4511914

Yes, I actually did try the above, and I did take it completely apart some time ago. However AFAIK in this laptop there is an additional static EEPROM that prevents the password from resetting even with the RTC battery disconnected.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by