Cannot boot to windows (dll missing?) after setting up dual boot

Hi,
I tried to install dual boot manjaro following this guide https://archived.forum.manjaro.org/t/howto-dual-boot-manjaro-windows-10-step-by-step/52668/48 but when I finished, it booted to windows. then I followed the steps to enable grub and it worked but when I select windows I got a BSOD! (Bad system config error). I removed the linux partitions and grub and now windows and followed solution guides online that involved the windows USB recovery and I followed all the steps but bootrec /fixboot says access it denied. Then I restarted and now it will boot into automatic repair instead of BSOD(it still won't start.) It says in the Srt logs that bootres.dll is corrupt... and I tried all the solutions online on how to repair it but nothing worked. Something I noticed is that I don't think I have a system reserve partition? At least not something that is 100mb. I can post any more info that would be helpful. I am looking to 1.boot into windows and then 2.re-apply dual boot.
Thank you!

We cannot help you with Windows trouble shooting.

The guide has been used in 100's dual boot installations - The guide never touches any Windows files and settings - which is why it is created the way it is - to avoid touching Windows files and the Windows file system.

Clearly you must have deviated from the guide at some point.

  • Boot a live Manjaro and backup your personal stuff to another external media.
  • The only viable option you have is to install Manjaro - and install Windows as VirtualBox VM

I can only think of one deviation - I accidentally shrunk my windows partition for use with manjaro using manjaro's installer (the dualboot option) instead of windows. When manjaro finished installing, it didn't even show up in the list of partitions (that's when I was booted directly to windows) but did after I cleared some system cache files and rebooted. Could this have messed with windows' boot?

And that could be your issue.

I messed up big time... turns out I had secure boot on this whole time. Any way to fix this mess without reinstalling os now that secure boot is off?

Okay. Good that you had identified, recognized and acknowledged that.
Takes a strong character to do that (uncommon nowadays).

You can try to boot to Manjaro (in UEFI) using the [More Complicated Setup] method and when booted bsides doing the grub-install and update-grub, don't forget to do the 2 [Additional UEFI commands]. It is important you do this.

Good luck.

ps: of course, always set your bios with secureboot off and uefi always on.
And fastboot (hiberfile) off in windows.

Ha ha... dll file missing. Good one, I'd forgotten about all those fun Windows errors. :rofl:

Ah.....schadenfreude.
I'm going to look out for more from you when secure boot fails.

Oh, I forgot - you only have one OS (one at a time). OS-monogamy!! :rofl:
My turn to have a schadenfreude moment. Hor! Hor! Hor!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by