Cannot Connect to Internet

Hello. Yesterday I installed Manjaro KDE (I don’t know what version to post so I’ll post them all:[KDE Plasma: 5.17.4 ; KDE Frameworks: 5.65.0 ; Qt: 5.14.0 ; Kernel: 5.4.6-2-MANJARO ; OS: 64-bit]) on my mid 2012 MacBook Pro (dual boot). I have not been able to connect to the internet. It tried and says deactivated then: “Wireless Interface (wlp2s0b1) IP configuration of was unavailable.” Yesterday if I typed systemctl restart NetworkManager.service it finally would connect. Today, however nothing is working. I have searched these forums for a fix, and I can’t find anything to help me. How would I go about connecting to the internet?

inxi -Fxxxza --no-host
So people can see the exact hardware.
Here's some light reading in the meantime.

1 Like

I have Broadcom and subsidiaries NetXtreme BCM433 802.11/a/b/g/n

1 Like

Post your specs when requested or expect little help.

That is the incorrect identification of your adapter,

1 Like

I have MacBook Air from 2013 maybe it has the same chip.
Do in terminal

pacman -S linux54-broadcom-wl


I think I have come to the conclusion that the issue is my network itself. I was on a friend’s wifi today and it worked perfectly, but my own network does not. It works on MacOS but not Manjaro. I think if other networks work though, the drive isn’t the problem.

Have you rebooted your router. Be sure there is no MAC or IP address filtering in your router blocking a connection.

If you control the router, reset your router to the factory default. Also be sure the routers firmware is up to date.

I would also suggest you disable MAC Address randomization. Search the forum for directions.

Your system specifications have been requested twice already and you have not posted the command outputs. I don't have the patience to help uncooperative users, so you're on your own from here.

Good luck resolving your issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by