Cannot Connect to Public (passwordless) Wifi Networks

Hey there! I'm new to Manjaro and loving it but I've hit a little hiccup. Whenever I use my laptop in public and try to connect to a wifi network that does not have a password, it doesn't work. I get to "Setting network address" before it just quits.

I could be a driver issue but I doubt it because I have not had problems connecting to wifi networks that have passwords. Which leads me to think it's a security setting that I don't know about. I've tried increasing the timeout time, multiple public passwordless wifi network (3 to be precise), and digging through all the network settings I could find.

If someone knows what's happening here and/or knows how to fix it that would be helpful. I would also appreciate information on how to, try to connect in the terminal so I can see what's happening in more depth and possibly find the problem that way.

Basic System Info:
Kernel: 4.14.48-2-MANJARO x86_64
bits: 64
compiler: gcc v: 8.1.1
Desktop: KDE Plasma 5.12.5
tk: Qt 5.11.0
Distro: Manjaro Linux 17.1.10 Hakoila

Network Cards:
Card-1: Intel Ethernet Connection I217-LM
driver: e1000e
v: 3.2.6-k
Card-2: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter
driver: wl
v: kernel

If you open a terminal, run

journalctl -f -u NetworkManager

then connect to the wifi network if will tell you what's going on behind the scenes.

Copy and paste that as text here so we can see too.


You'll also want to update then reboot your system to make sure this has not already been fixed by a package update.

Thanks for the advice Jonathon. I tried logging the output and it became clear that it kept hitting the timeout no matter how high I set the timeout configuration (I went up to 5 minutes). I'm going to see if going up in time helps however it doesn't seem to make a difference so I'm not hopeful on that front.

Since I got home and connected to wifi I upgraded my kernel and ran a package update. I'm hopping something in there solved this problem but I haven't had the chance to test it out and probably won't until tomorrow or Friday. The network manager version number changed so if it's a bug it might have been fixed.

If that didn't change anything I'm not really sure what the next step should be I've been reading the man pages for the NetworkManager and there's lots of configuration settings I could mess around so I might try that.

Now running :
Kernel : x86_64 Linux 4.17.0-2-MANJARO
NetworkManager : 1.10.10-1, Arch Linux

Here's the latest log before I ran an update :

NetworkManager --debug
<info>  [1530720148.9636] NetworkManager (version 1.10.8-1, Arch Linux) is starting... (after a restart)
<info>  [1530720148.9637] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity.conf) (etc: network.conf)
<info>  [1530720148.9680] manager[0x5597620df080]: monitoring kernel firmware directory '/usr/lib/firmware'.
<info>  [1530720149.2104] hostname: hostname: using hostnamed
<info>  [1530720149.2104] hostname: hostname changed from (none) to "Marsha-P-Johnson"
<info>  [1530720149.2106] dns-mgr[0x5597620f9930]: init: dns=default, rc-manager=symlink
<info>  [1530720149.2118] rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.2/0000:03:00.0/ieee80211/phy0/rfkill1) (driver wl)
<info>  [1530720149.2120] rfkill3: found WiFi radio killswitch (at /sys/devices/platform/dell-laptop/rfkill/rfkill3) (platform driver dell-laptop)
<info>  [1530720149.2272] manager[0x5597620df080]: rfkill: WiFi hardware radio set enabled
<info>  [1530720149.2272] manager[0x5597620df080]: rfkill: WWAN hardware radio set enabled
<info>  [1530720149.2297] settings: loaded plugin keyfile: (c) 2007 - 2016 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
<info>  [1530720149.2299] settings: loaded plugin iBFT: (c) 2014 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list. (/usr/lib/NetworkManager/libnm-settings-plugin-ibft.so)
<info>  [1530720149.2381] keyfile: new connection /etc/NetworkManager/system-connections/Algiers (472513c3-47e1-4921-b250-17c337373816,"Algiers")
<info>  [1530720149.2449] keyfile: new connection /etc/NetworkManager/system-connections/AlleyCat (a01d385d-ee56-4710-ae25-ea6570a961fc,"AlleyCat")
<info>  [1530720149.2516] keyfile: new connection /etc/NetworkManager/system-connections/GRAHAM31_5 (51f9c225-4ff4-427f-859f-c428c90b30cf,"GRAHAM31_5")
<info>  [1530720149.2581] keyfile: new connection /etc/NetworkManager/system-connections/GRAHAM31 (3e3e8e62-e00b-4063-ae96-a1f113df2512,"GRAHAM31")
<info>  [1530720149.2595] manager: rfkill: WiFi enabled by radio killswitch; enabled by state file
<info>  [1530720149.2595] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
<info>  [1530720149.2596] manager: Networking is enabled by state file
<info>  [1530720149.2597] dhcp-init: Using DHCP client 'internal'
<info>  [1530720149.2597] Loaded device plugin: NMBondDeviceFactory (internal)
<info>  [1530720149.2597] Loaded device plugin: NMBridgeDeviceFactory (internal)
<info>  [1530720149.2598] Loaded device plugin: NMDummyDeviceFactory (internal)
<info>  [1530720149.2598] Loaded device plugin: NMEthernetDeviceFactory (internal)
<info>  [1530720149.2598] Loaded device plugin: NMInfinibandDeviceFactory (internal)
<info>  [1530720149.2598] Loaded device plugin: NMIPTunnelDeviceFactory (internal)
<info>  [1530720149.2598] Loaded device plugin: NMMacsecDeviceFactory (internal)
<info>  [1530720149.2599] Loaded device plugin: NMMacvlanDeviceFactory (internal)
<info>  [1530720149.2599] Loaded device plugin: NMPppDeviceFactory (internal)
<info>  [1530720149.2599] Loaded device plugin: NMTunDeviceFactory (internal)
<info>  [1530720149.2599] Loaded device plugin: NMVethDeviceFactory (internal)
<info>  [1530720149.2600] Loaded device plugin: NMVlanDeviceFactory (internal)
<info>  [1530720149.2600] Loaded device plugin: NMVxlanDeviceFactory (internal)
<info>  [1530720149.2610] Loaded device plugin: NMWwanFactory (/usr/lib/NetworkManager/libnm-device-plugin-wwan.so)
<info>  [1530720149.2611] Loaded device plugin: NMWifiFactory (/usr/lib/NetworkManager/libnm-device-plugin-wifi.so)
<info>  [1530720149.2644] Loaded device plugin: NMTeamFactory (/usr/lib/NetworkManager/libnm-device-plugin-team.so)
<info>  [1530720149.2646] Loaded device plugin: NMOvsFactory (/usr/lib/NetworkManager/libnm-device-plugin-ovs.so)
<info>  [1530720149.2649] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/libnm-device-plugin-bluetooth.so)
<info>  [1530720149.2652] Loaded device plugin: NMAtmManager (/usr/lib/NetworkManager/libnm-device-plugin-adsl.so)
<info>  [1530720149.2658] device (lo): carrier: link connected
<info>  [1530720149.2662] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
<info>  [1530720149.2670] manager: (eno1): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
<info>  [1530720149.2679] keyfile: add connection in-memory (71ceed48-9a3f-361f-9f3d-26043deeddcb,"Wired connection 1")
<info>  [1530720149.2683] settings: (eno1): created default wired connection 'Wired connection 1'
<info>  [1530720149.2691] device (eno1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
<info>  [1530720149.2702] wifi-nl80211: (wlp3s0): using nl80211 for WiFi device control
<info>  [1530720149.2712] manager: (wlp3s0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
<info>  [1530720149.2720] device (wlp3s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
<info>  [1530720149.2727] device (wlp3s0): set-hw-addr: set MAC address to 96:90:22:B2:76:10 (scanning)
<info>  [1530720149.2751] ovsdb: Could not connect: No such file or directory
<info>  [1530720149.2771] bluez: use BlueZ version 5
<info>  [1530720149.2773] modem-manager: ModemManager available
<info>  [1530720149.2779] supplicant: wpa_supplicant running
<info>  [1530720149.2779] device (wlp3s0): supplicant interface state: init -> starting
<info>  [1530720149.2789] bluez5: NAP: added interface D0:53:49:D7:AE:02
<info>  [1530720149.3367] sup-iface[0x559762090970,wlp3s0]: supports 1 scan SSIDs
<info>  [1530720149.3373] device (wlp3s0): supplicant interface state: starting -> ready
<info>  [1530720149.3374] device (wlp3s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
<info>  [1530720155.1946] device (wlp3s0): Activation: starting connection 'AlleyCat' (a01d385d-ee56-4710-ae25-ea6570a961fc)
<info>  [1530720155.1947] audit: op="connection-activate" uuid="a01d385d-ee56-4710-ae25-ea6570a961fc" name="AlleyCat" pid=1048 uid=1000 result="success"
<info>  [1530720155.1951] device (wlp3s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
<info>  [1530720155.1953] manager: NetworkManager state is now CONNECTING
<info>  [1530720155.1961] device (wlp3s0): set-hw-addr: reset MAC address to D0:53:49:D7:AE:01 (preserve)
<info>  [1530720155.2076] device (wlp3s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
<info>  [1530720155.2078] device (wlp3s0): Activation: (wifi) connection 'AlleyCat' requires no security.  No secrets needed.
<info>  [1530720155.2079] Config: added 'ssid' value 'AlleyCat'
<info>  [1530720155.2079] Config: added 'scan_ssid' value '1'
<info>  [1530720155.2079] Config: added 'bgscan' value 'simple:30:-80:86400'
<info>  [1530720155.2079] Config: added 'key_mgmt' value 'NONE'
<info>  [1530720155.2372] device (wlp3s0): supplicant interface state: ready -> disconnected
<info>  [1530720155.2379] device (wlp3s0): supplicant interface state: disconnected -> inactive
<info>  [1530720155.2435] device (wlp3s0): supplicant interface state: inactive -> scanning
<info>  [1530720159.4581] device (wlp3s0): supplicant interface state: scanning -> associating
<info>  [1530720159.5385] device (wlp3s0): supplicant interface state: associating -> completed
<info>  [1530720159.5386] device (wlp3s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'AlleyCat'.
<info>  [1530720159.5396] device (wlp3s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
<info>  [1530720159.5401] dhcp4 (wlp3s0): activation: beginning transaction (timeout in 300 seconds)
<warn>  [1530720459.6508] dhcp4 (wlp3s0): request timed out
<info>  [1530720459.6510] dhcp4 (wlp3s0): state changed unknown -> timeout
<info>  [1530720459.6829] dhcp4 (wlp3s0): canceled DHCP transaction
<info>  [1530720459.6830] dhcp4 (wlp3s0): state changed timeout -> done
<info>  [1530720459.6834] device (wlp3s0): state change: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')
<info>  [1530720459.6837] manager: NetworkManager state is now DISCONNECTED
<info>  [1530720459.6838] manager: startup complete
<warn>  [1530720459.6843] device (wlp3s0): Activation: failed for connection 'AlleyCat'
<info>  [1530720459.6852] device (wlp3s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
<info>  [1530720459.6875] device (wlp3s0): set-hw-addr: set MAC address to CA:8D:83:8D:27:D5 (scanning)
<warn>  [1530720459.6888] sup-iface[0x559762090970,wlp3s0]: connection disconnected (reason -3)
<info>  [1530720459.6890] device (wlp3s0): supplicant interface state: completed -> disconnected
^C<info>  [1530720619.6174] caught SIGINT, shutting down normally.
<info>  [1530720619.6209] device (wlp3s0): state change: disconnected -> unmanaged (reason 'unmanaged', sys-iface-state: 'managed')
<info>  [1530720619.6212] device (wlp3s0): set-hw-addr: reset MAC address to D0:53:49:D7:AE:01 (unmanage)
<info>  [1530720619.6345] exiting (success)

This may not be a Manjaro configuration issue, but rather a limitation with the way the public portal is set up.

https://medium.com/@iospadov/the-problem-with-connecting-to-public-wifi-on-linux-20cebc740c6a

There are some fixes listed here. Unfortunately they are Ubuntu/Gnome centric.

https://askubuntu.com/questions/826998/cannot-log-in-to-public-open-wifi-connection

More fixes:

https://en.opensuse.org/SDB:WiFi

Disable MAC Address randomization.

This is still behind the latest available packages in the stable branch:

The current version of the 4.17 series is 4.17.3. Make sure you fully update your system:

sudo pacman-mirrors -f3
sudo pacman -Syyu

Also,

is also worth trying.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by