Cannot dual boot with Windows 7

In my BIOS I have a section on which I can see all connected SATA devices, and there I can see all my drives. But it doesn't show up as bootable in the boot section.

I realized something when I tried to access my 2TB drive (no OS, just storage) that I can't. I can only access the 2TB drive and the 1TB (with the OS) when I mount it (I also have to "log in" with my password). Does the fact, that I can't boot in it, has something to do with it?

Your BIOS is smart then. Maybe gohlip is right, the bootloader might be gone. What other commands did you run? update-grub won't do that by itself.

You might just need to reconnect everything like it was before and run the Windows 7 recovery disk (startup repair option). It'll install the bootloader again.

That's normal. Unless you manually add fstab entries for your windows partitions, they won't auto-mount on boot. Search the forum on how to do this. There's been a lot of threads on it lately.

1 Like

I really just ran update-grub. Should I plug out the drive with Manjaro while using the recovery disc? Do I have to change the boot drive in the BIOS after this every time I want to boot into Manjaro? Because as I know, it's not possible to boot with the windows bootloader into Manjaro.

And here the situation in my BIOS I mentioned
IMG_20180824_154444-min IMG_20180824_154507-min

Try this
in grub menu, press 'c' enter command line.
use ls as said above, and find where win7 is located. I think it's (hd2,msdos1), you can ls (hd2,msdos1) see its size. EDIT: should be (hd2,msdos1)
then input

set root=(hd2,msdos1)
chainloader +1

Doesn't work. It says that BOOTMGR is missing.

Sure that I have to run

set root=(hd1,msdos1)

and not

set root=(hd2,msdos1)

because you said it's (hd2,msdos1)
(just wondering and want to be sure)

I'm wrong. you should use ls (hd2,msdos1) to see its size. (hd1,msdos1) should be 2TB, and (hd2,msdos1) should be 1TB, where win7 located.

It also says that BOOTMGR is missing.

last try
first you should make a liveUSB of linux for rescue

boot into linux, open GParted, choose that partition of win7 (should be /dev/sdc, see it's 1TB size), right click choose manage flags, and tick boot, then reboot
I used this way to boot into win7 ago.

1 Like

Do you mean with that I should make a backup of my Linux installation or simply booting into a liveUSB with linux? (If so, I can use the stick which I used to install Manjaro, right?)

They both work, just need GParted.
Yes, and keep that USB and its content. You need change the boot flag back later.

1 Like

I still did not get the info (if posted):
Did you check visually in Linux File Manager for Win Bootloader existence in your Win drive/partition?
If it's missing then you may only try restoring via WinOS methods.
If it exists, then you should do alterations on the drive cables.

1 Like

Didn't work, let me boot into grub again where I can't choose Windows 7.

That's a good idea. As far as I know there should be a bootmgr file in C:\ but it's missing.
Would it be safe for my Linux installation to boot into Windows Recovery and make a Startup Repair? Would it then override grub and if so, have I to manually select the Linux SSD in my BIOS in order to boot into Linux again? I just want to be sure.

I dual boot with win7 too. My choice is install EasyBCD in win7 and let windows manage boot. It will enter boot menu twice (windows then grub), but you can do anything to linux part (just not install grub to win7 partition).
I also installed linux before that overwrite MBR, but I only have one disk, and what methods I said above let me boot into win7. Maybe multiple disk have different issues.

Haven't used a recovery disc, but I think if you choose the right HDD to repair, it should not touch file in SSD. And as default, your SSD should advance HDD in boot order, if you haven't changed that.

1 Like

Since you are already plug-unplug drive cables, leave Win drive only plugged in and boot to a Win recovery disk. Repair and reboot to check it works. Then Connect all drives and boot to Manjaro and update grub.

1 Like

It doesn't work. : (
I've created a bootable USB-drive with the Windows 7 Recovery Environment (Because I don't find my CD anymore) and it again says that BOOTMGR is missing so I can't even launch to the Recovery Environment.

So, it works now. Big thanks to all of you! I burned the recovery image to a CD and it repaired it. I installed EasyBCD like dorma recommended. So I can now boot into Manjaro and Windows 7. I'm so grateful for your support. :slight_smile:

1 Like

I changed the solution post to @gohlip, since he figured it out 1st (and possibly I wouldn't think of it :stuck_out_tongue: , I am still learning)

We would recommend that you use grub and you can get it back this way.
But you can use EasyBCD as suggested by Dorma and it is entirely up to you.

Oh, I said (earlier) that nothing you said here could have done anything to your bootmgr file in windows. In fact, linux cannot do anything to it. Can you think why this bootmgr has disappeared? If you cannot (think of anything), there is a common windows virus that does this (remove bootmgr). You might want to check with your antivirus program.

1 Like

I really have no clue why this file disappeared, I've done nothing and it never happened before. The day before I installed Linux, I used Windows like every time. The next day I plugged in my new SSD and installed Manjaro via liveUSB and ran sudo update-grub. And then I noticed that something is wrong because it didn't work.
Anyways, I ran sudo update-grub again and now it works perfectly and I can boot into Manjaro and Windows.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by